Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Compaq C700 laptop: No bootable device

27 Jul 2010   #1

Windows 7
Compaq C700 laptop: No bootable device

I have a Compaq Presario C700 which is giving me the following error:
No bootable device -- insert boot disk and press any key.

I'm a technical user and have been able to fix just about anything, until now. I've done some research, and I've found that this Compaq C700 is a terrible computer that just can't be fixed. They're probably right.

I've tried to boot off an external optical drive, but this failed to load the system. I've checked the boot order is correct and that the optical drive was enabled in the BIOS, but this still did not allow me to boot from the optical drive. I knew that it recognized a system there because it had an underscore, which meant it was trying to boot from the disk, but sadly, no luck.

As for the hard drive, I've replaced it with a spare, couldn't install Win7 on it directly from the laptop, so I installed it on my desktop system, then put it back in. Still, the message. No bootable device -- insert boot disk and press any key.

I've verified every available BIOS setting to the last detail. The only thing I could think of and haven't yet tried is to try to see if there's a CMOS battery anywhere and disconnect that, but I'm not sure where that could be on a laptop, and taking this thing apart is practically impossible.

I know the CPU and system board and everything else seems to be in working order, it's just that it can't seem to work off of a Windows 7 disc or installation. A red flag for me was when I went into the BIOS (InsydeH20) it mentioned that Vista was the factory installed OS. I wonder if it's doing this because it's expecting, and is proprietary to, Vista.

Sigh. Anyone out there with any ideas?

My System SpecsSystem Spec
27 Jul 2010   #2

windows 7

Try Load defaults os load factory settings in bios...
My System SpecsSystem Spec
27 Jul 2010   #3

Windows 7

Yeah, I tried that too. I don't think the BIOS 'supports' Windows 7, if that's possible.

Maybe I'll have to load up a BIOS program on a USB flash drive and see if I can load a new BIOS in?

Or maybe I can get my hands on a copy of Vista...
My System SpecsSystem Spec


 Compaq C700 laptop: No bootable device

Thread Tools

Similar help and support threads
Thread Forum
Reinstallation causing No bootable device, Acer Laptop
I have just reinstalled the OS on 2 of my computers but am having a very difficult time with my old acer laptop. I have already read many guides and spent many hours trying to resolve this. I really don't know much and should have taken some notes before but felt over confident. There doesn't...
Installation & Setup
factory restore on compaq c700?
pressing f11 on startup is not working. this had vista on it but i've installed windows 7. so the f11 don't seem to work? how do I do a factory restore on this? any ideas? thanks. :)
Installation & Setup
Hard Drive Disk is not detected in laptop - No bootable Device Found
Hi, My friend's laptop (Acer Aspire One 722 - Windows 7 x64) has been shut down after opening an email and Windows never started up again. When you attempt to start up the windows, it stays the black screen and says "No bootable Device Found"! 1- I inserted Windows Live Disk and loaded it...
Hardware & Devices
Compaq presario c700 restarts after the "starting windows" appeared
I'm doing a clean format to Compaq presario c700. It restarts after the "starting windows" appeared while installing windows 7 ultimate. before restarting a black screen and a mouse cursor appears briefly and it will restart... What will I do to resolve my problem??? and the laptop has no OS,...
Installation & Setup
Unknown Device - Compaq 6735s Laptop
Hoping somebody can help, I have installed W7 onto my HP/Compaq 6735s and picked up all the drivers except one "Unknown Device". I have downloaded all drivers from HP and tried to install them all, however the unknown device still remains, any ideas? Much appreciated

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:52.
Twitter Facebook Google+