Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Explorer.exe server execution failed

10 Sep 2011   #31

Windows 7 Professional 6.1.7601 SP1 Build 7601
Revived Thread

I keep the My Documents folder on an external drive. When I reattached it, the error went away.
If you've recently changed hardware, settings, or unplugged a drive, it may help to temporarily undo that change until you configure your system to live without it.

My System SpecsSystem Spec
21 Sep 2011   #32

7 home, 64 bit

Thanks for this thread!
I had installed an extra drive and wanted to plug in an external drive to copy some files to a thumb drive, and the "my computer" icon on the desktop would not want to open anymore.

Standard I have a 128GB SSD, and 1TB HD installed, but this time I added 2x 1TB drives, one external via USB, the other internal via SATA, and a 8GB microSD Card, and that seemed enough to make me lose two freakin hours of my time trying to figure out what the problem is. My AV scanner found no virusses, so I thought it it must have been a win bug!

Regedit did not solve my problem, but like one user said, just change admin privileges.
The problem is I could not open control panel, and neither user accounts.
I had to change from admin to standard user by selecting searching for 'user' in the taskbar and selecting 'create or remove user accounts' because the standard icon 'User Accounts' did not work!

Changing from admin to standard back to admin solved my probs! Thanks guys!
My System SpecsSystem Spec
21 Aug 2013   #33

Windows 7 64-bit

If you have the same problem listed in this thread, and there is no problem with your shell folders and mapped folders, there is another option that worked for me. I always check the box in FOLDER OPTIONS to always open folders in a separate process, but for some reason, this can be a problem if you get the server Execution Failed error, so try unchecking that box in Folder options and WAllah, It is really fixed finally.
My System SpecsSystem Spec

09 Mar 2014   #34

Windows 7 Pro and Enterprise x86 and x64

Quote   Quote: Originally Posted by gigaherz View Post
Hello people,

I just today had this same problem in my Windows 7 profile.
The solution is to go to regedit, and change 2 keys to point to valid places:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\Personal
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell  Folders\Personal
You can set back the defaults by looking at how the other entries in those keys look like.

I'm not enterely sure if the second one is necessary, but I changed both to point to valid places and it works now.
In my case both were required. I knew my documents were in another profile but I forgot I moved the folder to the current profile. Thanks for the fix. Don't bother deleting your old profiles people. Too much unnecessary work.
My System SpecsSystem Spec
13 May 2014   #35

Windows 7 Ultimate 64 bit
Fixed by restoring drive letter assignment

First of all, THANKS TO EVERYONE who posted in this thread, as it illustrated through various examples that the problem was a missing drive (or, as it turned out in my case, a drive re-mapped from its previous letter assignment), when directories tied to a given user account are involved in one of the partitions on that drive.

I was checking old drives as well as one that seemed to have gone bad on my son's notebook. I connected that one to a serial interface, and an older parallel drive on the only parallel interface on the board, which means it was on the same cable as my "D:" drive, DATA, on which documents, etc., from my user profile are stored.

I usually test on a USB-to-ATA/ATAPI adapter cable, but there were issues with these two drives and I've discovered that sometimes you can fix problems by a normal drive connection, rather than through the USB adapters.

When I rebooted after adding the drives and went to look at them I got the explorer.exe server execution failed error.

To summarize what happened, my computer had assigned the letter "D" to one of the two partitions on the notebook drive. I had done this before (attaching drives to check them) without the computer changing drive letter assignments, just giving them new ones after all the other drives. I was able to fix it by reassigning the letter "D" through the Disk Management section of the Computer Management program.

Now a detailed account. I searched the error and saw the posts about making the administrator account active, so I did that.

I saw the posts about it being a missing drive and thought perhaps my "D" drive had become inaccessible because of the old parallel drive having a problem.

I shut the computer down, removed the added parallel drive, and rebooted but still had the error. So I tried to access the storage section on Computer Management, but could not find computer management by searching for it.

Rebooted into administrator, went into Explorer, saw the "Restore" partition from the notebook drive had been assigned the letter "D:" and my DATA drive was now I:, after other drives.

So I turned off the computer, disconnected the laptop drive, rebooted into my user account, but still had the server execution failed error.

I went to computer management but I had no "run as administrator" option on the right click menu. Ran it anyways, went to drive management, saw that there was no D: drive, and tried to change the letter on DATA back to D: but it did not offer me that choice.

So I rebooted into administrator, went to computer management, did have the run as administrator option, did that, went to drives, and it did show the option to assign D: to the DATA drive.

Rebooted into my user account and everything is working normally.

I've yet to test whether it was something on the notebook drive that forced the use of D: for the restore partition or if there was a problem with my old drive on the parallel interface that made the computer not see my "D" drive and thus it assigned the now-empty letter "D:" to the first partition on the notebook drive.

Before doing that, am going to create a new account for testing, because I think if the problem of letter bumping recurs it will be easier to fix on a user account where nothing is mapped to "D, avoiding (I hope) the "server execution failed" error if it happens.
My System SpecsSystem Spec
18 Jul 2014   #36


Just wanted to add this for a possible solution:

It worked for me. :)
My System SpecsSystem Spec
28 Apr 2015   #37

Windows 7 Ultimate x64

The MS fix definitely works! I had exactly the same problem when turned off Libraries feature using method described at this forum. Disabling opening Explorer windows in separate processes has helped.
My System SpecsSystem Spec
16 Oct 2015   #38

Win7 Home Premium x64

(More information)

I know this is an ancient post, but just I had this same problem and none of the "solutions" below worked. I found the solution myself:

I didn't realize, but earlier in the day, I had tried to edit my "Send To" list by typing "." (period) from the Run menu to delete unwanted destinations. I must have tried to delete the "My Computer" folder because when I checked "C:\Users\{profile}\", "My Computer" was missing. (If you can't open the File Explorer, use the "File" menu from almost any app to look for it.)

Fortunately, I already had another account with Admin privileges (everyone should, even if you're the only user, in case of disasters like this), copied the "C:\Users\{current profile}\My Computer" folder to the profile that was missing it, rebooted, and now everything is back to normal.

If you don't already have another User Account, create an empty "Read Only" folder in your "C:\Users\{profile}\" called "My Computer" and reboot. I didn't try it myself but it may work.

If that doesn't work, "Windows Repair" from the DVD may be your only option.

Hope this helps someone.
My System SpecsSystem Spec
23 Aug 2016   #39

Win 7 64 bit

Awesome worked beautifully for me. Thanks so much. I noticed my documents and others were pointing to the wrong drive. Once I corrected this after backing up the registry of course, it worked beautifully. Don't forget to backup the registry when working in it. Mistakes are made.
My System SpecsSystem Spec

 Explorer.exe server execution failed

Thread Tools

Similar help and support threads
Thread Forum
Server execution failed
Error (Server execution failed)started happening out of nowhere when I try to use Media Player. No new hardware or software. No Registry changes.
Music, Pictures & Video
Server execution failed
I get this message sometimes when I click on a desktop folder, it comes up with the path c:\Users\Mike\Desktop\System Utilities (which is the folder I am trying to open when fault showed). It can happen when I try to open any desktop folder. The odd thing is (to me!) is that I had this fault...
General Discussion
Explorer.exe server execution failed (Tried mostly everything)
So after rebooting after a virus scan, I keep getting the message "Explorer.exe server execution failed" whenever I try to open a document, game, internet browser, etc. I've tried everything I could find, and I still can't solve the problem. Any help would be greatly appreciated.
General Discussion
Server Execution failed
I solved the date problem but now I have another problem. I was transferring files from my pendrive. After that, I tried to gain access to My Computer but then out of a sudden, i can't open My Computer and The Control Panel as well as Music, Pictures etc on the Start Menu. When I click My...
General Discussion
Server Execution Failed
Does anybody know what is causing this error: I restarted Prometheus this morning to allow some updates to be installed, and when I got home from work this afternoon, I get the message "Server Execution Failed" with anything that uses "explorer.exe" (Computer, Control Panel, Libraries,...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:26.
Twitter Facebook Google+