Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 100% CPU Issue

22 Aug 2010   #1

Win7 Home Premium x64 SP1, Archlinux x86_64. Elementary Luna
100% CPU Issue

Can anyone tell me in the services if uPnP Device Host is supposed to be set to Manual or Automatically. Because that service seems to be the reason behind my svchost
spiking high..When i disable or put it's state on Manual then restart all is fine.

I've downloaded a i guess a default service config for Win7 Premium x64 from BlackViper site.. and as i said it set the uPnP service to manual, restarted and i have no problems.

Guess i just wanna know what it should be set as and be started.

EDIT: To Clarify for other people that might have the issue, My CPU only spiked to 100% when connected to the internet, disconnect i had no problems (this is all when uPnP Device Host was set to automatically under services.)

so you might wanna check that also if you have this issue and set it to manual.

My System SpecsSystem Spec
22 Aug 2010   #2

Windows 7 Ultimate x64 SP1

Mine is set to Manual, and is in a stopped state. Default.
My System SpecsSystem Spec
22 Aug 2010   #3

Windows 7 Professional SP1 64-bit

If it's set to manual, it should start when it is needed, but I would wait for second opinions.

EDIT: mine is also already set to manual. I did not change it at anytime.
My System SpecsSystem Spec

22 Aug 2010   #4
Microsoft MVP

Windows 7 Ultimate 32bit SP1

Manual - stopped :)
My System SpecsSystem Spec
22 Aug 2010   #5

Win7 Home Premium x64 SP1, Archlinux x86_64. Elementary Luna

Alright thanks guys. What a load off my mind.
My System SpecsSystem Spec
22 Aug 2010   #6

Win7 Home Premium x64 SP1, Archlinux x86_64. Elementary Luna

Edited for people that might have same problem.
My System SpecsSystem Spec
23 Aug 2010   #7

Win7 Home Premium x64 SP1, Archlinux x86_64. Elementary Luna

Another Update:

Okay, so the problem came back after a restart..(took awhile because i always put it to sleep) now after some tests, i think i've finally fixed it (this time) see i use dial-up it's a USB Modem and i thought thats what made the uPnP Device Host service start so thats still set to manual and not started (default).

Now the other issue comes in when ICS - Internet Connection Sharing is started.. When this service is started so is the uPnP Service. So i set both services to manual and still being able to connect with my USB Modem to the net.

i'm pretty sure noone uses ICS anyway but the only thing i use it for is the Xbox 360 to receive Updates/Game updates...soooo for now problem is solved(finally)

EDIT: This time i've downloaded the "safe" config for the services merged them in the registry making everything good. now i can use ICS and connect with xbox 360
My System SpecsSystem Spec
23 Aug 2010   #8

Windows 7 Home Premium 64bit

Just curious, was it always like this or what started it?

System tweaks and turning off/disbaling services to "improve" performance?
My System SpecsSystem Spec
23 Aug 2010   #9

Win7 Home Premium x64 SP1, Archlinux x86_64. Elementary Luna

I'm guessing it was a tweak program i tried that swapped around services to different states (Another reason to stay away from these things) this is probably the most obvious reason people have this issue i just had.

But adding the safe config services reg file from the blackviper site seem to def. fix my problems.
My System SpecsSystem Spec

 100% CPU Issue

Thread Tools

Similar help and support threads
Thread Forum
Boot issue, 0xc0000098 ci.DLL file issue
OK so I hope this can be a quick fix and thanks for your help. * Randomly computer didn't start, get something telling me that the ci.dll file is missing or corrupt and error 0xc0000098 * safe mode and last know good configuration both result in bsod * Tried a few things, disconnect all...
BSOD Help and Support
net start command line issue - 64bit issue?
I am trying (in vain) to issue a net start command "net start - "C:\Program Files (x86)\uTorrent\utorrent.exe", on the command line. The error message is "the filename, directory name or volume label syntax is incorrect". I believe the 3 details are correct, as i am looking at the utorrent.exe file...
General Discussion
HP Multi Print/Scan Issue Re Install Issue?
I have an HP M1522 NF multi function peripheral attached to a PC running Windows 7. I needed to re install the drivers and software the other day but now it will only install the printer drivers and not the scanner drivers or any of the accompaying software?
Hardware & Devices
jpeg permission issue / possible encryption issue
Hello, I am new to the forums and have looked around just about everywhere I can think of for a similar topic and thus far have been unable to locate any help. If this has been previously covered, please point me in the direction and I will read up. So as for my issue.... I was running...
General Discussion
Interesting connectivity issue, just a browser issue
Opps, maybe not so unique since I just noticed an ENTIRE forum for browsers...perhaps moving this is appropriate...if so, please do. I will be reading up in there. Its interesting because I can't find any mention of it anywhere on this site. Specifically browser connectivity is lost after a...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:53.
Twitter Facebook Google+