Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: DLL not found

29 Aug 2010   #1

7 64-
DLL not found

For the past few weeks I've been getting a DLL not found error upon bootup --- NMPavce.dll.
This morning, after my wife installed Windows updates and rebooted, we immediately started getting a second DLL not found --- ejipicericoxepod.dll

I have searched everywhere I know, but cannot find anything on these. Anybody see them before or have an idea?


My System SpecsSystem Spec
29 Aug 2010   #2

Windows 7 Home Premium x64

Hi, and welcome to Seven Forums.

These two .dll files look "fishy", and the fact that a Google search produced nothing is concerning.

What program(s) did you instal prior to the first error message?
My System SpecsSystem Spec
29 Aug 2010   #3
Abhishek Ghosh

Windows 7 Ultimate 64 bit, Mac OS X 10.6

What antivirus you are using?

Do you have a system restore point set?
My System SpecsSystem Spec

29 Aug 2010   #4

7 64-

Thanks for the replies. I agree it looks fishy for the same reasons you gave.

I don't recall installing anything just prior to getting the first error msg. Using McAfee. I don't recall setting a restore point prior to the first msg either. This is a fairly new machine.

So far, nothing bad is happening to me, that I know of. I suspect that McAfee has disabled something bad, but left some residual evidence that shows up in the error messages.
My System SpecsSystem Spec
29 Aug 2010   #5
Abhishek Ghosh

Windows 7 Ultimate 64 bit, Mac OS X 10.6

Problem is that, I cant find this particular dll.

Wait for any others answer here. Then...

You are saying the PC is new, so, I think you can e-mail the tech guys of Microsoft directly, they are very helpful and asks if it was solved or can provide alternative. Here is the link.

Are you using Windows 7 that came per-installed (OEM) or bought the DVD separately (Retail Version) ?
My System SpecsSystem Spec
29 Aug 2010   #6

7 64-

Thanks for the help. Pre-installed 7. I'll wait a few days, then check out the M$ link.
My System SpecsSystem Spec
29 Aug 2010   #7
Microsoft MVP

Windows 7 Ultimate 32bit SP1

Both are an indication of malware.

Download Malwarebytes' Anti-Malware to your desktop
|MG| Malwarebytes Anti-Malware 1.46 Download
* Double-click mbam-setup.exe and follow the prompts to install the program.
* At the end, be sure a checkmark is placed next to Update Malwarebytes' Anti-Malware and Launch Malwarebytes' Anti-Malware, then click Finish.
* If an update is found, it will download and install the latest version.
* Once the program has loaded, select Perform full scan, then click Scan.
* When the scan is complete, click OK, then Show Results to view the results.
* Be sure that everything is checked, and click Remove Selected.

* When completed, a log will open in Notepad. Please save it to a convenient location. Copy and Paste that log into your next reply.
My System SpecsSystem Spec

 DLL not found

Thread Tools

Similar help and support threads
Thread Forum
HDD not found in Windows Installation but found in BIOS
So it's a long story. I hadn't had Microsoft Net Framework on, so I turned it on. Then my PC randomly crashed. Tried to reboot but it got stuck in the crash then reboot circle. I tried my hardest to fix it but I couldn't find anything to fix it so I decided to just, reinstall windows. I made...
Hardware & Devices
USB disc not found at boot but is found when restarted
Hello all, I've had this issue for quite some time now, it never really bothered me that much, but it is annoying, so I thought I'd give it a shot to see if anyone could help me out. I've got 2 external USB drives, one on 2 Gb and one on 4 Gb. the 2Gb drive is no issues at all. Works...
Hardware & Devices
Lost Pwr During Defrag - FOUND folder not found
Last night was using Auslogics to defrag an external WD 1.5TB BU drive... 2 hours in we had a power loss...lights and TV went out and came back on. The laptop that was running the Auslogics had a batt, but the external drive lost power in the middle of the defrag process. Turned everything off for...
Performance & Maintenance
operating system not found and no drivers were found eror
as usual I turned off my laptop and after a while a turned on again to use my laptop but it couldn't reach operating system and showed error : " OPERATING SYSTEM NOT FOUND" ! I tried all instructions to solve the problem and finally run by windows start up CD to re-install new windows. this...
Installation & Setup
Network drive found but not found?
Hi I'm having a problem that is causing me to pull my hair out. I hope someone can help. I'm using a Vernatim media share 1 tb network drive on my LAN to store things like my iTunes library. Well yesterday it started not allowing me to login through windows. I deleted the mapped share and tried to...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:01.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App