Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: no bootable device: f1 to retry...

07 Sep 2010   #1

Windows 7 Home Premium x64
no bootable device: f1 to retry...


I have a dell inspiron 1545 laptop which has just been clean installed
with Windows 7 x64. I get an intermittent error on boot up

No bootable devices: f1 to retry, f2 for setup

If I press f1 it continues normally and boots up.

This is not a major problem yet but is it a symptom of something worse
and/or is there a fix?

I had Vista x64 before and would get the same error occasionally.

I spoke to dell support and they said it was a s/w error and would not
help me fix it - they did refer me to the paid for s/w support

Thanks for any help.

My System SpecsSystem Spec
07 Sep 2010   #2


Set Win7 HD first to boot in BIOS setup.

If you need to boot CD/DVD using one-time BIOS Boot Menu key.

Do you have the latest BIOS version update?
My System SpecsSystem Spec
07 Sep 2010   #3

Windows 7 Home Premium x64

Thanks, I changed HDD to boot first.

I have BIOS update A14 which I think is the latest.

Hopefully it wont occur again.
My System SpecsSystem Spec

07 Sep 2010   #4


Let us know if it does.
My System SpecsSystem Spec
08 Sep 2010   #5

Windows 7 Home Premium x64

Unfortunately it is occurring again.

HDD is still first in the boot list.

I have run the F5 diagnostics no errors are reported.
My System SpecsSystem Spec
08 Sep 2010   #6


Back up your data externally now. Make your Recovery Disk set.

Boot the Win7 DVD Repair console or Repair CD by tapping F12 key at bootup to run Startup Repair which will run numerous tests and if necessary repair or rewrite the critical MBR boot files: Startup Repair

Run SFC /SCANNOW Command - System File Checker

Then test your HD using maker's full diag/repair CD scan:

Next run Disk Check

To be complete in testing hardware, Test RAM using memtest86 CD for 5-6 passes.
My System SpecsSystem Spec
08 Sep 2010   #7

Windows 7 Ultimate x64 SP1

It's either a BIOS error, or a problem with your hard drive not starting up in a timely manner. Either way, use your service tag on Dell's support site to check your BIOS level and download the diagnostics disc creator to test out your hard drive.
My System SpecsSystem Spec
08 Sep 2010   #8


Check your installed BIOS version by typing System Information in Start Search box.

Or audit it from mobo using Belarc Advisor.
My System SpecsSystem Spec
08 Sep 2010   #9

Windows 7 Home Premium x64

Thanks for the quick replies.

I ran scannow and it found no problems

I booted from the dvd into repair. The first thing it did was
claim an error starting up that it fixed. I restarted and ran
the startup repair again and it passed.

HD is Toshiba who dont provide diagnostics as far as I can see.

I will burn a dvd and run memtest in the next few days.

Bios is A14, 07/12/2009, I started out at Dells website with
the service tag to find what drivers I was missing.

My System SpecsSystem Spec
08 Sep 2010   #10


Does the Repair (likely MBR) fix the issue?

Are you able to run a full HD scan using the F5 tools?

If not, try GWScan which works on most all models: GWSCAN 5.12 Unzips to C:cabs where you can browse to find ISO to burn.

Please post back a screenshot of your full Disk Management drive map with listings, using Snipping Tool in Start Menu. Something might be obvious.

Also, google repeat errors in Device Manager>Admin View to see how others have resolved them. Study Performance log as well on Advanced Tools page accessed by clicking WEI score at Computer>Properties; check for cued issues at top of Tools page, Generate a System Health Report.
My System SpecsSystem Spec

 no bootable device: f1 to retry...

Thread Tools

Similar help and support threads
Thread Forum
No bootable device
while cleaning i accidentaly shut down my laptop,when i try to turn it on. The words check cable connection no bootable device--insert boot disk and press any key pops up,i don't have any boot disk in can anyone please help me fix this?if not can i restore factory this lg xnote r570...
Installation & Setup
No bootable device found-please enter a new boot device
Hi guys, im new here and i wish you can help me cuz im really stucked. I have a toshiba satellite L350, and it cant boot. Firstly there was just a blue screen and then it switched to a blaack screen and says no bootable device, please enter e now boot device. I knew my HDD was gone beause he...
Hardware & Devices
No bootable device
I have a PowerSpec computer purchased from MicroCenter two years ago. It's been a wonderful machine until about a week ago. It came from the factory with a 64gb SSD drive, which was becoming too small for my needs. We purchased a 256gb Crucial SSD several months ago and finally got around to...
Hardware & Devices
No Bootable device (HELP)
Hello people my laptop says no bootable device insert boot disk and press any key please help i dont have no disk i am one a Windows 7 64bit please help
BSOD Help and Support
no bootable device
when i turn on thers a blank screen saying f2 and f12,iv,e pressed both and nothing happens,just a other blank screen saying no bootable devices, i connected a external hard drive and put a windows disc in to try reinstall windows,but still nothing ,windows goes through the motions,and then says...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:38.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App