Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Trying to delete "Windows.old", driving me nuts!

09 Sep 2010   #1

Win7 Ulitmate x64
Trying to delete "Windows.old", driving me nuts!

Not sure which sub-forum to start this thread in, but it looks like this one's the closest. Before resorting to posting this note here, I did a fair bit of googling on the subject and learned that, apparently, I should be able to delete windows.old using the disk cleanup tool. Only problem is, it doesn't do the clean up as the directions describe. It deletes only a small handful of files from the main windows.old folder and leaves all subfolders intact and full of files.

The machine is a Gateway notebook I inherited from my daughter. It was a Vista machine until last week, when I upgraded to Win 7. Back when a major Vista service pack was d/l'd to this machine, it created a backup directory for Windows, called windows.old. I've tried off-and-on for months trying to delete it. It's taking up 11.4 gigs of drive space. I could use the space and I sure don't need this back up directory any more.

I've been through all the security settings regarding that folder, insuring that "administrators", of which I'm one -- or the only one, actually -- and even "administrator" (without the 's') has all necessary permissions in order to delete the folder.

I keep getting a couple of message pop-ups whenever I try to delete it. First is a message that the folder is shared and other people won't be able to access it if I delete it. Only thing is the folder isn't shared, although Windows Explorer shows it to be shared with "Administrator" -- which I figure must be me, right? This message pops up repeatedly during the so-called deletion process. The other message is that it requires admin approval to delete. I click on OK for that one, and soon another one pops up stating the same thing, but this time, instead of an "OK" button, there's a "Try Again" button, and no matter how many times I try again, I don't get anywhere.

So I went inside the folder and selected a couple of files at random. Right-clicked, then Properties, then Security, and set it up so I had all rights. But it didn't matter, I still was unable to delete a single file.

I was thinking the fact that this used to be my daughter's machine is part of the problem. She is not listed as a user anymore, but somehow her user profile was and in some way I don't understand, my user ID was associated with her user profile. This profile was initially preventing me from deleting the "windows.old" directory, even though my account has all administrator privileges. I was getting a pop-up telling me that it required permission from her user profile to delete the folder.

Since I wasn't able to delete my daughter's user profile (there were only two listed -- hers and "default"), I created a new user account, and then from that account I was able to delete her profile. Didn't do any good, though. I still get the same messages when trying to delete the folder, despite my being the administrator and having full control. Yeah, "full control," right. I got your "full control" right here . . .

At this point I feel like cussing and throwing things. Dammit, I just want to delete a folder and I'm the admin on this machine. I want to do anything I want or need to on my machine without having to put up with it telling me I can't! Grrrr . . .

Any ideas how I can delete this blankety-blank folder?

My System SpecsSystem Spec
09 Sep 2010   #2

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

Lets give this a try
Windows.old Folder - Delete
My System SpecsSystem Spec
10 Sep 2010   #3
Microsoft MVP

Vista and now 7 in 32 and 64 bit.

Use the built in "Disk cleanup". Make sure you have the option selected in the drop down boxes
My System SpecsSystem Spec

10 Sep 2010   #4

Windows 7 Ultimate x64, Mint 9

Wait, so if you right click on the folder and choose delete, it doesn't work?

My System SpecsSystem Spec

 Trying to delete "Windows.old", driving me nuts!

Thread Tools

Similar help and support threads
Thread Forum
Windows will not allow me to format drive C: this is driving me nuts!!
Hi all! I have aquired a new but secondhand net book from a friend, it was running so slow! i decided to reinstall windows but with there being no cdrom drive i had to rip it onto my friends pc and transfer it over to the netbook and use daemon tools to install it. i installed windows onto...
General Discussion
"Java Auto Updater" driving me crazy...?
Almost every day a flashing box appears wanting me to let Java update itself. I even went into the control panel, found Java and told it not to look for updates etc. It totally ignored me and still does it every day. "Java Auto Updater". Anyone got a solution that will help me tame this...
Does WLM "completely" delete email without "Compact Datadases"?
With XP's Outlook Express- When you'd delete email from their Folders, they weren't "completely deleted..." until you Compacted Databases & Reboot (without CD, OE would Not release from backup..., and Bloat...!). ~~~~ Q1?- I now use WLM 2009 POP3/only (I like 2009's GUI, Much better than...
Browsers & Mail
The lack of encoders for windows 7 is driving me nuts!
Ok I am getting at my wits end.. do anyone know a good, functioning encoder program for windows 7 64 bit versions? Windows media 9 encoder is not functioning and I have googled the world thin to find solutions as to why.. but aparently I must be the only guy in windows 7 who has even attempted...
"Item Not Found" is driving me nuts
Hi all! For some unknown reason, my 64-bit 7 gives "Item Not Found" dialog whenever I try to move/delete a folder or an archive. All I have to do is to click "Try Again" for the command to go through, but it's driving me insane. What's wrong with my 7? Sample dialog box in an attachment.
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:05.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App