Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Problem with the Diagnostics Policy Service + Internet

19 Sep 2010   #1

Windows 7 Home Premium
Problem with the Diagnostics Policy Service + Internet

Hello everyone,

This is my first post on this forum, regarding a problem my sister is having with her computer. I tried asking about it on the Microsoft Windows 7 forums but after over 200 views no one has yet responded. Below I've pasted what I posted on that forum:

Hello everyone,

I'm having a really annoying problem on my sister's laptop. It's an HP with Windows 7 Home Premium that's only about 3 months old. Approximately two weeks ago (if we remember correctly) her (wireless) internet stopped working even though it works perfectly fine on my less-than-a-year-old Toshiba Windows 7 Home Premium laptop (we have a router). Also, Comodo (the anti-virus program she uses) stopped working, saying something about it not being activated. When I'd try to activate it it wouldn't work/let me (I'm trying my best to remember exactly I did that day). When my sister asked me about the problem she said it first showed up a few days before. I tried to fix it that day but had no luck. Today, about a week later, a tried again but still can't find a solution. I'll start off with describing what I remember trying the first day I tried to fix it (approximately a week ago):

First, I clicked on the wireless internet icon on the taskbar (with the bars) and could see that the wireless network connection for my house had the bars all the way up and also that it said "Limited Access" for some reason next to the bars. Next, I right-clicked our wireless network and clicked on "Status" and then clicked on "Diagnose". It scanned for problems for a few seconds and then under "Problems found" stated that "The Diagnostics Policy Service is not running". I clicked on "Try these repairs as an administrator" but that didn't solve the problem.

Next, I tried searching on Google for the same problem, hoping to find a solution. I remember when running into threads in which people suggested restoring the computer to a date before the problem started and I tried to do that but (if I remember correctly) I couldn't set it to an early enough date, even when I checked the box "Show more restore points". After reading about/attempting various other solutions that day involving doing things that I didn't even necessarily understand I ultimately decided to just put the computer back to factory condition but during that process some strange error message would pop up (which, unfortunately, I don't remember).

Fast forward to today, where I tried once more to fix this problem.

I ran into this thread

Diagnostics Policy Service and internet drop

which gives links to two other threads with possible solutions. Here are the two threads:

Diagnostic Policy Service start, stops
SFC /SCANNOW Command - System File Checker

As far as the first thread goes, I tried this solution


1. Go to device manager.
2. Uninstall all the network devices including the network card.(Don't delete the driver)

3. Restarted the computer and it automatically found and installed the network card and the driver for it.
4. Wholla, the internet and associated groceries worked normally again... :)

but it didn't work. Next I went to the second thread I mentioned above and tried both "OPTION ONE" and "OPTION TWO", but still no results. I also tried another solution that didn't work but unfortunately I can't find the thread which describes the steps. I remember that it was something about third-party applications and disabling all the Microsoft programs that load at startup (I think) but that didn't do anything either.

Well that was the best description I could come up with of the problem and everything I've tried to do to resolve it. Does anyone have any ideas of what I should do?

My System SpecsSystem Spec
20 Sep 2010   #2

MS Windows 7 Ultimate SP1 64-bit

You did or you did not get the System File Checker (SFC) to run?

Also temporarily disable Comodo and see if your problems go away.
My System SpecsSystem Spec
22 Sep 2010   #3

Windows 7 Home Premium

I actually just ran SFC again just to be sure and once again it said "Windows Resource Protection did not find any integrity violations". I don't even have Comodo anymore and there's still problems.
Also, when I try to enable Windows Firewall a small window that states "Action Center can't turn on Windows Firewall. I then click on where it says "Turn on Windows Firewall manually" which opens up a window that says "Update your Firewall settings" with the words "Windows Firewall is not using the recommended settings to protect your computer" under. Next to it there's a button that says "Use recommended settings". When I click on it a small window pops up that says "Windows Firewall can't change some of your settings. Error code 0x8007042c"
My System SpecsSystem Spec

22 Sep 2010   #4

MS Windows 7 Ultimate SP1 64-bit

We need to make 100% certain that your system is clean.

do following which will take several hours. We will hear from you then.

1. Download MalwareBytes. Malwarebytes Malwarebytes
2. Disconnect from the Internet.
3. Disable your present antivirus software and firewall.
4. Remove your present antivirus software and firewall.
5. Install and run the MalwareBytes Quick Scan (remove any bad guys). 3min 29secs on my laptop.
6. Reconnect to Internet.
7. Update MalwareBytes.
8. Run malwarebytes quick scan again.(remove any bad guys). 3min 38secs on my laptop.
9. Run MalwareBytes full scan. 16min 8secs on my laptop. With large,full disk ~2hours.
A. Disable your present antivirus software and firewall
B. Remove your present antivirus software
C. Download Microsoft Security Essentials.
D. Run Microsoft Security Essentials. Quick Scan - ~8 min on my laptop.
E. Run Microsoft Security Essentials. Full Scan - ~ 1hr 50 min on my laptop.
Now I advise you to uninstall MalwareBytes and only install again when and if you need it.
Why?, you ask. Leaving MalwareBytes installed slowed my system. AutoRuns showed MalwareBytes processes running even after exiting from MalwareBytes.
My System SpecsSystem Spec
23 Sep 2010   #5

Windows 7 Home Premium

I completed Step 5 on your list and there was nothing infected/malicious found on my sister's laptop (it took 4 minutes and 11 seconds, by the way). However, I'm not sure how I'm gonna be able to update MalwareBytes since my sister's laptop can't connect to the internet. I had to download the installer on my laptop and then use a USB flash drive to transfer it onto my sister's laptop.
Should I just skip steps 6-8, or is there some way I can get the update on my sister's laptop?
My System SpecsSystem Spec
23 Sep 2010   #6

MS Windows 7 Ultimate SP1 64-bit

Yes, the MalwareBytes update is available as a separate download.

Go to this website to download:
Malwarebytes' Anti-Malware

I really don't remember where to put the update and don't have malwarebytes installed at this very minute. I do know this much, if you ask in the SevenForums Security Forum, someone will be able to answer. I know what I'd do--that is look at the extension of the file you download (after any need extraction), and then go to \program files\MalwareBytes and look for a file with an identical name and overwrite it with the downloaded file.
My System SpecsSystem Spec
23 Sep 2010   #7

Windows 7 Home Premium

Why do I have to update MalwareBytes anyways? Isn't it already the latest version? On their website it says that version 1.46--which I downloaded--is the latest.

And I think you gave me the same MalwareBytes link--not to any update.
My System SpecsSystem Spec
13 Feb 2013   #8

Windows 7 64bit Proffesional

I realize I'm necroing this thread but in case anyone else has trouble with this issue, the following worked for me:

net localgroup Administrators /add networkservice
press enter then type:
net localgroup Administrators /add localservice
press enter then type:
press enter and restart your computer

Got it from the last post here: Wireless not working and starting "diagnostic policy service" - Microsoft Community
My System SpecsSystem Spec
14 Aug 2014   #9

Win 7 Ultimate -64 bit sys 1/Win 7 Home Prem - 32 bit sys 2
Thank you...awesome fix!

Muchas gracias. I tried everything in this thread and also all the netshell commands to fix the stack but only this worked.

Will go in my tool box now.

Tremendous help which saved my several hours of work.

My System SpecsSystem Spec

 Problem with the Diagnostics Policy Service + Internet

Thread Tools

Similar help and support threads
Thread Forum
Diagnostics Policy Service not running and no internet connection
A few days ago, my desktop stopped being able to connect to the internet. I rebooted it and it still didn't work. I rebooted the router (DSL connected to desktop via Cat5e cable) and still no internet. My laptop (which I am writing this from) connects fine to the router. And on the face of...
Network & Sharing
"The Diagnostics Policy Service is not running" - No Internet Access
I hope I find you all well. This is my first post on this forum. I've first dug through all previous posts on this matter, have followed all instructions that seem to have worked for other people with the same issue but none have yet solved my problem. Initially I had a problem when I tried to...
Network & Sharing
Diagnostics policy service won't start - Connected, but no internet
For some reason my laptop does not connect to my wireless network. It says I have "limited access." I tried troubleshooting as administrator and it says diagnostics policy service will not start. All other gadgets in the home work. I have tried so many methods to fix this and I just cannot find any...
Network & Sharing
Diagnostics Policy Service not running + internet problems?
so today my laptop was working perfectly until it shut off. once it turned back on, the internet was connected but it said limited access. the internet is working on all of the other laptops, so i tried a troubleshoot to further determine the problem and it said the Diagnostics Policy Service is...
Network & Sharing
Diagnostics Policy Service and internet drop
I have been having an issue over the past few days with my connection. It randomly dropps and reconnects or doesnt reconnect at all. When I try to run the windows diagnostics service it fails. I get this error every time I run it even if the internet is connected: "The Diagnostics Policy Service...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App