Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Arbitrary file access privilege changes

23 Sep 2010   #1

Windows 7 64 bit Home Premium
Arbitrary file access privilege changes

My rig is an i7-930, 12GB, Nvidia 250GTS, Win7 64 bit Home Premium with all updates current.

I do a lot of photo editing with Nikon software and CS5. My critical problem affects CS5 64bit, Nikon CaptureNX2 - 32 bit, and Nikon ViewNX2 - 32 bit. Suddenly last night I could not save labels in ViewNX2 or files in CaptureNX2 and CS5. The error message was the red circle with an 'x' saying I did not have access privileges to change the file, that I will have to go to the file and change the access privileges in the files/info properties in the operating system. I can save files with a new name, I just can’t edit and save again. I have over 40,000 image files; changing access privileges would be close to impossible, even if I knew how to do it.

I took a look at the properties of the folder where the images were and, for some unknown reason, the whole folder was marked as 'Read Only'. Unchecking that attribute did not solve the problem, I still can't edit the files.

This problem does not occur in other programs, notably Word and Excel 2003.

This is just baffling and has stopped my photo editing in its tracks.

Any suggestions? Thanks

My System SpecsSystem Spec
23 Sep 2010   #2

Windows 7 64 bit Home Premium

Update. As trial measure I took ownership of one of the image folders, even though I am in an Admin user account. Now I am able to edit in that folder. I did NOT take ownership of another image folder, although I am now able to edit images in that folder without error messages.

OTOH, when I tried to edit an Excel file just now I got an error message that said it was Read Only. I looked at the properties and it was NOT read only. Then, went I went back to save the file Excel still said it was read only and prompted me for a new name. I opened the save-as dialogue box and simply saved with its original name, and it saved the file.

What gives with this inconsistent, random, and arbitrary access privilege changes?

I really need some help here or I won't be able to use this computer in a work environment. Thanks.
My System SpecsSystem Spec

 Arbitrary file access privilege changes

Thread Tools

Similar help and support threads
Thread Forum
Batch file for Hibernate on/off with admin privilege.
Hi, I trying to create a batch file for hibernate on/off. I tried this: echo off :Ask echo Activating Hibernate (Y/N)? :INPUT set /P INPUT=Type input: %=%
General Discussion
Adding document and arbitrary file results to Start Menu search
Hey guys, I've been very heavily reliant on the program Everything lately and it's basically completely taken over as the way I navigate my computer. Being able to type in a random file name and have it instantly appear is a huge win for productivity. But, I am wondering if there's any way to...
General Discussion
Arbitrary BSOD - Page Fault In Nonpaged Area
I'm running a relatively fresh install of Windows 7 Ultimate x64, and have had three BSOD since the install. It tends to happen while either web browsing or navigating through my file directories in Windows itself - fairly benign behavior. I have followed the instructions on this site, and am...
BSOD Help and Support
Arbitrary BSOD for a couple of months now
This has been going on for a couple of months, and I can't seem to recognize the cause. That is to say, I don't notice any one program which brings this about. It's now getting to the point that my computer is unreliable. So? I humbly come to the boards and ask for your help, as I don't want to...
BSOD Help and Support
Arbitrary Processor Downclock
Here is the CPU-Z screen: I am running Windows 7 Pro, 32 bit. The performance I should be getting from my two cores is around 2.2 GHz, but the clock speed has been reduced to 600 MHz for reasons unknown to me. The problem happened randomly. Upon sleeping and then awakening my laptop, I...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:19.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App