Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 3 GB installed but only 1GB usable.

30 May 2009   #11
Grandpa Ubu

windows 7 RC 7100

Well supposedly drivers are kinda important.....go figure I thought I had installed the W7 driver but I checked the date and ver and found out it was in fact a Vista driver I installed the Win 7 drivers and now I have 2 G usable now...I opened almost everything on my computer and even Battlefield 2142 at the same time.....only used about 40% I have recovered 1 gb of the 2 gb that was lost....

Now I'm gonna try to find the last Gig....

Thanks guys for all your help and suggestions......

Snuffy...thanks for the links...I'll check them out...

My System SpecsSystem Spec
30 May 2009   #12

Win 8 Release candidate 8400
bios settings

sorry I forgot to ask if there is a setting in bios for "OS installation" or something similiar? On some systems to keep the mobo and OS most compatible the bios will only use 1 gig while installing an OS. Let me see if I can gleen some info abt the mobo from the mfr web page.

My System SpecsSystem Spec
30 May 2009   #13
Microsoft MVP


Windows isn't stealing your memory. First, the 3gB is visible to your computer, so it's there. Windows does stuff in the background (in addition to everything that's running in the foreground) - so it's eating some memory just by running.

If you open up Task Manager (right click on the Task Bar to get to it) and sum the memory usage in the Processes tab (with the "Show processes for all users" selected, you'll see most of what's being used.

Then go to the Performance tab of Task Manager and you'll see a description labelled Physical Memory - that'll show the Total, Cached, Available, and Free

Here's a description of the stuff in Windows 2000 Server Task Manger (I can't locate a more recent link): Task Manager It describes all but the "Free" entry under Physical Memory

32bit client OS's (not server OS's) can only see 4gB of physical memory addresses. Some hardware leaps in front of the line and reserves some of this address space for itself. This means that Windows (being 2nd in line) may not get all of the physical memory addresses that it needs for your memory.

For example, if you have 4gB of RAM, and your hardware claims 1gB of address space, there's only 3gB of address space left for your RAM. You can have a gazillion gB of RAM installed - but if there's only 3gB of address space available, that's all that Windows will be able to see/use (BTW - Windows changed the display in Vista SP1 so you'll see installed RAM rather than usable RAM).

NOTE: This is physical memory, and is not related to the /3gb switch for virtual memory

The only way around this limitation is to remove the hardware that's doing it. IME the biggest culprit here is the video card - so you can remove the video card to remove the restriction, but then you won't be able to see anything! :)

Virtual memory bears no direct relation to physical memory (that we can see). The Windows Memory Manager sub-system manages the swapping of memory between virtual memory and physical memory by swapping stuff in and out of physical memory and the pagefile.

Each process in Windows 32 bit client OS's is limited to 4gB. 2gB are reserved for kernel-level activity, and 2gB are reserved for user-level activity.

So, if you've got 50 processes running, then you've got 200gB of virtual memory address space reserved for those processes (they may not all be used).

You can switch the 2gB/2gB thing to 1gB/3gB only under these circumstances:
- the /3gB or PAE switch must be enabled in Windows
- the application that's using this MUST BE PAE AWARE. If it's not, then nothing will change.
My System SpecsSystem Spec

30 May 2009   #14


Your motherboard uses Scalable ability to both 3 way CrossFireX and 3 way SLI support for ultimate graphics performance.
If your using SLI configuration, (a SLI configuration also removes an amount of ram equivalent to that of your Video cards) then your 1GB Video card accesses 1GB Memory for max video. (per the mobo settings.) now you only have 2GB usable.
You might also expand the task manager to show all processes. Then you can add up memory used per process.

checking you mobo specs it says it is very specific on how memory modules are inserted.
According to Intel spec definition that XMP DIMMs and DDR3-1600 above are supported for one DIMM per channel only
When enabling Dual Channel mode with 2 memory modules, be sure to install them in the DDR3_1 and DDR3_3 sockets
When enabling 3 Channel mode with 3 memory modules, be sure to install them in the DDR3_1, DDR3_3 and DDR3_5 sockets
When enabling 3 Channel mode with 4 memory modules, be sure to install them in the DDR3_1, DDR3_2, DDR3_3 and DDR3_5 sockets
might make a BIG Difference.
My System SpecsSystem Spec
30 May 2009   #15
Grandpa Ubu

windows 7 RC 7100

WOW...the response here is amazing....Let me go through everything....

GARY...attached is a pic of Task Manager....Its showing the 2 g now after my driver update. As you can see this update reduced my usage from 60+ % to 25% or so....

ZigZag....mem test showed good

Usasma....Thats good info to check out...I'll do that...great information for future reference as well

Snuffy....I have me memory in 1,3,5....I only have one video card but using 1Gb for video makes sense due to it being a HD card....I'll look into this as well

Guys, again, your response is nothing short of amazing...thanks for everything...I'll check everything and report back to you...

Thanks again,


Attached Images
3 GB installed but only 1GB usable.-wtm.jpg 
My System SpecsSystem Spec
31 May 2009   #16
Grandpa Ubu

windows 7 RC 7100

Darkassain....attached is my WEI....this memory should be scoring higher than this. I did find out in my bios that my voltage profile was back to 1.5 v and I adjusted it to the 1.65 v the memory calls for and it placed it to the true 1600 speed in the bios now...

It does appear that 767mb is shared system memory but I'm not sure if this is the missing ram so I'm not sure if this is what you were talking about



Attached Thumbnails
3 GB installed but only 1GB usable.-wei.jpg  
My System SpecsSystem Spec
08 Jun 2009   #17

Windows 7 RC, Windows 7 BETA, Vista, Hackintosh OS X 10.5.6

go check BIOS if reads 3Gb or not, also use CPUZ to check if you've installed your RAM correctly. CPUID
My System SpecsSystem Spec
08 Jun 2009   #18
Captain Zero

Windows 7 Home Premium x64

I'm thinking it's the BIOS. Second option to look at is how the RAM is installed and in what slots. Snuffy and usasma are on the right track. CPUID will show you what's recognized by Windows but unless the BIOS sees it, Windows never will. If you still can't see all your RAM, it might simply be a bad chip or slot.

1.6v into your chip is a little hot. I'd check temps on the NorthBridge and make sure you're not cooking it. If it's higher than 50-60c, you're pushing it for 24/7 and that will cause your RAM to fail - and possibly fry your board.
My System SpecsSystem Spec
08 Jun 2009   #19
Grandpa Ubu

windows 7 RC 7100

From Stoneage...thanks for the suggestion of CPUZ...great tool even if I done understand everything...attached are shots..3 g is showing and running but the freq appears to be off. My bios is showing 1600 mhz and CPUZ is showing only 800mhz.

Cpt Zero....attached is the memory voltages for the memory. I have the TR3X3G1600C9. It calls for 1.65v

I am gonna check with corsair as well but the system and bios both seem to be registering 3 gb.

Thanks guys.

Attached Images
3 GB installed but only 1GB usable.-memory.jpg 3 GB installed but only 1GB usable.-mem2.jpg 3 GB installed but only 1GB usable.-corsair.jpg 
My System SpecsSystem Spec
08 Jun 2009   #20

windows 7


Enter into the bios setup when you start your PC, probably it is to press `Del' or ctrl A, look out for the message on the screen, scan all the tab shown in the bios, it would be in advanced bios feature, look for the RAM installed in all the channels, there may be four channels for RAM, otherwise remove all but one and add one bye one, look into the bios, if it doesn't detect all of your RAM, then get the RAM physically checked into some other PC.
My System SpecsSystem Spec

 3 GB installed but only 1GB usable.

Thread Tools

Similar help and support threads
Thread Forum
4GB Installed only 2GB usable
Sorry guys, I had to post another topic about this. I already understand why PAE isn't enabled on 32-bit versions. This is making me uncomfortable seeing that only a half of the memory is being used and the remaining is sitting there doing nothing. I'm not even getting better performance it's...
Hardware & Devices
8 GB RAM installed (3.98) usable
Hi all, Have check everywhere for a solution do this. I have recently build my own pc and its going great But i have 2x4gb ram chips installed dual channel and its only detecting 4gb usable there is no memory mapping for my mobo and yes im on a 64 bit system have tried everything can...
General Discussion
Installed vs Usable Ram
I've got a new Dell XPS 8100, i5-750. Shows: Installed Ram: 6 gb (2.96 gb usable) System: 64 bit System managed paging, which shows a page size of 3 gb. I have a GTS 240 1 gb card. Shouldn't all my Ram be usable? Suggestions?
Performance & Maintenance
RAM: 4GB installed and only 2.93 usable.
I have 4GB installed and only 2.93 usable. I tried the solution given by rektalstab 1)Run 2)type "msconfig" 3)Go under the "boot" tab 4)click "advanced options" button 5)UNCHECK! "Maximum memory" 6)Reboot
Hardware & Devices
6 GB Installed (3 GB usable)
Howdy! So I've read up a bit on this from other posts of the same problem and here's what I've tried: Tried msconfig---every time I try to set the amount to anything above 2048 it resets. Tried deselecting "Max Memory" and it shows the same amount. Updated BIOS (Which only detected 3063...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:01.
Twitter Facebook Google+