Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: help - can't access explorer or play mp3s

12 Oct 2010   #1

7 x64
help - can't access explorer or play mp3s

Hi folks,

I've had a relatively trouble free time with this machine and W. 7 x64 since bought in March 2010. Yesterday, after receiving some emails with mp3 attachments, it's been acting up...

I have winamp as default mp3 player. When attempting to play the mp3, winamp skin opened on the desktop but would not play content. Tried a number of mp3 music files from disk... same problem. Tried opening with wmp, same problem.

Ran chkdsk on C drive and this morning - no problem. Switched on machine one hour ago and same problem. Now when I click on the Windows Explorer icon I get the remote procedure failed error.

Error messages: yesterday "rpc server error", today: "the remote procedure failed and could not execute"

Help will be very happily recieved. Thanks!


My System SpecsSystem Spec
12 Oct 2010   #2

Windows 7 Home Premium 32-Bit - Build 7600 SP1

Try doing a System Restore to a date before you had the problem. Let us know how things turn out.
My System SpecsSystem Spec
12 Oct 2010   #3

Windows 7 Ultimate

Try turning on RPC :

1. RIGHT click my computer, then click "manage"
2. Click Services and Applications, then click Services
3. Find "Remote Procedure Call (RPC)" and double click it
4. Click "Start"

Try opening the files again
My System SpecsSystem Spec


 help - can't access explorer or play mp3s

Thread Tools

Similar help and support threads
Thread Forum
Android emulator with play store access
I have been trying to get an android emulator to work that has play store access, but to no avail. Blue stacks WAS working on this exact hardware a few days ago, then it went into it's typical "Initializing" loop. I contacted Blue stacks support and all they said was wait for a new version,...
MP3s don't play in any media player!
Hey guys, For some reason when I download an mp3 to my computer it does not play at all! I've tryed using all sorts of media players from itunes to media monkey, windows media player and quick time. All of them just show the song in the play box, but it doesn't start playing. Even when i click...
Music, Pictures & Video
Sounds suddenly stops when I play mp3s/online games
I don't know what caused this; the sounds(in my headset) suddenly stop then resume again. I'm sure that it isn't caused by lag or other internet related issues, I'm using the same headset after my computer has been replaced entirely and my past OS is WinXP. But my speaker works fine and doesn't...
Sound & Audio
CD Art in Explorer for MP3s
While browsing folders in Win 7 explorer, my mp3s sometimes have the cd art instead of the generic mp3 file logo. How can I turn that off? It's editing my mp3 tags, and I find it annoying! Thank you in advance.
Music, Pictures & Video
Remote Desktop Access with Plug-and-play Drivers
Hello, I am currently running a tablet netbook with w7 pro x32. It's not powerful enough to run photoshop very well, and my license wouldn't let me put it on there anyway. However, this netbook is a tablet. I'd like to use it for graphics, as it has a Wacom digitizer. What I'm interested in...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:14.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App