Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 using old version of program from cache?

28 Oct 2010   #1

Windows 7 home premium 64 bit
Windows 7 using old version of program from cache?

I am working with a netbook containing Windows 7 Starter.

Last week I created a folder in C:\Program Files. Why did I do this? Well for many years I have had several XP computers set up this way for an MS Access database and all activity occurs in this folder.

So I copied the access database to this folder, everything works fine. This week I have an update of that program (I do my work from another computer) so I overwrote it. When I run it, it's running the old version. I tried deleting it and emptying the recycle bin, then copying the new program again. When I run it, it's still the old version.

So I instead copy the new file to the desktop and run it from there, and it's the right version so I drag it to the folder in Program Files, open it, and it's the old version.

If I rename it to anything but the original name, then it will run as the new version but it seems like it is reading the old version of the program from a cache of some sort. I also tried deleting the entire folder and recreating it but that didn't make any difference.

Does anyone know what's going on here and how to fix it without using a different folder? This database is run on several computers using this folder configuration and I would prefer not to have to change that for the sake of this one computer.

Thanks for your help

My System SpecsSystem Spec
29 Oct 2010   #2

MS Windows 7 Ultimate SP1 64-bit


First, welcome to seven forums.

Now you made a very poor choice for a folder name.

Program Files is a rather sacred name to Windows.

Did you delete the Win 7 Program Files folder? That's a no-no.

The program that you want to run. The name of the program is?

Is there a Win 7 version of this program?

Some old programs can run in "compatibility mode".

Other than your problem with a particular program, is your netbook functioning correctly?
My System SpecsSystem Spec
29 Oct 2010   #3

MS Windows 7 Ultimate SP1 64-bit

We really need you to help us.

Would you please fill out your system specs?

Here's how.


In the line at the top of you will see UserCP.
That is an abbreviation for User Control Panel.
Click on UserCP.
In the left-hand column, under Your Profile you will see Edit System Spec.
Click on Edit System Spec
You can copy and paste from the output of Speccy, Speccy - System Information - Free Download to fill out much of the info. Be sure to use the Other Info section of your System Specs for such info as your optical drive, your wireless adapter, your speakers, etc.

My System SpecsSystem Spec

29 Oct 2010   #4

Windows 7 Ultimate (x64)

RichO, first of all, welcome to the forums!

I did not quite understand from your post, whether you are updating a database or the actual MS Access.

In any case, if you are running without administrative privileges, then you might have problems with writing to system folders and Program Files is one of them. This is normal behavior.

As an example, suppose you want to manually update a program. So you go ahead and replace the executable file in the corresponding Program Files folder. What will happen is that Windows will replace your file with the old version. The proper way to update is to use the installer.

Now, I understand that you are talking about your own database or script, not a program that comes with the installer. The simplest way to avoid the problem is to put it into some other folder. I see that this is not what you want. In that case you should try to take ownership of the folder in question (but not the whole Program Files!), revoke permissions for anything else, and perform your writing as administrator. That should work, I think. But this is really not the most elegant solution, so hopefully someone else will be able to come up with something better.
My System SpecsSystem Spec
29 Oct 2010   #5


i think you will find there is a copy in users/yourname/appdata/local/virtualstore that is what your program is using, try deleting it.
My System SpecsSystem Spec
29 Oct 2010   #6

Windows 7 home premium 64 bit

Hi everyone!

Thanks for your replies.

I will update my user CP soon with the specs.

To clarify, Access is already installed on this computer. The program I am working with and updating is the database (mdb) file. I did not delete program files (I know better than that ). The only folder I am working with is the one I created within program files.

The one and only user that is set up on this computer is an administrator user type so there have been no issues with writing to this folder initially.

Pusspa, you hit it on the head! That's where the old version was stored. When I deleted that file the new one worked.

Thanks for all your help!
My System SpecsSystem Spec
21 Jul 2011   #7

Windows 7 Ultimate x64
same problem with Caching on my Program Files Folder


I come back to this thread because I face the same problem on my Windows 7 Ultimate x64.
I have put a FileMakerPro database in the "Program Files (x86)" folder (I mean the .fp7 file).
When working on that database (opening it from that location), everything is fine, I can add data, modify the content etc.

But when I copy that file and paste it somewhere else, it is the INITIAL version of the file which is copied, without my modification. It is as if Program Files would have kept a copy of the initial file as well as the file I usualy modify. Even though I have "versioning" disabled on my system...

Do you have an idea where can I disable this weird "security" behaviour ?

Best regards.
My System SpecsSystem Spec

 Windows 7 using old version of program from cache?

Thread Tools

Similar help and support threads
Thread Forum
Spoof Windows version to install a program
Hi I'm talking about Vista but I'm also interested in doing the same on Windows 7! They are probably very similar on both system. Please state which system is your answer for. I need to install some programs which require Vista without service pack. I only have a Vista SP2 DVD. I don't...
Installation & Setup
Problem updating program version in windows 7 64Bit
Hello Everyone ,, I'm a computer programmer and I have a database program for pharmacy >> The problem is on a customer's computer with Windows 7 64 Bit I installed the version 1.2 for example .. then I wanted to replace it with version 1.3 !!! After replacing the files when lunching it >>...
64-bit program installs as 32-bit version in W7 64-bit
I have downloaded and installed a panorama stitching program - Panorama Factory - as a 64-bit installer. On the PF Factory website it correctly identified my W7 as 64-bit and downloaded that installer version. However it has actually installed as the 32-bit version that does run as such...
Trivia Question: first version of Windows with Program Files folder?
I'm thinking the introduction of the Program Files folder coincided with the advent of spaces in paths. Before Program Files you couldn't name a file "My File.txt" people did MyFile.txt or my_file.txt. It must've been one of the 9x but I can't remember.
Chillout Room
Uninstalling a 32 bit program on 64 bit version of 7
I recently installed a 32 bit program, using compatibility mode, on my computer with a 64 bit version of Windows 7. Everything worked fine with the install but I have since acquired a 64 bit version of the same program and want to install it. The problem is, when I try to uninstall the 32 bit...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:03.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App