Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: dismantled 2 disk RAID array (data) corrupts win7 OS on SSD

07 Nov 2010   #1

dismantled 2 disk RAID array (data) corrupts win7 OS on SSD


My setup was the following:

60GB SSD - win7 64bit
3TB RAID0 array - data

I needed to break down my RAID array so they could be accessed by two other OS. Once I broke down the RAID, Win7 fails to boot. It goes into constant reboots. The thing that REALLY confuses me, is that the OS should not care about my RAID array. The OS was specifically installed to a completely different hard drive. On a different bus.

Any help/explanations/ideas would be a lot of help.

(didn't really know how to search this problem on google)


My System SpecsSystem Spec
07 Nov 2010   #2
Orbital Shark


Hi, and welcome to the forums :)

At which point does it reboot? Can you access the boot options menu (constantly pressing F8)?

p.s. Dig the username

My System SpecsSystem Spec
07 Nov 2010   #3


Thanks for the welcome!

Well, I can get it to the repair/safe mode menu. Safe Mode will flash BSOD>reboot after loading CLASSPNP.SYS.

Repair fails.
My System SpecsSystem Spec

07 Nov 2010   #4
Orbital Shark


Does the repair give any details on the fail?
My System SpecsSystem Spec
07 Nov 2010   #5


Switched from droid to netbook to actually give details :)

Repair can start up, finds Windows install on F: (which I find odd). Select startup repair. Startup repair cannot repair this computer automatically.

Details: (or lack thereof)

Problem Signature:
Prob Event Name: StartupRepairOffline
Prob Sig 01:
Prob Sig 02: 6.1.7600.16385
03: unknown
04: 21200744
05: AutoFailover
06: 3
07: NoRootCause
OS Version: whatever
LocaleID: 1033

I have no problem booting with a live linux distro/backing up data and wiping the SOB. I am just so irritated with how/why this has happened. The RAID array should have no bearing on the OS install! Logic is in disarray!

Going to disable SATA ports of two 1.5TB drives in BIOS and give that a shot.
My System SpecsSystem Spec
07 Nov 2010   #6


In BIOS: The RAID SATA ports have 3 options.


AHCI is needed for another OS (which should not be mentioned) to access those disks.

Switched to disabled and windows boots up. I have to admit, I'm pretty confused at the moment. I guess I'll probably need to reinstall 7 with AHCI enabled. The bitch of all of this is, I need to install 7 FIRST. So my linux and hack installs will have to start from scratch all over again
My System SpecsSystem Spec
07 Nov 2010   #7
Orbital Shark


It sounds like the MBR is screwed up...

You might want to look at MBR - Restore Windows 7 Master Boot Record
My System SpecsSystem Spec
07 Nov 2010   #8


Thanks for the tips and quick replies, Shark!

I started searching AHCI and problems with windows7 and came across this link: AHCI : Enable in Windows 7 / Vista

It appears in order to use AHCI I need to enable it in BIOS prior to Install of OS. It looks like I'll need to format after all. I will leave this info up so if anyone else has this problem they can reference this.

EDIT: Any way to mark this thread as solved?
My System SpecsSystem Spec
07 Nov 2010   #9
Orbital Shark


You're welcome, just wish we could have got a better solution for you

To have a thread marked as solved click the dismantled 2 disk RAID array (data) corrupts win7 OS on SSD-report.gif on you're first post then type 'solved' into the box :)

And, please enjoy the rest of the forums :)

My System SpecsSystem Spec
07 Nov 2010   #10

W7 Ulti/64, XP Pro/32

I do not believe you have to do a fresh install to enable AHCI. Wish I had the link to give you. Google more in depth. I bet theres a "Brink" tutorial here!
Your SSD should be able to run in IDE mode.
What was it in when OS installed?
Did you change its port when breaking array? It should be in port 0.
When setting up the SSD, did you move temp files, tmp files, or page file off the SSD to the array?
My System SpecsSystem Spec

 dismantled 2 disk RAID array (data) corrupts win7 OS on SSD

Thread Tools

Similar help and support threads
Thread Forum
Raid array error, disk not accessible for check disk?
Hi everyone. Going crazy with this. So about 2 weeks ago, my "intel rapid storage technology" software gave me an error. I opened it and saw that one of the disks (2 disk array) in my Raid 0 array, had an error. I reset it back to normal and left it. Then I started to get pop ups saying that...
Hardware & Devices
Borked my PC when trying to split up a RAID 1 array (not windows disk)
I have two 1TB disk drives as storage space. Originally, I set these up as a RAID 1 array, but am now using this PC for DVR purposes and not so much for actual work, so the disk space is more valuable than the redundancy. So I wanted to undo the RAID, but the RAID is not my boot disk, so I figure...
BSOD Help and Support
How to install Win7 to an SSD Raid array?
I would like to get 2 SSD’s and put them into a raid array using Windows 7-64bit, but wanted to make sure I understand how to do that. The 2 SSD’s will be the only drives in the system. My computer has an X58 motherboard with an ICH10R. Here is what I think is the correct procedure: Boot into...
Installation & Setup
win7 hangs when adding new HDD raid array
First of all, thanks for the read, like the forum, tons of info here. Second, I tried to search and find my problem here, and just didn't see a thread that fits what I see... lots of problems, but so far nothing matches me. Finally, seems to be some very savvy PC guys here, so hopefully you can...
Hardware & Devices
Disk Boot Failure with RAID 0 Array
Hi I have two 500Gb SATA drives in a RAID 0 config set as my system drive 'C', and a 1TB SATA as a storage drive 'E' Never had this problem until last night when I removed the storage drive. Tried the usual fixes with no luck, put the drive back in and the system boots normally. The...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:49.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App