Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: One more .exe association problem + gadgets not working

07 Nov 2010   #1
Kolji

Windows 7 Professional x64
 
 
One more .exe association problem + gadgets not working

1. How it all started:

I decided to disable Avast Antivirus a week a go and start using Microsoft Security Essentials instead. That's when the problems started (which might be just correlation, not causation).

2. Problem:

a) When I try to run an .exe file from Total Commander, I get "Error executing program".

b) When I try to run an .exe file from FreeCommander, I get "Your internet security settings prevented one or more files from being opened."

I tried to change all internet settings to "Lowest security" (tried all - intranet, internet...) but problem remained.

c) Start\Search (which I usually use to run applications that don't have icons among the frequently used) doesn't find anything. For example, I type in "Photoshop" and all it finds are blank icons named "Programs" "Documents" "Control Panel" and "Pictures".

I tried fixing the file associations in registry (changing HKEY_CLASSES_ROOT\exefile\Default to "%1" %*) but nothing changed. The only way I can run .exe files now is to locate them in Start Menu, locate them using Windows Explorer or via command line.

d) Windows Gadgets stopped being displayed properly.

I have no other clues what might be preventing .exe files from working properly.


My System SpecsSystem Spec
.
07 Nov 2010   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by Kolji View Post
1. How it all started:

I decided to disable Avast Antivirus a week a go and start using Microsoft Security Essentials instead. That's when the problems started (which might be just correlation, not causation).

2. Problem:

a) When I try to run an .exe file from Total Commander, I get "Error executing program".

b) When I try to run an .exe file from FreeCommander, I get "Your internet security settings prevented one or more files from being opened."

I tried to change all internet settings to "Lowest security" (tried all - intranet, internet...) but problem remained.

c) Start\Search (which I usually use to run applications that don't have icons among the frequently used) doesn't find anything. For example, I type in "Photoshop" and all it finds are blank icons named "Programs" "Documents" "Control Panel" and "Pictures".

I tried fixing the file associations in registry (changing HKEY_CLASSES_ROOT\exefile\Default to "%1" %*) but nothing changed. The only way I can run .exe files now is to locate them in Start Menu, locate them using Windows Explorer or via command line.

d) Windows Gadgets stopped being displayed properly.

I have no other clues what might be preventing .exe files from working properly.

Does it to the same thing when booted in safe mode?

DO exe's launch outside for the "commander" apps?

do you have a backup from before the problem started?

Do you have a win 7 dvd?


ken
My System SpecsSystem Spec
07 Nov 2010   #3
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Maybe you created a mess by not correctly uninstalling Avast. Here is the official procedure: avast! Uninstall Utility
My System SpecsSystem Spec
.

07 Nov 2010   #4
Kolji

Windows 7 Professional x64
 
 

zigzag:

1. does the same thing when in Safe mode

2. don't understand the question a bit - apps launch only if I try to run them from start menu, command line or from windows explorer. It seems like an .exe file cannot open another .exe file (although Visual Studio is still able to run and debug a freshly built .exe file)

3. no backup (the only backup I kept was before updating MS Essentials definitions but AFTER installing it - I noticed this problem AFTER updating it)

4. I don't, I have Windows from MSDNAA but not currently downloaded and burned it on a DVD. I am affraid I will have to, though.

whs: I uninstalled Avast using this utility
My System SpecsSystem Spec
Reply

 One more .exe association problem + gadgets not working




Thread Tools




Similar help and support threads
Thread Forum
file association not working..
When I try to open a folder by left clicking with my mouse I get a message that tells me there is no file association. If I right click then select "open", it works! How do I fix this?
Software
Help - File Association Not Working - Only One Extension Fails
I run Win 7 Pro x64. I've tried searching for a solution to a recent minor but irritating problem. In Windows Explorer I can automatically launch most applications based on the associated file extension. This does not work for the files named "*.skf" which I have associated with a legacy...
General Discussion
Gadgets has stopped working - strange and tough problem ;/
Hello, today I have changed my audio driver and after this my gadgets windows disappear + windows constantly showing me message "Gadgets has stopped working..." with no resolve info about this. I've tried to resolve this problem a number of ways, including: - restore gadgets installed...
Customization
Possible File Association Problem or Open With Problem! MAJOR
Apologies if this is not the appropriate catagory but i had trouble finding a suitable one, here is my problem: I was messing about with a file using winrar, (sorry i cant remember which file it was) i right clicked the file and clicked 'open with' i chose winRAR and it screwed up and decided...
Software
GP4 Association problem
I accidentally sat the program to notepad so I can't open any .gp4 files. Anyone know ho to reset it to default?
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:03.
Twitter Facebook Google+