Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Print to file: Access denied

02 Jan 2013   #11

Windows 7 Ultimate x64

I do, however it's the top result when searching Google for that error message. I figured I'd share the fix for anyone who had the issue, regardless of the year or how old the thread was, since I doubt the error message was limited to 2010 :).

My System SpecsSystem Spec
02 Jan 2013   #12

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64 +Linux_VMs +Chromium_VM

+1 slowmo

Thank you for adding your experience to help others with this...
I am no guru, but I do search for answers and solutions whenever I am trying to solve a problem.
Info like this helps me, no matter how "old" the question is.

Interestingly I just ran into the same issue!
I placed an order on Newegg and got the same message trying to "print to file"...
I worked around it and got the info I needed...meh

Seeing this thread, I was intrigued and curious...and had to try...
I tried printing to file from the SF page, and again got the access denied error!

I log into Win 7 with a Standard (non-Admin) account, and use Firefox.
I closed the FF Window I was using, then started FF with "Run as administrator".
Tried printing again, and it printed to a file with no errors !

fwiw, here's a screen print with the error I see when running FF without Admin authority...

Print to file: Access denied-prtsp01.png

My System SpecsSystem Spec
01 Sep 2013   #13

Windows 7 Home Premium 32 bit

Also, fwiw, I used a complete file specification: c:\users\default\My Documents\test.txt and was able to print to my printer Generic/Text on FILE. Thanks for the tip.
My System SpecsSystem Spec

09 Jun 2017   #14

Windows 7 Home Premium
XPS “Access is Denied” - Fix

My XPS (print to file) also was giving an “Access is denied” error when creating the file. I fixed it as follows.

Summary: change the port to “XPSPort”.

Note that you can probably just apply the below to the existing XPS device; to do that, skip the first section — within “ [ ] ”.
!! However … in the one I created, I can change the permissions; in the existing one I can not. (See the pertinent section below.)

• Open Control Panel/ Devices and Printers.
• “Add a printer”.
• Select “Add a local printer” and click “Next”.
• Select “Microsoft” from the list on the left, and then “Microsoft XPS Document Writer” from the list on the right. Click “Next”.
• I selected “Replace the current driver”, put it is probably fine to just “Use the driver that is currently installed (recommended)”. Click “Next”.
• Type a name for the printer. Click “Next”.
[Above, I have been retracing my steps; I have stopped here; just do whatever else may be required to finish creating this printer.]

Back in Control Panel/ Devices and Printers…
• Right-click on the “Microsoft XPS Document Writer” (or whatever you called yours); select “Printer properties” from the [contextual] menu that comes up.
• Click the “Ports” [3rd] tab.
• Select the port “XPSPort”. (You will have to scroll down to see it.) Click “Apply”.
Done (except see below)!

(I also changed • the paper size to A4 and • the Image format to Lossless Compression… in General/ Change Properties/ Preferences/ Advanced.)


Note that, in addition to the above, it might be necessary to change the permissions. (See note above.)
• Click on the Security tab.
• Change permissions as desired; I gave “Everyone” the right to “Print”, and all rights (except Special Permissions, which is not accessible) to everyone else. This included my account, which I added using the “Add…” button (you have to *type in* the account name). (You do not have to click on Advanced; just change the settings in situ.)
My System SpecsSystem Spec

 Print to file: Access denied

Thread Tools

Similar help and support threads
Thread Forum
SYstem File Checker Result - CBS.Log file says Access Denied
I have just completed a System File Check and some repairs were done I was told that the relevant report could be seen at C:\WINDOWS\LOGS\CBS\CBS.LOG. When I Clicked on that I got Access Denied How can I Open that log file? I am the Administrator
Performance & Maintenance
"access is denied' DIR > PRINT.TXT
I used an "elevated command prompt" (that is what it is named as a desktop icon) Why is access denied? Karen's directory printer produces an essentially blank sheet. Why is that?
General Discussion
File - Access Denied
So, it's like this: I used to have some files on a laptop with windows xp. In that computer, the files only had permissions for admins, I think. I never had problems accessing those files in the laptop. Later that laptop died, but I managed to get those files in my new computer. Problem is, I...
Network & Sharing
FSX CFG File Access Denied
Ok im new to forums so im just gona say my problem :p I have had FSX for vista and i could easily save repaints into their aircraft.cfg files. But now with windows 7 when i try to save a message box says *access denied*. Someone then suggested to make me the admin but i have done this and still...
Put file on desktop -> open file -> access denied?
Hello there. Whenever i take a file and put it onto the my desktop, all the permissions to the file is completely stripped. Leaving none able to open the file. I am able to go into access control and add myself again, but it makes no sense at all.. Why does windows do this and do anyone know...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:13.
Twitter Facebook Google+