Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Accidentally set "deny" on full control, can't unset

13 Jun 2009   #1

Windows 7 RC #7100
Accidentally set "deny" on full control, can't unset

Can someone please help me? I meant to deny only one folder access temporarily to another user I added, but even though I right clicked that folder, it apparently gave me the properties of the entire D:\ drive. On top of that, I ended up denying full control on 'users', which even locked out my Admin!

That said, now in "Computer", that drive does not show how much space it has left. If I right click it, I get NO security tab.

I have also attempted to go into cmd.exe and do cacls D: (anything here results in "Access is Denied" error.

I went into safemode, also got "Access is Denied" error.

Apparently, I made it so not even the admin can change the permissions or even access that drive, period.

Is there ANYTHING that I can do to override this and reset it somehow?

My System SpecsSystem Spec
13 Jun 2009   #2
Microsoft MVP


Dunno if it'll work in Win7, but you'll have to run it as an administrator.
Here's 2 links that may help (or at least give you a start):
Reset Registry Permissions (originally posted18Oct08)
Reset Registry Permissions2 (originally posted 16Dec08)
My System SpecsSystem Spec
13 Jun 2009   #3

Windows 7 RC #7100

I tried all that, and during the SubInAcl process it became red and started spamming me with Access is Denied errors (in an ADMINISTRATOR command prompt, even)
My System SpecsSystem Spec

13 Jun 2009   #4
Microsoft MVP


I'm just shooting in the dark here, but have you tried to copy the registry hives to a FAT32 volume and then copy them back to the NTFS volume?

You'll have to do it from outside of Windows, but this used to be a trick back in the old days to strip file permissions from NTFS data.

Another way is to use another OS and mount the registry hives in that, then change the permissions there. We do this at work, but it's with a proprietary tool, so I'm not familiar with how to do it manually.
My System SpecsSystem Spec
13 Jun 2009   #5

Windows 7 Ultimate

go to tools> folder options, then uncheck the option to use simple file sharing. That will make the security tab come back, then go ahead and set the permissions. Hope that helps.
My System SpecsSystem Spec
13 Jun 2009   #6

Windows 7 RC #7100

I just reinstalled Windows 7. The drive's permissions were STILL fubar'd. This time I was able to take ownership, though, but the drive's really messed up now.

ALL folders have a lock icon, and I can't make them go away.

The security tab used to list 4 things in the Users list.
Authenticated Users

Now they only show ONE.

As well, nothing lists itself as being inherited by the drive, it's non-inherited now. It's so messed up. I even ran the subinacl tool stuff again, no go.

I had to do "lcacls D:\ /Grant Users:F /T" just so windows would stop asking me to give it permission to open files/folders on the drive.

It's a total mess, and it feels like I can't repair it. I want to just reset all the stuff to what they would be if the drive was formatted and new, I want it to have all the proper inheritances and userlists applied like all other drives do... but I don't know how to get it back that way.
My System SpecsSystem Spec
13 Jun 2009   #7

XP sp3

have you tried "Take Ownership"

Its a way out...of this lockout situation

My System SpecsSystem Spec
13 Jun 2009   #8

Windows 7 Ultimate
After you run this Fix it, standard user accounts may no longer appear on the log on screen when you start your computer or try to switch users. This occurs because standard user accounts are removed from the Users group when you reset Windows security settings. To add the affected users accounts back to the Users group, follow these steps:
  1. Click Start, and then All Programs. Or click Programs.
  2. Click Accessories, right-click Command Prompt, and then click Run As Administrator.
  3. In the Command Prompt window, type net users and then press ENTER. A list of user accounts is displayed.
  4. For each accountname listed in the Command Prompt that is missing from the log on or switch user screen, type the following command and then press ENTER:

    net localgroup users accountname /add
My System SpecsSystem Spec

 Accidentally set "deny" on full control, can't unset

Thread Tools

Similar help and support threads
Thread Forum
Accidentally "Take Ownership" of the whole "Windows" folder.
I was trying to patch and install non legit Windows 7 themes and long story short, I have installed Take Ownership and had accidentally click "Take Ownership" of the C:/Windows folder and it took ownership or alot of files... So question is, would it affect anything? Good or bad? So far nothing...
General Discussion
Cannot open/copy files I have 'Full Control': "you need permissions"
I cannot open/copy files within a folder containing web files. Basically the files that make up my website in a PHP-based CMS, a bit like Wordpress. All the files appear to be created by someone else, but I bought licencing rights (i.e. they are website 'theme' files). All the files were...
General Discussion
I accidentally checked the "Hidden" box for userid under "network/user
trying to see the hidden folders, I accidentally checked the hidden box. Now Windows 7 has hidden my userid folders. How can I get it back. I tried restoring it from the copy of this morning but it won't. Help from a person that should have known better.
Performance & Maintenance
File and Folder - Add "Set and Unset as Read-only" to Context Menu
How to Add "Set and Unset as Read-only" to File and Folder Context Menu in Windows 7 and 8 This will add Read-only File Attributes and Read-only Folder Attributes to the context menu of files and folders for all users to be able to set or unset the read-only attribute of one or more selected...
Permissions set to 'Deny' Full Control
Ok, so I set permissions to deny, hoping that nothing would be able to change the files inside. Unfortunately, now I can't do anything to the folder. I have tried takeown /f while running cmd in administrator. I've tried "rmdir" nothing works. pics included. Anyone know how i can delete the file...
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:44.
Twitter Facebook