Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Messing around with ownership brings general problem

16 Dec 2010   #1

Windows 7 Ultimate x64
Messing around with ownership brings general problems

Hello everybody,I need a little help
I was playing around with ownerships on C partition(and D,and E as well,but those two are data partitions only and have managed to solve a problem with those two) for I don't remember what reason exactly,and I have a general problem now.
There are problems involved I never dreamed about like access to program files folder,writing in it,installing anything and many many other,but with following a common sense(which account needs to do what),I have maaged to resolve a most of my problems,but there are still few to work on(for example Event Viewer ad Log Viewer etc)If it is not a problem,if aybody could write here who ows and which rights what folder in his PC has.
I need this properties:
-owner(system,admiistrator or user),
-full permision(everybody with full permission-admin,system,trusted installer,etc),
-and who has only basic rights(user xy)
of following folders:
-Program Files
-Program Data
-User Documents
-Public Documets
And it would be also great to know who is the owner of the whole partition,and who has which rights.
I hope there is someoe out there,who wont find this too complicated to find.
And I am sorry on my English,it is not my native language and because of that,sometimes it is not so easy to find a word you would want to use,but I still thinnk that it is better this way then push it through the Google Translator.

My System SpecsSystem Spec
16 Dec 2010   #2

64-bit Windows 10 Pro

Hello Drazenn,

You could do a system restore at boot using a restore point dated before you did this to undo and hopefully fix it.

Hope this helps,
My System SpecsSystem Spec
16 Dec 2010   #3

Win 8 RP, Win 7, XP

See if this utility can help: (I have not used it and don't know if it really works!)

Messing around with ownership brings general problem-restore-security-settings-windows-7.jpg

My System SpecsSystem Spec

17 Dec 2010   #4

Windows 7 Ultimate x64

yes Brink,you are right,it would probably solve that,but the problem is I have done all that mess log time ago,and since then,I have managed everything to run so flawless,that I have even forgot on that,made an image,and bump,that was it.
Those few unresolved (and unneeded at that time)remained things I solved in the walk,but then,i that time,I had all that stuff in my head since I was agonized with that for days.
And now,ohohoho months later(or year and something),after I made a really big mess on a hard disk,and there was really no option to repair(I was happy that I saved eve some of data on other 2 partitions),I had to pull that famous image made backthen(I was always thinking that I don't need to make another image,because I will make fresh install some day,and I'll make an image of that,but due to delay of that,that day never came).
Briefly said,image that I installed few days ago has no healthy restore points,and I have no clue where to start anymore.
Thanks to Boyans,I hope there will be no need for another repair or fresh install(still haven't tried but looks promising)
My System SpecsSystem Spec
18 Dec 2010   #5

Windows 7 Ultimate x64

Sadly,it didn't worked.
I ran security restore few times,but nothing changed.
I ran it normal and as admin,but neither one of admin rights changed.
Seems I will need to find normal,usual,default properties somewhere,and change them maually through each folder.
But still,thanks on a try
My System SpecsSystem Spec
18 Dec 2010   #6

64-bit Windows 10 Pro

Doing a repair install will restore the default permissions on the C: drive.
My System SpecsSystem Spec
18 Dec 2010   #7

Windows 7 Ultimate RTM (Technet)

Back up your files and do a clean install. It's the only way to be sure.
My System SpecsSystem Spec
20 Dec 2010   #8

Windows 7 Ultimate x64

Quote   Quote: Originally Posted by MacGyvr View Post
Back up your files and do a clean install. It's the only way to be sure.
Erh,MacGvyr,that is exactly what I want to avoid,I have really many many programs installled,and have maximally adjusted instalation to my needs and preferences,so problem is not a windows instalation itself,but few weeks of adjusting PC again after fresh install.

Brink,repair install will definitely be a way to go(I have done it few times before,but have completely forgot on it)but I am in mess with time this days,so I have't done it already.
I have one more question for you since you look like one of the most advanced users here(since pre-beta,if I remember well).
I have a problem with Media Center too(it can't access tuner so I believe it is also a permissions problem,and can't remember how I solved that problem backthen because I started to use it-Media Center-only few months ago,and now I am completely tied to it),and since I read I can loose Media Center after repair install,do you think after reinstalling it,it will work like before?
My System SpecsSystem Spec
20 Dec 2010   #9

Windows 7 Ultimate RTM (Technet)

Bear in mind...every minute you spend trying to "fix" it is time you could have spent rebuilding. It's likely that you would have already been done. Also, I recommend next time you have all the "adjustments" done, that you make a full system image that you can roll back to at any time.
My System SpecsSystem Spec
20 Dec 2010   #10

Windows 7 Ultimate x64

Yes,MacGvyr,like I wrote above,I do reinstall system from an image usually,but this particular image has permissions messed up,and I have forgot to make a newer one when I solved all the problems.In fact,I haven't forgot,but have always delayed thinking I'll make an image when update one program,uninstall another,istall the other of the same kind but different developer,and so on.
But this time,I hope,repair install will do the job.I know it will take quiite time because of so much programs and files already in,but it's worth waiting.
Still,since like I said,I didn't use Media Center at that time,I can't remember when I did repait install,did I have to download Media Center separetely,or I haven't loose it at all.
My System SpecsSystem Spec

 Messing around with ownership brings general problem

Thread Tools

Similar help and support threads
Thread Forum
Take Ownership problem
i try to change the task bar orb, so i edit the explorer.exe, and then i right click the normal explorer.exe and click take ownership, and when i try to rename the normal explorer a massage pops up that says this: "you need permission to do this action, you need permission from TrustedInstaller...
problem in acquiring ownership!!!
hi! i am unable to delete a folder in c drive. The folder contains files copied from an antivirus CD.. Quickheal Antivirus Pro.. in taking ownership method, access is being denied.. i even downloaded the unlocker bur it isn't working this folder!! :( PLEASE HELP ME OUT..:confused:
System Security
Double clicking .txt files brings up cmd.exe - Assoc problem?
Hi all, The title says it all really, Notepad seems to have lost its association to .txt files somewhere along the line. If I double click a .txt file, the command line window appears. Is there a solution? I've tried re-associating txt files with Notepad to no avail :confused: ...
General Discussion
Taking Ownership problem?
Hi, Before sending my dead laptop in for repairs, I pulled the drive and put it into an enclosure to copy some important files. But to access the files I found that my other computer had to change the ownership of the main folders. Here's my question: when I eventually reinsert the drive...
General Discussion
take ownership problem
I have downloaded a small file that is supposed to make a few changes to the Windows Registry. My problem is that a number of folders are locked, since I upgraded from Windows XP to Windows 7. This little "take ownership" registry file looks fine, there is a tutorial attached, etc. but my problem...
Installation & Setup
Odd problem after taking full ownership of C:
First the basics... Asus G71G laptop; dual core T9400 CPU; Nvidia 9800m; 6gb ram; Win7 Pro x64. Drivers and everything up to date (I think). What happens is that immediately following taking full ownership of C:, the "safely remove hardware" icon stops working. I can hover the mouse over the...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:47.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App