Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can NOT delete any registry key in HKLM/SYSTEM

20 Dec 2010   #1

Can NOT delete any registry key in HKLM/SYSTEM

I have Windows 7 Ultimate, and every time i want to delete a key in HKLM/SYSTEM, i get "Cannot delete (key name): Error while deleting key" Here's what i've tried: setting Permissions on the key to full control for administrators group, owner, owner rights, SYSTEM, and my own admin account, NONE of that helps. Also, in 'Advanced security settings-->Owner, i changed it to my own admin account, and also ticked "replace owner on subcontainers and objects" but i get another error "Registry Editor could not set owner on the key currently selected, or some its subkeys." I even turned off User Account Control (UAC). What gives? Some help would be great.

Thanks in advance.

My System SpecsSystem Spec
20 Dec 2010   #2

Vista Ult64, Win7600

My System SpecsSystem Spec
20 Dec 2010   #3


You're trying to delete the entire "SYSTEM" tree?
My System SpecsSystem Spec

20 Dec 2010   #4

Windows 8.1 Pro RTM x64

Invoke the registry editor (regedit.exe) with administrative privileges (right-click, Run as administrator).
My System SpecsSystem Spec
20 Dec 2010   #5


Well, after restarting my PC, i noticed some of the keys i wanted to delete are either gone or blanked out. Now, i followed the M$ link : how to add, modify, or delete registry subkeys... and while it said "The keys and values contained in have been successfully added to registry", the key is STILL present in registry Also, right-clicking regedit.exe and "Run As Administrator" did NOT help either. Any other suggestions?
My System SpecsSystem Spec
21 Dec 2010   #6

Windows 10 Pro (x64)

What in the world are you trying to do?!
My System SpecsSystem Spec
21 Dec 2010   #7


run Ccleaner registry cleaner and those blank registry keys should be removed. You could have malware/virus on your machine as well.
My System SpecsSystem Spec

 Can NOT delete any registry key in HKLM/SYSTEM

Thread Tools

Similar help and support threads
Thread Forum
Cannot delete Registry entry
After trying to recover from severe malware infection, I ran Spybot S&D. It removed several Registry entries but one it could not. I tried manually but it could not be removed. It is located at Hkey-users\S-1-5-21-200258984-2800820833-1255355968\Software\DataMngr. It has subdirectories "Files",...
System Security
Cannot delete certain Registry Key; Cannot change Owner of Registry Ke
In order to get rid of the *.zip folder view in WinExplorer on a64bit WIn7 system I tried to delete (according to some tutorials) the Registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\CLSID\{E88DCCE0-B7B3-11d1-A9F0-00AA0060FA31} Unfortuantely this is NOT possible immediately....
General Discussion
Driver Sweeper can't delete all registry files in registry editor So this is the situation: I've unistalled Amd Driver from Device Manager, Unistalled Catalyst software and ran Driver Sweeper. There is only 3 registeries that the Driver Sweeper CAN'T delete and these are under SYSTEM\ folder. I've tried to change user...
Can i delete ALL registry ERRORS ?
hello. i saw alot of registry errors when i do a PC analyzer. it listed 300++ registry errors . I wonder if i can delte this registries.
General Discussion
Cannot delete registry entries
(Incorrectly posted earlier in the sound and devices forum group) My Wacom Intuos tablet needs a new driver but after removing the old one my Windows 7 Pro 64bit registry still has this old driver mentioned in many lines of all the CurrentControlSet, ControlSet001 and ControlSet002. I...
General Discussion
messed up permissions in registry / HKLM
i've messed up the permissions in the registry HKLM - got a blue screen AND not get a Blue Screen on boot up with an error x0000... and "system has been shut down". i'm online with a dual boot Vista installation on the same machine. what do i need to do to repair this? i didn't try Safe...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:05.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App