Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 Pro won't boot in RAID-0

26 Dec 2010   #1

Windows 7 Ultimate x64
Windows 7 Pro won't boot in RAID-0

Hello. My PC is setup with two hard drives as RAID-0 (1 partition) and it has refused to boot Windows 7 for the past few days. The computer simply shows a black screen after it goes through the BIOS screens. Pressing F8 to enter Safe Mode does not work at all.

This issue has arisen after I tried installing a video card (XFX Geforce 8800 GTX) without uninstalling my old video drivers. It's still a mystery to me how installing the card would cause problems with Windows or my hard drives. Here's what I've done so far to troubleshoot:

I created a System Recovery boot disk because I lack the original Windows 7 installation cd. System Restore does not work, nor does the Image function. System Repair simply hangs for an unbelievable amount of time.

After scanning my hard drives for various info, I found out that my first hdd is listed as NTFS, yet my second one is RAW. Subsequently, the C:\ drive is also listed as RAW, and I cannot use Chkdsk.exe on it. Through a cmd prompt, I used Bootrec.exe /FixMbr and /FixBoot, but it did not seem to fix the issue. I also used Bootrec.exe /ScanOs to see if the Windows 7 installation still existed, yet it came up with nothing.

I've managed to use a program called RAID Reconstructor, via a PE Builder boot disk, in order to copy all my hard drives' sectors over to my external hard drive. The external is now hooked up to a second PC that I'm using to troubleshoot. It seems that all of my personal files are intact and working perfectly fine, and the file names are also correct. I don't really know how to check my Windows/System32 files for corruption.

I'd like to fix Windows 7 without having to format the hard drives. Since I lack the Windows 7 installation cd, I can only install Windows XP while lacking 64-bit support. Since I'd like to avoid this, I was wondering if there was a way to get Windows 7 back up and running. But I suppose this isn't possible without getting my second hdd back to NTFS format.

PS: I apologize if this thread is in the wrong forum. It just seems like an all-encompassing issue.

Edit: Should I simply format my hard drives and copy all my files over from the external? I wonder if this would restore Windows 7, but I suppose it wouldn't be as simple as that.

My System SpecsSystem Spec
26 Dec 2010   #2

Windows 8.1 Pro RTM x64

Hi burntoast and welcome to Windows 7 Forums

When you boot up, just after the BIOS POST has completed, do you get a prompt to press F10 (or some other key) to enter the RAID configuration? This will only appear if there are HDDs set up to use RAID in the BIOS. If you don't get this option, check the settings in the BIOS to see if the disks are still configured to be in a RAID array (the default is non-RAID).
My System SpecsSystem Spec
26 Dec 2010   #3

Windows 7 Ultimate x64

Hello and thank you Dwarf. :) I am able to press F10 in order to enter the RAID configuration screen. The array is listed as the following:

Boot ID Status Vendor Array Model Name
Yes 1 Healthy Nvidia Stripe 465.77G

The Details screen lists the following:

Adapt Channel M/S Index Disk Model Name
2 0 Master 0 ST3250824AS
2 1 Master 1 ST3250824AS

The Capacity of each hdd is 232.88GB, Striping Width is 2, and Striping Block is 64k. I'm not the one who built this computer, so I'm not sure if this matches the original RAID configuration. I've never changed it in the past, however.

Edit: I'm currently downloading a program called Ultimate Boot CD and I'll see if I can run some more diagnostics on the hard drives.
My System SpecsSystem Spec


 Windows 7 Pro won't boot in RAID-0

Thread Tools

Similar help and support threads
Thread Forum
RAID array won't boot after downloading Windows updates
This is so aggravating. I always put off rebooting because my computer is busy with downloading or I'm playing a game or have a conversation or whatever. So I get home from work and then I try to reboot. I click on the shut down button and Windows goes away and then I see the normal update progress...
Hardware & Devices
RAID Changed, Windows 7 Won't Boot (BSOD)
Ok, so Bare with me while I explain the problem. A few days back, my computer would not post on boot. For some reason, no signal would go to the monitor. After reading a considerable amount on the subject online, I tried various hardware swaps (ram, video card, remove optical drives to try and...
BSOD Help and Support
Dual boot with Raid + non-Raid
I'm really hoping there are some hardware gurus here that can help me with this. I've searched to the ends of the "www" (well, it feels that way anyhow) and have found no conclusive answer to this question: If I have a machine with XP installed on RAID-0, can I add a 3rd, non-Raid drive to an...
Installation & Setup
Cannot boot from non-RAID image restored to RAID SSD
OK, I was using one Vertex 120 as my Windows 7 C: drive and bought another to take advantage of RAID0 performance. Did a system image backup of the C: drive to my 1TB D: drive, installed the 2nd Vertex 120 (both are FW 1.5), enabled RAID in BIOS and created a RAID0 in the Intel RAID launch...
Backup and Restore
Windows 7 System Image - Restore Non-RAID to RAID 0+1
I created a windows system image with the backup and restore utility built into win7. This windows install is on a single hard drive. I built and onboard RAID 0+1 array and used the windows 7 install disk to restore the image on to the new RAID volume. Windows starts to boot up but the screen goes...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:26.
Twitter Facebook Google+