Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Missing winnsm32.rom file?

06 Jan 2011   #1

Windows 7 Home Premium 64-bit
Missing winnsm32.rom file?

Hi there! I'm new and I need some help
(Am I even posting in the right place?)

I have an Acer Aspire with Windows 7 Home Premium 64-bit and I've recently started to get a pop-up everytime I log in, saying:
"There was a problem starting winnsm32.rom
The specific module could not be found."

Now, I have no idea what this winnsm32.rom is, whether it's something that should be in my computer or not. I've tried to find information about it, but have failed to do so. Since I don't know much about computers (my dad usually helps me, but he's out of ideas too), I came to the conclusion that this might have had something to do with the spyware (?) Relevant Knowledge that I removed recently. Maybe it deleted something...?

Please tell me if there's some specific information of my computer that I should still mention!
Thank you,

Attached Images
Missing winnsm32.rom file?-winnsm32rom.png 
My System SpecsSystem Spec
06 Jan 2011   #2

Windows 10 Pro (x64)

What ever it is, it is not part of Windows. My brief searching hints at it being connected to malware.
My System SpecsSystem Spec
06 Jan 2011   #3

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

Hello Heidi and welcome to the Forum.
It is malicious software. I would strongly recommend that you download and install this free program and run a scan. See what that comes up with . I assume you have an up to date anti virus software running?
Here's the free download link;
Malwarebytes' Anti-Malware: Malwarebytes
Just scroll down and click on the Free edition download button.
My System SpecsSystem Spec

06 Jan 2011   #4

Windows 7 Home Premium 64-bit

Thank you for the quick replies!
Yes, I'm running an up to date McAfee Internet Security Suite. I will download the program suggested and run the scan. I'll get back if I encounter problems!
My System SpecsSystem Spec
06 Jan 2011   #5
Mike Connor

Several, including Windows 7 x64 Ultimate

It's malware, some info;


Don't download the software from that site, ( Prevx ), the firm seems reputable enough, but it is best to stick with things people know and can recommend in good faith.

Prevx - PC and Internet Security for Home & Families, Businesses, Enterprises, Banks, Financial, eCommerce, and their customers. also they will doubtless want money for their services.

The FREE Malwarebytes Anti Malware that Mitchell65 gave a link for is OK.

Regards....Mike Connor

EDIT: A little research shows that Prevx is not reliable. They do a free scan, and then ask you for money to remove the malicious software. Reputable firms don't run their businesses like that.
My System SpecsSystem Spec
06 Jan 2011   #6

Windows 7 Home Premium 64-bit

Thank you for the info, Mike.

The quick scan found 5 threats, three of which had to do with Relevant Knowledge. I removed them all, and everything seems fine at the moment.

Thank you all for the help!
My System SpecsSystem Spec
06 Jan 2011   #7

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

Delighted to hear that the problems seems to solved. Thanks for the feedback. When you have a problem solved just click on the red triangle at the top of each post and in the message box type "Solved". A mod will then put a green tick against the thread to let everyone know this thread is solved and doesn't need any further input. Then when the helpers look down the list they don't need to open a thread to see if someone is waiting for help!
My System SpecsSystem Spec

 Missing winnsm32.rom file?

Thread Tools

Similar help and support threads
Thread Forum
sfc "Cannot repair member file...Desktop.ini....file is missing"
No problems with my computer, but in the interest of PM after reading of problems here at 7f I ran sfc /scannow and got a whole lot of errors, every one of them related to the file Desktop.ini. Just one example from the CBS.log: 2014-11-22 11:19:45, Info CSI 000001ab Cannot...
Performance & Maintenance
Missing file mia.lib
Hi all, Been trying to install an update for the ASCOM astronomy common model platform and getting error message that the file mia.lib is missing. Does anyone know what this file is and if it should be installed by the Win 7 install or where I can find it, searched Microsoft site but no luck....
Installation & Setup
Missing File?
Never saw this before.
Chillout Room
Missing inf file
every-time i try to install the ATI catalyst driver, this error would come up "INF FILE IS MISSING" i downloaded a software that removes all of the ATI drivers and files, i used it to re-install the latest driver, people say this might be the source to the problem because these type of software...
BSOD Help and Support
Missing dll file?
On a recommendation from this forum I downloaded and installed software that will resolve a problem. Only one problem--the software fails to function due to a missing file: "msvcr80.dll". The author says the problem is mine and my system. However, I've searched my system and have found at...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:50.
Twitter Facebook Google+