Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: COM Surrogate Windows 7 64bit

25 Mar 2012   #21
writhziden

Windows 7 Home Premium 64 Bit
 
 

Download and install Malwarebytes and update it to the latest version. Start the program (do not start the trial), and run a full system scan for viruses/malware. Post back the results.

Also, do you have the same theme shared between the two computers? Is it a custom theme?

See if any of the steps (minus hardware upgrades) provided in Optimize Windows 7 resolve the COM Surrogate crash.


My System SpecsSystem Spec
.
25 Mar 2012   #22
PrinorB

Windows 7 Professional x64
 
 

Thanks. Malwarebytes didn't find anything.

That looks like a sweet list of optimization for general purposes also.

I have the feeling that windows should work with all of them enabled still because I didn't change anything from the default and on other computers all the transparency etc also works together with the windows photo viewer (at least I presume so...).

Things I can think of that are the same between the two computers are:
Is there anything on that list that you think might cause the problem?

Also on a different note; My friend has an old laptop which used to have windows vista home premium (I think 32 bit) and she still has a license key but not the install CD. She needs to reinstall this. I tried googling for ISO images but I can't say what is genuine and what isn't. Do you know where I could find a genuine version?

Thanks!!
My System SpecsSystem Spec
25 Mar 2012   #23
PrinorB

Windows 7 Professional x64
 
 

Oh; and I have the same mouse: Logitech M510
My System SpecsSystem Spec
.

25 Mar 2012   #24
writhziden

Windows 7 Home Premium 64 Bit
 
 

Unfortunately, the Vista version of the ISOs are no longer available to my knowledge. She could try posting in the VistaForums which are a neighbor site to these forums. There is not as much activity there, so no guarantees help will be given.

If anyone else knows of a genuine Vista ISO that is allowed to be linked, please share.


As to your problem, it could be the themes you use. Try a basic Windows 7 theme and see if it persists. If so, that would rule that out as a likely candidate. I am with you that it is likely something else underlying, but I am not able to discern what. Do you have any explorer based applications built in (winRAR, for instance, can cause problems like these if it is not functioning properly)? If you right click on a file, can you provide us with what options you are given? That may lend some clue to what might be interfering.
My System SpecsSystem Spec
25 Mar 2012   #25
PrinorB

Windows 7 Professional x64
 
 

Thanks for the tip! I'll tell her.

I tried a basic theme and it didn't work... Attached are screenshots for right clicks on Folders and a Word document for Work and home respectively (the text for the work Pc is weird because I connected remotely).

What I did for the moment is download Picasa and work with that. If I have time I can maybe reinstall windows from scratch on my home PC where I don't have to run around (that far) to get all the software back together. Then I could slowly build up the system and check at every step if the problem occurs.

If I was to do that, I need to two things though:

  • When I bought the PC pre-installed, will there be any issue when I reinstall windows? If not then I might need a Windows Home Premium SP1 ISO
  • One thing that bugs me is: My Laptopt came with a test version of Microsoft office Pre installed (in English; the language that I would like it in). I upgraded that with a license from a CD purchased in Germany. Because the test version was English, the language pack remained English. For my work PC where I used the same German office CD to install MS office, (it was one of those disks with 3 licenses) I had to buy an English Language pack. Now, if I was to reinstall windows on my Laptop I would need to install office from the CD and end up with having to buy another language pack. I could see two solutions (maybe you have another?):
    • I find out how I can get the original installation with the test office version back. The laptop did not come with an install DVD. Maybe I can ask someone if they provide ISO images...
    • OR is there any way of getting an official, free, English trial office version install file that I could then activate with the (German) key I have?
Sounds complicated. The thing is, so far the error is not THAT bad but now that I spent four days trying to fix it it would be nice to know what it was...
My System SpecsSystem Spec
25 Mar 2012   #26
PrinorB

Windows 7 Professional x64
 
 

Attachments...


Attached Files
File Type: zip Screenshots.zip (2.10 MB, 96 views)
My System SpecsSystem Spec
26 Mar 2012   #27
FliGi7

XP / Win7 x64 Pro
 
 

Quote   Quote: Originally Posted by PrinorB View Post

Things I can think of that are the same between the two computers are:
  • I have some of the same software c.f. list of software attached with some of my earlier threads.
I can't seem to find where you list your software. Could you list all of the software, to include any themes or tweaks, you have done on the fresh install of your system?
My System SpecsSystem Spec
26 Mar 2012   #28
PrinorB

Windows 7 Professional x64
 
 

Sorry that list was in another thread...

Here is a list both for home and for work including windows features that are turned on and off.

Other tweaks than that are
  • themes but changing my PC to a basic theme didn't change anything.
  • Make windows ask me before installing updates. (so disable "automatic" updates. I have been good on updating though.
  • I can't even think of anything else (maybe some energy things like "never shut down" etc)


Attached Files
File Type: zip Software Liste.zip (1.85 MB, 14 views)
My System SpecsSystem Spec
26 Mar 2012   #29
PrinorB

Windows 7 Professional x64
 
 

My System SpecsSystem Spec
26 Mar 2012   #30
Brds7t7

Windows 7 Pro & Ultimate (64-Bit) Retail, Windows 8.1 Pro (64-Bit) Retail
 
 

Hi PrinorB,

I did have that problem a few months ago and I tracked it down to the codec pack I was using (k-lite) which was causing the issue. But if you're getting that error on a clean install that's a different story.
My System SpecsSystem Spec
Reply

 COM Surrogate Windows 7 64bit




Thread Tools




Similar help and support threads
Thread Forum
"Com Surrogate Has Stopped Working" - Windows 7 Ultimate x32
A few months back I received an error message caused by an act that I can no longer recall. Ever since that day I have encountered hundreds of the same message and a few others every day, prohibiting me from playing games and using programs. During these months, I have read every forum, read...
General Discussion
Com Surrogate Stopped Working. Win7 Home Premium 64bit
Problem signature: Problem Event Name: APPCRASH Application Name: DllHost.exe Application Version: 6.1.7600.16385 Application Timestamp: 4a5bc6b7 Fault Module Name: RPCRT4.dll Fault Module Version: 6.1.7601.17514 Fault Module Timestamp: 4ce7ba59 Exception Code: c0020043 Exception Offset:...
General Discussion
COM Surrogate Error in Windows Photo Viewer
Hi Since last week I have been getting a COM Surrogate error in Windows Photo Viewer. I can see the photos in the Picture Library but when I open one up I cannot move onto the next photo without the Com Surrogate Error and Slideshow is not working either. I am not aware of anything being...
Music, Pictures & Video
COM Surrogate
Okay so I got a new laptop a few days ago and whenever I go through pictures it pops up with an error that says COM Surrogate has stopped working. Any idea on how to fix this. Help would be nice! New PC: Alienware M17x R4
BSOD Help and Support
COM Surrogate
After doing a disk cleanup and deleting "Thumbnails" without realizing it would cause this, I have started to get the message "COM Surrogate has stopped working" a lot of the times that I try to open images (and other people who receive this error report it to happen with videos/movies as well, but...
BSOD Help and Support
COM Surrogate crashes
Ok I installed the latest Shark007 codecs which were released last week I believe and I started getting some hard lockups with the message being "COM surogate has stopped responding". When these errors happened I couldn't do anything but puch the power button because Only the mouse was movable and...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:38.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App