Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: can't copy old windows files...access denied

14 Jan 2011   #1
trojannemo

Windows 7 Ultimate x64
 
 
can't copy old windows files...access denied

hey guys. i installed windows 7 pro x64 recently. i'm in the process of copying my own old windows xp files, as well as copying the backed up windows xp files from my friend's installation that were in my old hard drive.

i've been battling windows 7 with permissions left and right to copy the remaining files. i'm trying to delete my old windows installation folder. there's a file in sytem32 that's preventing me from deleting. i've established ownership, i've changed it so i have full privileges, i've changed it to enable sharing, disable sharing, i have UAC down to medium, still keep getting you need permissions and the try again message, and no matter how many times i click on try again it comes back up.

now this is also happening when trying to copy files from my friend's old installation to my portable hard drive. we're talking about movie files, folders, documents, etc. still keep getting permission requests and no matter how i go about it, it keeps asking again and again and the files never copy. i thought maybe if i renamed the documents and settings folder that i'm grabbing them from, but that made no difference.

it is so difficult to enjoy this new windows when at every step there is some assinine feature like this!

any help? thanks!


My System SpecsSystem Spec
.
14 Jan 2011   #2
DeaconFrost

Windows 7 Ultimate x64 SP1
 
 

Ah, one of the reasons I always avoid using the "My" folders, and just keep all of my data on a data drive. Anyway, for your own files, if you had used the same username and password as your old install, you might not have had the issue. When I do that, I can't ever replicate your issue. Since you mentioned already taking ownership, try turning UAC off for now, and see if that lets you do it.

As for your friend's files, did you taking ownership of them?
My System SpecsSystem Spec
14 Jan 2011   #3
trojannemo

Windows 7 Ultimate x64
 
 

yes i took ownership of the entire folder and the files inside. if i right click any one file it shows i have ownership of it. but wont let me move it to the other drive.

problem is neither now nor before have i used passwords in my account. previously it was my computer. now my wife and i built this so its "our" computer and the username changed. but no password in the previous account nor on this account.

i'll try disabling UAC and see how it goes. thanks.
My System SpecsSystem Spec
.

14 Jan 2011   #4
boohbah

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

Be aware turning off UAC ,resets your system restore points , leaving no restore points to go back to
My System SpecsSystem Spec
14 Jan 2011   #5
trojannemo

Windows 7 Ultimate x64
 
 

would have been nice if windows notified me of that.

anyways, made no difference. in trying to delete my old windows folder i get the following

"Folder Acccess Denied"
"You need permission to perform this action"

and then it tells me i need permission from MY OWN ACCOUNT to make changes to the folder.

i'm set to have ownership and full privileges. the files are in a secondary drive, not in the windows installation drive...yet i can't delete it...
My System SpecsSystem Spec
Reply

 can't copy old windows files...access denied




Thread Tools




Similar help and support threads
Thread Forum
Access denied registering dll files Windows 7 Pro 64
Hello, I've searched through the forum and have tried many of the solutions posted but still am being denied. I've registered the same dll files on other machines with no issues but on this clean install I've had no luck. Any help is appreciated. Thanks,
General Discussion
Error 5 (access denied) when starting Volume Shadow Copy service (VSS)
Firstly, apologies if this is in the wrong section - noob in this forum :) System: Win 7 Ultimate x64 on an HP Pavilion DV6. My account is the only proper user account on the laptop and is an admin account. In short, when trying to do a system restore, it come up with an error that the Volume...
Backup and Restore
Permissions Denied, can't copy my own files
I'm new to this site, so i apologise in advance if this is in the wrong section. On my external hdd, I recently noticed that one specific folder has reduced permissions ( containing my game ISO's ). I have tried just about every guide on how to set, change, add permissions for myself, all of...
General Discussion
Permission denied to access/copy files from my old computer
I built a new desktop and did a clean Windows 7 64-bit install. I hooked up the hard drive from my old PC, which had XP on it, so I could copy all the files over to my new hard drive. But when I try, I keep getting errors that I don't have permission to access the file or copy the file. I was...
General Discussion
Permission denied to copy my own files
Hi there, I know there have been a lot of tutorial/tips on how to deal with permission when you need to copy files on Windows 7. I have turned off UAC, take the ownership of the folder and all sub-folders/files ... but still I have not been able to copy quite a few files in one of my folder. ...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:54.
Twitter Facebook Google+