Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sidebar Memory Issues (Svchost.exe)

17 Feb 2011   #1
Rontro

Windows 7 Home Premium 64bit
 
 
Sidebar Memory Issues (Svchost.exe)

I am having an issue with physical memory being grabbed/hogged. I find that up to 75% of my 4GBs is being used by sidebar and svchost.exe. This memory leak ocurs even with only one gadget running. Also, the memory is not all taken all at once it is a slow process. I can reclaim this memory by closing all of my gadgets and by using Process Explorer to kill the offending svchost process. I am running a fairly fresh install (New Machine) of Windows 7 64bit, AMD Athon II X4 630 process, 4GB of ram.

I have Ran virus scans, Malaware bytes and Hitman Pro and found nothing. A reboot of system restores the memory as well. I am not sure where to turn next. I don't have any gadgets running now so that problem has a band-aide, but the svchost issue continues.

Thank you for any help offered.


My System SpecsSystem Spec
.
17 Feb 2011   #2
KazeNoKoe23

Windows 7 Professional x64 SP1
 
 

Do you have IE9 installed? For some reason it causes a massive memory leak in svchost.exe and sidebar.exe. I had the same problem as early as yesterday on both my Vista and 7 installs. After removing IE9, the memory usage went back to normal.
My System SpecsSystem Spec
17 Feb 2011   #3
kncowans

Windows 7 Ultimate x64
 
 

Hello all

Do you use the 'All CPU Meter' Gadget?

If so then there is a new version (3.4) which apparantly fixes an issue with IE9 and a Memory Leak.

Hope this helps.

Kevin
My System SpecsSystem Spec
.

17 Feb 2011   #4
Rontro

Windows 7 Home Premium 64bit
 
 

Both of these replies are true: I just installed IE9 and I am using a older version of All CPU Gadget. I will try the update gadget first and then move on to uninstall IE9. Thank you very much for the great suggestions.
My System SpecsSystem Spec
18 Feb 2011   #5
Rontro

Windows 7 Home Premium 64bit
 
 

This issue is resolved. Updating All CPU Gadget fixed the problem and I did not have to uninstall IE9 RC1. BTW you can not get the current version of the ALL CPU Gadget from Windows Live Gallery. I had to get it from ADDgadget.com. Thank you for the help.
My System SpecsSystem Spec
Reply

 Sidebar Memory Issues (Svchost.exe)




Thread Tools




Similar help and support threads
Thread Forum
One svchost.exe is using 148mb of memory. Do I need all this?
Can anyone tell me if I need all these highlighted services running all the time? Have Acer Aspire, Win 7 Home Premium, 64 bit, 8 GB ram. 1 T HD. Using Firefox 21. I have cable internet and just one computer. No networking. It doesn't seem to be affecting performance, just seems like way too much....
General Discussion
svchost.exe memory question
Is it usual for that process to take up 500-600K or memory? I don't recall seeing it take up that much space before. Just curiosity because if i run some program that requires lots of memory, it starts to lagg. Never had that happen before either.
Performance & Maintenance
svchost.exe high memory
Whenever I start my computer,I'm getting high memory usage on svchost.exe ImageShack® - Online Photo and Video Hosting I'm not so sure which info I need to provide,to continue troubleshooting so here is some: Nod32 antivirus,Q9650 @ 3.00GHz,8 Gig of ram,around 10Gig of free space at the system...
Performance & Maintenance
Sidebar memory leak?
hello im having problems with the sidebar.exe. Every time i log on after shutdown or logging off, sidebar starts eating up the memory and within a half minute my memory usage reaches 99%. because of this I have to end the process right when i startup. I made other accounts and sidebar works fine. ...
BSOD Help and Support
Svchost taking too much memory
my svhost process is taking too much Memory... making my computer lag..it havent happened any time before... http://www.pikipimp.com/pp/pimped_photo/s/image/52/806/368/Capture.PNG?ts=1264555978397:shock::shock::shock: please suggest a solution..
Performance & Maintenance
svchost.exe using lots of memory
Hello, I noticed my memory usage was at 42%, when it is usually 25-30%. I opened task manager and found 12 different processes of svchost.exe running. One of then was using 149,156 k of memory, from which I understand is a whole lot. Is this normal? And if it isn't how do I fix it? Thanks in...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:13.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App