Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Command Prompt is literally broken

25 Feb 2011   #1
Windows i7 920

Windows 8 Pro x64
 
 
Command Prompt is literally broken

My laptop:
Quote:
Windows 7 Professional x64 (build 7601 SP1 Beta)
Intel Core i7 740 QM
8 GB 1333 MHz DDR3 RAM
500 GB 7200 RPM HDD
I press Win + R and type cmd, then a console comes up. I went to flush my dns cache with ipconfig /flushdns then suddenly got an error saying that it is not a command. Well, wait what? I've used that many times in the past. Additionally, typing even basic bath commands fail. I tried typing help, same error. I even made sure I launched it as administrator. I also scanned my laptop for viruses/malware using three different scanners. Nothing came up (McAfee, MS Security Essentials, AVG Free)

Also, oddly enough, batch files still operate as usual. Also before accusing the beta service pack, I installed that a long time ago with absolutely no problems. Although, maybe an update did not install properly or something...


My System SpecsSystem Spec
.
25 Feb 2011   #2
Jacee
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

Try C:\Windows\system32\cmd.exe
My System SpecsSystem Spec
25 Feb 2011   #3
Windows i7 920

Windows 8 Pro x64
 
 

Quote   Quote: Originally Posted by Jacee View Post
Try C:\Windows\system32\cmd.exe
That is the same thing as Win + R and then typing cmd.
My System SpecsSystem Spec
.

25 Feb 2011   #4
logicearth

Windows 10 Pro (x64)
 
 

Check your environment variables, namely PATH.
My System SpecsSystem Spec
25 Feb 2011   #5
blakej777

Windows 7 home 64bit
 
 

If you type in "path" do you see C:\Windows\system32\?
My System SpecsSystem Spec
25 Feb 2011   #6
Orbital Shark

 
 

Quote   Quote: Originally Posted by Windows i7 920 View Post
Quote   Quote: Originally Posted by Jacee View Post
Try C:\Windows\system32\cmd.exe
That is the same thing as Win + R and then typing cmd.
What Jacee is getting at is that if typing the above works ok then you we can start looking at your environment variables....
My System SpecsSystem Spec
25 Feb 2011   #7
Everlong

 

Just sounds like your PATH is not there.

Easy way try and fix it is right clicking on computer>properties>advanced system settings>advanced tab>environment variables then in the system variables go to the path variable and click "Edit", then at the end paste

;%SystemRoot%\system32

Leave the ; on as that splits up paths.
My System SpecsSystem Spec
Reply

 Command Prompt is literally broken




Thread Tools




Similar help and support threads
Thread Forum
Command Prompt command <ipconfig> not working
when I open up my command prompt and type 'ipconfig' without the ' and press enter it returns the line: 'ipconfig' is nto recognized as an internal or external command, operable program, or batch file I am trying to find out the information I need in order to set up a static IP Address for port...
Network & Sharing
How to fix MBR through command prompt?
Question: What commands could I run in the command prompt during the system recovery? I try & run say "fixmbr" but it doesn't work. Say if I want to write a new master boot record how would I do that?
General Discussion
SSH command prompt
Is there any way I can use ssh or something similar to enter command line prompts from my Mac terminal, similar to SSH but windows commands? (From mac to a windows 7 desktop)
Performance & Maintenance
command prompt
Hi all i need you help me a thing :cry: I went to use autosave all text on command prompt (CMD), how can i do or use what command prompt cade for mark it autosave when i used command prompt. Example : Color 0a
General Discussion
Run administrative command prompt from command prompt
Ok So I got myself into a unique bind here. I was trying to install some custom system files (for a theme) and I did it wrong and now I cant open explorer.exe . I dont want to goto a backup because this is a easy fix. (in my view). So I need to know how to run command prompt with administrative...
General Discussion
command prompt bug ?
Hi, I just tryed to use cmd as usual but it seems that I can't explore an other HDD than C: It bugs me I don't understand why i'm the only user on my computer and I am admin on it I at home so it should work but when I type "cd d:" I get that : ...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:45.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App