Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Security issues (Access Denied)

16 Mar 2011   #11

Windows 7 Ultimate RTM (Technet)

Quote   Quote: Originally Posted by CrazyAwesome View Post
The owner is my PC and my only account. The copy of the hosts file, I compared all the security settings side by side. They are identical. Yet one I can edit and one I can't.
Try going to c:\windows\system32\drivers\etc at a command prompt and type

attrib hosts

does it show as below?

R C:\Windows\System32\drivers\etc\hosts

My System SpecsSystem Spec
16 Mar 2011   #12


It says
A C:\Windows\System32\drivers\etc\hosts
My System SpecsSystem Spec
16 Mar 2011   #13

Windows 7 Ultimate RTM (Technet)

I'm stumped. By default, the owner is "System" and read-only is set. I just unset my read only and made a change. No prompts for anything related to permissions.

Did you try using the Administrator account?
My System SpecsSystem Spec

16 Mar 2011   #14


The account I'm using is the only account on the pc. When I installed Win7 months ago, I just entered my name and thats it. Not other accounts present. Really appreciating all the help.
But im also stumped. Every guide I've seen online tells me just running notepad as admin will work. Yet it doesnt. Nothing works.
My System SpecsSystem Spec
16 Mar 2011   #15


Almost sounds like you're logged in using a temp account
My System SpecsSystem Spec
16 Mar 2011   #16


Well I surrender. I rebooted the computer and hey presto. I can now edit the file no problem. WTF
Many thanks for everyones input.
The most annoying part is I already tried rebooting once already and it didnt make a difference.
Another Windows mystery.
My System SpecsSystem Spec
16 Mar 2011   #17

Windows 7 Ultimate RTM (Technet)

Just a note, the Administrator account is there, but disabled by default. You have to go in and enable it to use it. Glad you got it sorted!
My System SpecsSystem Spec
19 Mar 2011   #18

Windows 10 Pro (x64)

All of this could have been avoided if you just dragged "hosts" from the directory it is in to your desktop, edit the file, then drag it back to the folder it was in. I've done this a dozen times and works every single time.
My System SpecsSystem Spec
19 Mar 2011   #19

Windows 7 Ultimate 64bit

To edit the host file I have always ran notepad or notepad++ with elevated admin permissions.
Then opened the host file "C:\Windows\System32\drivers\etc\hosts" made changes then saved.
My System SpecsSystem Spec
14 Jul 2012   #20

windows 7 ultimate 32bit

Had the same problem
My System SpecsSystem Spec

 Security issues (Access Denied)

Thread Tools

Similar help and support threads
Thread Forum
Simcity 4 Deluxe Edition Access denied issues
I have never had this message in the past, but everytime I click on the simcity 4 icon, I receive this message I have already attempted re-starting my computer, I have run as administrator several times, but I continue to receive the same message. Any aid would be greatly appreciated!
Security & Permissions Too good? - Error 5 Access is denied.
My not quite 3 months old Win 7 system has taken a notable dislike to me trying to install programs now that I have an actual need to burn some disks of the data and DVD kind. For certain programs I am getting that lovely little message box which states; "Unable to execute file in the temporary...
Cannot start Windows Security Center Services. Error 5 access denied
I had trouble updating the MSE definitions a couple of days ago and I tried everything to get it to update, something about no connection. I gave up and uninstalled MSE completely using Revo. From Microsoft's web site, I downloaded and installed the newest version of MSE and the definitions updated...
System Security
Win 7 - Local Security Policy, Access Denied
Norton/Symantec, in its ever-ibimitable wisdom installs its Internet Security and Utilities packages into a locked folder(s). By locked I mean that one CANNOT modify (Rename, Delete, etc) the installed folder(s) and any of its sub-objects. I AM an administrator user, so I SHOULD (expect to) have...
General Discussion
Access denied and user privileges issues
Hi, I am experiencing weird issues with my Windows 7 64bit Pro installation. Some, but not all, programs won’t start, giving me a “The application was unable to start correctly 0xc0000022 click ok to close the application” error. It seems that 0xc0000022 is linked to some kind of access denied...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:34.
Twitter Facebook Google+