Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: can't run programs from system32 with CMD

25 Mar 2011   #1

Windows 7 Ultimate x64 SP1
can't run programs from system32 with CMD

Please Help. I can't run any programs from system32 folder (like chkdsk or chkntfs) with Command Prompt (even in an elevated one and I turned off my UAC). It'll return like "''chkdsk' is not recognized as an internal or external command, operable program or batch file."

So I have to navigate to system32 folder first then using Shift+Right Click and select "Open command window here" then run the program from there

But using the usual Command Prompt, I still can run programs from Windows folder (like regedit)


My System SpecsSystem Spec
25 Mar 2011   #2

Windows 7 Ultimate

See if you can list the directory contents, from the cmd window.

My System SpecsSystem Spec
25 Mar 2011   #3

Windows 10 Pro X64

Also check the path environment variable. Just enter path from the command prompt. Make sure it has


in it. If not, add it via Control Panel, System, Advanced system settings, Environment Variables button. Scroll down to Path in the lower window, select it then click Edit. Be careful not to wipe it out completely as it's allready pre-selected.

On a clean install of Win 7 Ultimate x86, path is set to: C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\
My System SpecsSystem Spec

25 Mar 2011   #4

Windows 7 Ultimate x64 SP1

Thanks Ztruker. It works

Somehow the path value has changed to
C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\QuickTime\QTSystem\;C:\Program Files (x86)\Windows Live\Shared;C:\PROGRA~1\DISKEE~1\DISKEE~1\
My System SpecsSystem Spec

 can't run programs from system32 with CMD

Thread Tools

Similar help and support threads
Thread Forum
X:\windows\system32\cmd.exe - What is this...???
Hi, You'll have to excuse any shortcomings I have with my computer literacy. The other day my laptop slowed to a crawl so my wife hard-booted it. When I restarted it, it brings up a screen that says: Windows Error Recovery Windows failed to start. A recent hardware or software change might...
General Discussion
System32 Corrupt
I tried to install a Theme last night and I did something wrong I believe it has something to do with my explorer.exe. Anyway when I my computer started it shows a black screen, I didn't get any error though. I had to manually run explorer.exe with task mananger. Now when I tried to 'Optimize' my...
General Discussion
is system32/root/system32.exe a virus?
when i installed windows 7 any version after installing the drivers a dialog box poped up saying system32.exe has stopped working and many such box appeared at once....then when i got a software called combofix.exe which was a boon to me and ran then in the result it deleted ...
System Security
No default programs working. System32/disk error?
Roughly six hours ago I was using my computer and, with out warning, everything started crashing (including explorer.exe, chrome etc.). The only program that was still working (that I could see) was Skype, because I was talking to somebody while it happened. I tried hitting CTRL+ALT+DELETE. The...
BSOD Help and Support
Let <system32\startup.exe> run on 64-bit?
Hi, Installed win 7 64-bit the other day. Everytime after startup, as my desktop shows up, a prompt "can't verify the publisher of this program" (or something like that) comes up - click 'yes' or 'no'. Been chosing 'no' so far, not knowing if the program should be let loose or nor not:sarc:....

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:44.
Twitter Facebook Google+