Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: odd post/bios screen, plus no keyboard detected @ post

30 Mar 2011   #1
sinkheadhxc

Windows 7
 
 
odd post/bios screen, plus no keyboard detected @ post

i had recently built a new computer. after installing windows 7 everything was fine, except for during start-up it'd say 'no keyboard deteced'. which it wasn't detecting it because i couldnt acess bios during this. once i came to the windows log in screen, it was then reading the keyboard.

a few days ago i had a power outage during a thunderstorm and now a screen appears when turning on my computer giving me 2 options somehwat like 'continue start up' and 'enter a set up'. these are extremely general ideas of what it says but its not the usual 'start windows normally' screen. i would look but i'm currently at work since i cannot access the internet at home due to these problems lol.

the problem with this screen appearing is that since it is not detecting my keyboard at post, i have no where else to go. i've tried every usb port, as well as a ps/2 keyboard.

i either a. need to figure out how to get past this screen or not have it appear at all or b. figure out how to get it to detect my keyboard.

if you have any suggestions or info i'd really appreciate the help.

thanks.


My System SpecsSystem Spec
.
30 Mar 2011   #2
Shootist

Windows 7 Pro x64
 
 

you could try removing the CMOS battery on the motherboard and using the jumper to reset the BIOS to factory defaults.

Always us a known good PS/2 keyboard. USB is OK after you have everything setup but unless you enable Legacy USB support in the BIOS the USB keyboard may not be seen by the BIOS (I've had this exact problem).

If the PS/2 keyboard is not seen when plugged into the keyboard PS/2 port move it to the PS/2 mouse port.
My System SpecsSystem Spec
30 Mar 2011   #3
sinkheadhxc

Windows 7
 
 

ok that sounds good. someone else recommended the cmos restart but i didn't know to remove the battery AND hit the jumper. do i hit the jumper before i remove the battery, after, or when i reinstall the battery?
My System SpecsSystem Spec
.

30 Mar 2011   #4
Shootist

Windows 7 Pro x64
 
 

Usually all you have to do is move the jumper to the CLEAR position. Removing the battery is just another way to reset it so doing both should put everything back to default.

Best to read the manual.
My System SpecsSystem Spec
30 Aug 2013   #5
swaachhand

Windows 7
 
 
Keyboard not detected i bios

I have a logitech keyboard for around 5 yrs And has been using it since. But suddenly in bios it is not detected that means I can't use the customary DEL key to enter bios. But its working fine when the windows starts. I have also updated the bios but the problem still persists. Kindly help
My System SpecsSystem Spec
Reply

 odd post/bios screen, plus no keyboard detected @ post




Thread Tools




Similar help and support threads
Thread Forum
No USB at POST after BIOS update
I updated the BIOS on a Gigabyte GA- MA790X (AMD socket) motherboard and my USB keyboard will no longer trigger BIOS access. The system still boots correctly and the machine is very stable with no other issues. But it sucks having to keep a PS2 keyboard around in order to access the BIOS. ...
PC Custom Builds and Overclocking
Start-up BIOS/POST Screen Message(s) Too Fast to Read
ASUS M5A88-V EVO mobo AMD FX4130 CPU W7 Pro 64-bit AMI BIOS On boot-up, the AMI POST screen flashes by so fast there's no way to read it. I have tried various BIOS Quick-Boot, Full Screen Logo, Force BIOS settings, together with mashing the keyboard's Pause/Break key. The 'del' key only...
Installation & Setup
Bios post screen too fast
Bios post screen too fast. I can not stop post screen with pause break key on my keyboard... My motherboard is asus z97-k. Thanks.
Hardware & Devices
POST Bios screen logo change
Hi There, I have Dell Optiplex 3010 machine in which the POST bios logo (not windows splash screen) appears some other instead of Dell manufacturer logo. How can i change that back to default so that when POST happens i can see the Dell logo?? I have tried reformatting the machine but still the...
Customization
Problems with Nvidia gpu post BIOS system BIOS update.
Hello all, this is my first time posting here so please forgive any mistakes/oversights. I've just updated my Samsung laptop's system BIOS via their software update program, and my Nvidia GPU (GT 650m DDR3) no longer seems to work. The Nvidia control panel is still there, and it still gives me...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:50.
Twitter Facebook Google+