Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: windows cannot access the specified device, path or file

12 Apr 2011   #1

windows 7 have no idea
windows cannot access the specified device, path or file

Hello Everyone. I am a 72 year old man who has tried to get to grips with computers since age of 60.

Hopefully someone can help - I have looked for an answer online but most of either does not work or is very complicated for your average man.

Windows 98 was the best operating system, everyone knows that.

Windows 7 has been treating me fine until recently.

Over the last week, 4 or 5 different programs that I have been using , wont load. They come up with the error message in the subject of this post. And it says i may not have permission to view the files? These are programs i downloaded such as skype, vlc media player, google talk, audacity, utorrent. Things like that. Only 1 did it at first, now 5. Really annoying and I cant see a reason for it. So I usually will have to download the program again, but I cant keep doing that and it doesnt always work anyway.

One idea i had , i thought it might be a problem to do with AVG virus killer thing.

I have AVG free virus killer thing but it keeps crashing. It says many files are unhealable cos theyre unabale to locate the file. and also it indicates that there is a problem with one of the AVG files. Sometimes avg wont respond . (it says not responding)

Does anyone have an idea of what I should look into ? I never had a problem with windows 98 until they started making stuff that only runs on later versions. I used to play worms on windows 98 for 8 hours a day.

Simon - new member of this seven forum.

My System SpecsSystem Spec
12 Apr 2011   #2

windows 7 have no idea

i would like to add. The programs that dont work and come up with the error message, they used to have a proper icon . But now they have changed. They have changed to a white icon with a window with 6 little icons inside.

My System SpecsSystem Spec
12 Apr 2011   #3
Mike Connor

Several, including Windows 7 x64 Ultimate

First of all, check your system to see if it is being affected by malware.

Download the free version of this;


and run a FULL scan. Post the log results here.

Regards....Mike Connor
My System SpecsSystem Spec

14 Apr 2011   #4

windows 7 have no idea
scan results

Here are the results. Should I click on remove selected? Thanks

Malwarebytes' Anti-Malware

Database version: 6350
Windows 6.1.7600
Internet Explorer 8.0.7600.16385
14/4/2554 12:51:27
mbam-log-2554-04-14 (12-51-15).txt
Scan type: Full scan (C:\|D:\|)
Objects scanned: 231921
Time elapsed: 4 hour(s), 7 minute(s), 12 second(s)
Memory Processes Infected: 2
Memory Modules Infected: 0
Registry Keys Infected: 2
Registry Values Infected: 0
Registry Data Items Infected: 4
Folders Infected: 2
Files Infected: 13
Memory Processes Infected:
c:\program files\relevantknowledge\rlservice.exe (Adware.RelevantKnowledge) -> 2132 -> No action taken.
c:\program files\relevantknowledge\rlvknlg.exe (Adware.RelevantKnowledge) -> 3404 -> No action taken.
Memory Modules Infected:
(No malicious items detected)
Registry Keys Infected:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RelevantKnowledge (Adware.RelevantKnowledge) -> No action taken.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{d08d9f98-1c78-4704-87e6-368b0023d831} (Adware.RelevantKnowledge) -> No action taken.
Registry Values Infected:
(No malicious items detected)
Registry Data Items Infected:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Security Center\AntiVirusDisableNotify (PUM.Disabled.SecurityCenter) -> Bad: (1) Good: (0) -> No action taken.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Security Center\FirewallDisableNotify (PUM.Disabled.SecurityCenter) -> Bad: (1) Good: (0) -> No action taken.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Security Center\UpdatesDisableNotify (PUM.Disabled.SecurityCenter) -> Bad: (1) Good: (0) -> No action taken.
HKEY_CLASSES_ROOT\regfile\shell\open\command\(default) (Broken.OpenCommand) -> Bad: ("regedit.exe" "%1") Good: (regedit.exe "%1") -> No action taken.
Folders Infected:
c:\program files\relevantknowledge (Spyware.MarketScore) -> No action taken.
c:\programdata\microsoft\Windows\start menu\Programs\relevantknowledge (Spyware.MarketScore) -> No action taken.
Files Infected:
c:\program files\relevantknowledge\rlservice.exe (Adware.RelevantKnowledge) -> No action taken.
c:\program files\relevantknowledge\rlvknlg.exe (Adware.RelevantKnowledge) -> No action taken.
c:\Users\administrator\AppData\Local\Temp\~os902E.tmp\rlvknlg.exe (Adware.RelevantKnowledge) -> No action taken.
c:\Users\administrator\AppData\Local\Temp\~os902E.tmp\rlvknlg64.exe (Adware.RelevantKnowledge) -> No action taken.
c:\program files\relevantknowledge\rlls.dll (Adware.RelevantKnowledge) -> No action taken.
c:\program files\relevantknowledge\rlls64.dll (Adware.RelevantKnowledge) -> No action taken.
c:\program files\relevantknowledge\rlvknlg64.exe (Adware.RelevantKnowledge) -> No action taken.
c:\program files\relevantknowledge\nscf.dat (Spyware.MarketScore) -> No action taken.
c:\program files\relevantknowledge\rloci.bin (Spyware.MarketScore) -> No action taken.
c:\programdata\microsoft\Windows\start menu\Programs\relevantknowledge\about relevantknowledge.lnk (Spyware.MarketScore) -> No action taken.
c:\programdata\microsoft\Windows\start menu\Programs\relevantknowledge\privacy policy and user license agreement.lnk (Spyware.MarketScore) -> No action taken.
c:\programdata\microsoft\Windows\start menu\Programs\relevantknowledge\Support.lnk (Spyware.MarketScore) -> No action taken.
c:\programdata\microsoft\Windows\start menu\Programs\relevantknowledge\uninstall instructions.lnk (Spyware.MarketScore) -> No action taken.
My System SpecsSystem Spec

 windows cannot access the specified device, path or file

Thread Tools

Similar help and support threads
Thread Forum
Windows Cannot Access The Specified Device, Path, or File. You May N..
It literally took me around 30hrs to fix this problem so I hope my trial, anguish, and error will help others. It truly is a PERMISSIONS PROBLEM. Go to the PROGRAMS FILES folder in C:, and find the folder for the program you're having this error for. Right click the folder, select properties,...
General Discussion
Windows cannot access the specified device,path or file
Help! I've just done a fresh install of windows 7 on one of my computers to pass over to my sister as a gift. I set it all up at mine, updated all drivers and created an image thinking it was all ready to go...i was wrong. I unplugged the pc, took it over to hers, plugged it in and it...
General Discussion
windows cannot access the specified device path or file.
Hello, I have an encrypted USB by 'Safend data protection agent'. I have been using this software for some time however yesterday windows gave me the error 'windows cannot access the specified device path or file. you may not have appropriate permissions to access the item'. I tried a system...
Hardware & Devices
Windows cannot access the specified device, path, file.
I know there was a thread a long time ago about this, but my situation is a little different. I downloaded Abode Masters Collection CS6 and it worked great until I restarted my computer. When I went to access the folder it showed "empty". The files are still in my Programs, but i can't access...
General Discussion
Windows cannot access the specified device path or file
Hello I have just installed a fresh copy of windows 7 Ultimate 64 bit. After configuration is done, i am not able to access any folder or any programs not even control panel at all, its giving me the message "Windows cannot access the specified device path or file. You may not have appropriate...
Installation & Setup
windows cannot access specified device, path or file.
im running 7 rc1 and this is the first time ive come across this. this is on a local drive and i have ownership of the files but i cannot open them. any idea how to unblock this?
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:08.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App