Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Strange misconfiguration of settings

02 May 2011   #1

Windows 7 Professional Service Pack 1 32-Bit
Strange misconfiguration of settings

Hi guys,

After a merry go round with 1st line MS support suggesting irrelevant Mr. Fixits etc, I thought I'd turn to you all to get to the heart of a solution. I kindly appreciate any assistance in manually returning my machine to a normal state.

In the last week of Sp1 updates, my machine has suddenly become unable to open certain applications which used to work fine. Two I am aware of are:

1. Any OpenOffice executable (e.g. scalc.exe, swriter.exe, etc) - Upon launch, error displayed is "The application has failed to start because its side-by-side information is incorrect. Please see the application event log or use the command line sxstrace.exe tool for more detail." After uninstalling it and associations going to WordPad, I'm getting the same error when clicking on an RTF file for example, but WordPad starts anyway. WordPad opens fine when manually opened. Not so with OpenOffice, which doesn't open.

2. Adobe Reader X - Upon launch, error displayed is "Adobe Reader Protected Mode - Adobe Reader cannot open in Protected Mode due to a problem with your system configuration. Would you like to open Adobe Reader with Protected Mode disabled?" Consequently, if we select the option "Open with Protected Mode disabled" and continue, an error appears: "Fatal Error - Acrobat failed to load its Core DLL".

As an attempted solution, I've un-installed both Adobe Reader X and OpenOffice, restarted, and attempted to re-install from freshly downloaded installers. The exact same errors persist.

Causes? I'm not sure which is the cause of my problems, but two notable things I recall in the last week was a series of automatic Win 7 updates being pushed to my machine, and also the automatic detection and removal of malware (Dynamer!.dtc) by Microsoft Security Essentials. So I suspect it might be Security Essential's automatic removal of this not being complete due to unexpected behaviors of this resilient trojan, or a disruption in MSE's removal process due to Windows 7 having been in an unrestarted state between a series of updates awaiting configuration, or maybe it's totally unrelated to this and just some messup purely of the Windows updates, or other.

But all I want is a solution! I need to be able to open Reader and OpenOffice after installing them. I hope I can avoid having to do a re-format and clean-install of Win 7 again, given that sometimes people say when Sp1 is installed you can't Repair the installation, but I don't know, I haven't tried , maybe I should or is there another way?

I'm not a super power techie beyond the above but I can follow instructions well; any help in returning my operating system to normal so I can successfully launch these applications would go a long way.

Thanks and regards!

My System SpecsSystem Spec
02 May 2011   #2

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, 64-bit

Have you done a system restore to a date prior to the beginning of the problem?

Have you run sfc /scannow from a command prompt?

Have you done a full malware scan?
My System SpecsSystem Spec
02 May 2011   #3

Windows 7 x64 Ultimate

OpenOffice is complaining about a missing libc library of the specific version it was compiled against most likely Or some common control lib. Don't know why an update would break it but reinstalling OO may fix the problem. The installer should re-install the proper library.

Don't know about #2 though
My System SpecsSystem Spec

02 May 2011   #4

Windows 7 Professional Service Pack 1 32-Bit

Ignatzatsonic: Tried System Restore now - the only previous restore point before the updates is like, a year ago when I first installed Windows, so that's out. After the original trojan was removed last week, full scan with Microsoft Security Essentials and MalwareBytes found no threats, so there's likely no actual malware left on my machine. Have just run SFC /scannow... no integrity violations found.

Fseal: "As an attempted solution, I've un-installed both Adobe Reader X and OpenOffice, restarted, and attempted to re-install from freshly downloaded installers. The exact same errors persist." So I conclude that the problem is a Windows one as it retains the same problem after re-installing these applications.
My System SpecsSystem Spec
02 May 2011   #5

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, 64-bit

Have you considered a repair install? I've never personally done it, but it seems to be the last resort other than reinstalling Windows from scratch. You might uninstall Adobe and Open Office before you begin if you try it.
My System SpecsSystem Spec
02 May 2011   #6

Windows 7 Professional Service Pack 1 32-Bit

Thanks for those tips guys; I was hoping to exhaust all ideas before trying the Repair Install, as it means I have to free up 9 gigs of hdd to work and then might tell me it won't since I've patched windows already with SP1. I guess I'll have to make time for that in the coming days unless someone else posts who'se seen this thing before or something. Best
My System SpecsSystem Spec
02 May 2011   #7

Windows 10 Pro X64

What about something like this:

Uninstall Open Office
Uninstall Adobe Reader
Uninstall SP1

Install Open Office
Install Adobe Reader or Foxit PDF Reader

If they work, create a System Restore point, then install SP1.

BTW: Installing SP1 should have created a System Restore point. Did the trojan removal wipe out restore points?
My System SpecsSystem Spec
03 May 2011   #8

Windows 7 Professional Service Pack 1 32-Bit

Thanks Ztrucker,

I'm going to give that a shot and post back. Strangely, besides the restore point from a year ago, the most recent (and only other) one I could find was created after the removal, not after SP1.

My System SpecsSystem Spec
03 May 2011   #9

Windows 7 Professional Service Pack 1 32-Bit

It didn't work - uncannily, the problem remained. But your suggestions helped me get to a solution... I am really happy to say, all problems gone!

I tried your initial suggestions Ztruker:

Uninstalled Adobe Reader 10.0.1
Uninstalled LibreOffice
Uninstalled all 15-20 Windows & Security updates installed since problems began Apr 27 including SP1
Restarted machine

Then to my surprise - Windows 7 updates are like malware themselves, even after uninstalling all of them and restarting, not only did the same ones reinstall on reboot, but something like 3x the original number of updates were installed, including Hotfixes etc!!!!! What the hey!

Fortunately after turning off automatic updates, I caught SP1 before being reinstalled, and unchecked all.


Installed LibreOffice
Installed Acrobat Reader 10.0.1

Tested launch --- same problems. That got me thinking hmm, if SP1 is uninstalled but these other updates were, maybe it was a problem with one of those other series of updates. So I investigated their descriptions and found one related to Visual C++, which I found a little strange, but thought may have something to do with applications not running right. So I googled for both my problems. And it was really hard to find a solution, but bingo:

I found a post on MS Answers that suggested uninstalling and reinstalling Visual C++ 2008 to refill missing libraries. I looked and found in my Installed programs list, something strange - Microsoft Visual C++2008, and an update to that KBXXX, Microsoft Visual C++ 2005, and an Update to that too. The updates were installed at the same day Windows Updates were delivered. Something with either windows updates, the trojan removal, or the proximate timing of both, led to MS probably delivering nonstandard fixes/updates that led to wrong library info. I just uninstalled all 4 - given that Win 7 should include Visual C+ 2010 and doesn't need these old ones - and presto! LibreOffice, Wordpad, and all apps open fine now. If any still gives a problem I'll just reinstall the latest version(s) of Visual C++.

Except for Adobe Reader X ... which stayed dysfunctional. Using goole search tools to find most recent entries in the last week, I managed to land on a fresh post on the Adobe support site:

Announcement: Would you like to help us improve Adobe Reader?

Hi All,

We have had a few bug reports related to Adobe Reader X protected mode coming in from you in this forum. We have addressed a large number of them in our upcoming Reader update and we would like to hear your feedback.

To that extent, we would like to invite you to the Adobe Reader Prerelease program and try out the latest build. To participate, please fill in the form available at interest and indicate Adobe Reader as the product of your interest.

We look forward to your active participation, feedback and help towards making Reader a better product.

Thanks and regards,
Adobe Prerelease Team

So these turned out to be two separate issues that happened to come at the same time, confusing the source.

I'm now reactivating automatic updates and reinstalling all updates.

Hope this benefits other Internet users in the future who have the same problem and may be helped by this, as I found a lot of past frustrated ones on the net with no answers on forums to this problem including this site.

Thanks to all who contributed. Much appreciated.
My System SpecsSystem Spec

 Strange misconfiguration of settings

Thread Tools

Similar help and support threads
Thread Forum
Cannot see Multimedia Settings under "Change advanced power settings"
I have already clicked "Change settings that are currently available" but it still does not show it, restarted the PC and still same result. MSE disabled Windows 7 Starter 32-bit Power Plan: High Performance System Model: HP Mini 110-3500
General Discussion
Strange dates and settings
So I have all my systems to tell me if there are updates, but that I get to chose which ones to install. But in the past month something strange has happened to one system and I have not seen this. I was wondering why the computer had none of the recent Nov. updates advising me. Dug around and...
Windows Updates & Activation
Windows 7 Regional Settings and Office 2010 Language Settings
I need to know if the Windows 7 Regional settings has any affect on Office 2010 language settings. If so, how? Heather
Microsoft Office
Strange language in power settings?
The power options settings in the first option shows a strange language...I dont know exactly what it is. Can anyone explain to me this and how i can change it to normal? It was not like this before. Here is what I am talking about:
General Discussion
Strange Account That Only Appears When I Change Parental Settings
Hi guys. First off, first post officially :D. I have been trolling this website since I started working with windows 7 the large community is very helpful! Anyways, I have an account that I cannot edit or delete. My computer is not hooked up to anything else that could put it there. I suspect it to...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:59.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App