Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Shift+Delete problems and reappearing files after deletion

09 Jun 2012   #21

W7 Pro SP1 64bit

Welcome to the Seven Forums :-)

When you say that "it usually resolves itself after a reboot" - are you saying that the issue stops for a while or are you saying the a deleted file goes away, comes back and then goes away again after a reboot?

Just grasping at straws here: Do you have any hard drive encryption software installed?

My System SpecsSystem Spec
09 Jun 2012   #22

Windows 7 Professional x64

The file goes away, comes back, then goes away after a reboot. The fact is, the file isn't really there when it "comes back", it's just still being displayed as being there. Problem is, it won't let me overwrite the file until it disappears fully.

And no, I'm not using any encryption software. I've had the issue persist through a new install of windows. It could be some software conflict or something, but idk what would be conflicting.

Also, it's not a memory issue or HD space issue because I'm running 12gb of ram, and not even half of it it's being used, and the HD has about 100gb free.
My System SpecsSystem Spec
09 Jun 2012   #23

W7 Pro SP1 64bit

Does the problem exist in the safe mode?

I think it would be interesting to know what program is keeping you from overwriting the file until it goes away... it is probably the OS - i.e. Explorer. You might try installing Unlocker - see this post (below the video) for warnings about the install process. Once Unlocker is installed, right click on a file that should be gone and see what program (if any) shows to have a handle open on the file.
My System SpecsSystem Spec

10 Jun 2012   #24

Windows 7 Professional x64

OK, well I kinda accidentally fixed the issue.

I downloaded that Unlocker program, but it wasn't in the right-click menu like it was supposed to be. So I was going to reboot, assuming that maybe part of the program would finish installing after a reboot.

In this specific case, the file I was having issues with was in my Dropbox folder and, since it had been changed, it was waiting to sync to Dropbox. I was also running a virtual machine within VMWare, so I had to shut down the VM before restarting the physical machine. As soon as I suspended the VM, the file synced to Dropbox.

So for some reason, it seems that VMWare was the program that had the file locked. I'm not sure exactly why, but at least now I know. Thanks for your suggestions! They didn't directly find a solution but, in a way, they did eventually lead to me figuring it out.
My System SpecsSystem Spec
10 Jun 2012   #25

W7 Pro SP1 64bit

In case others find this thread like you did - I should have mentioned that Unlocker can also get to a file via a browse function. Just open the Unlocker app via the Start menu and navigate to the file or folder of interest.

Edit of old post: You need the 64bit version of Unlocker to be able to use the context menu in the 64bit Windows Explorer.
My System SpecsSystem Spec
01 Apr 2013   #26

Win 7 Embedded x64

Sorry for resurrecting this thread - but I have no choice. I have been building a Win 7 Embedded x64 image for distribution and this exact bug has appeared on three separate builds so far.

This only affects executable files when shft-deleted. The files are deleted, but they exist as ghosts in Explorer for 30 seconds to five minutes before disappearing. During that time, you cannot create a new file with that name and extension without getting an access denied error. Attempts to run the deleted program fail without a message.

For a while, I thought it was a bug in the file-based-write-filter - but it happened on one machine before we had even configured or enabled the fbwf.

I confirmed with Process Explorer that the program file isn't running when the error occurs.
My System SpecsSystem Spec
16 Sep 2015   #27

Windows 7 Ultimate x64
Possible solution

I know this thread is ancient, but it still shows up in search results for this issue so I felt that it would be good to post this here:

I had this issue happening to me on a Virtual Machine running Windows Server 2008 R2. I found that the "Application Experience" service was disabled and that was causing Windows Explorer to maintain locks on executable files while it waited for requests to the service to time out.

Enabling the service and starting it seems to resolve this issue for me. I hope this helps others too.

SQL Dude
My System SpecsSystem Spec

 Shift+Delete problems and reappearing files after deletion

Thread Tools

Similar help and support threads
Thread Forum
Ctrl shift delete isn't working in firefox
So I just tried the ctrl shift delete thing in firefox and it isn't working. I have version 34.0.5
Browsers & Mail
Anybody know of a way I can redirect the "Shift-Delete" shortcut to just normal "Delete"? Or just disabling that shortcut. Because I have a very bad habit of deleting files permanently, and deleting very important files by accident, and I've tried multiple file recovery techniques. Thanks!
General Discussion
shift and delete accident
ive just managed to delete the whole of my lossles music collection by using shift and delete on the folder (wasnt concentrating) can i get it back? thanks
General Discussion
Unable to delete files and such. Problems with privilages?
So, lately my Win7 started acting weird. I'm not able to delete or rename files that I have used recently. Let's say I run File.exe, close it and I want to delete/rename this file. Sometimes I'm trying to do that I get error about something that couldn't delete file because it's in use. It also...
General Discussion
Folder deletion problems
Hi everyone, I wanna start with "i rarely use forums cause I am lazy n all, but this problem has been testing the limits of my patience so much that I think i am finally fed up with it" Now, to the point: While trying to delete a folder(don't remember about files..) I occasionally get shown...
General Discussion
Problems with shift delete
Hi, I'm having a weird problem. Often, not always, when I try and delete one or serveral files with shift-delete nothing happens. It is obvious that the system has registered the command because when I open task manager there is a process, inapplications, called "delete file". I can work around...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:12.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App