Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't delete folder - access denied

14 May 2011   #1
Fleshcrawl

Windows 7 Professional 32bit
 
 
Can't delete folder - access denied

Hello!

I have a small issue concerning deleting folder. Here's situation:

I had a folder that I wanted to delete. I used shift+del combo for instant deletion, but than issue occured. Basicly, folder stayed, yet files deleted themselves. And when I try to delete the folder, it says I need administrator privilegies, which after clicking yes it says I don't have, eventhough I'm the only user on computer and my account is set up under administrator.
I can't even open folder, since I get error message as followed:

E:\Directory (name of directory I want to delete) is not accessible.

Access is denied.

I checked forums around, some people are saying just to make another identical folder and Windows will interpret them as 2 diff folders, but it didn't work for me.

Any suggestions?:P


My System SpecsSystem Spec
.
14 May 2011   #2
StalkeR

Windows 10 Pro x64
 
 

Hello there. You should try to delete it with Unlocker. But first follow this tutorial to Take Ownership to that folder.
My System SpecsSystem Spec
14 May 2011   #3
Fleshcrawl

Windows 7 Professional 32bit
 
 

Thank you very much. WOrked like a charm
My System SpecsSystem Spec
.

14 May 2011   #4
StalkeR

Windows 10 Pro x64
 
 

You're welcome!
My System SpecsSystem Spec
15 Jan 2013   #5
aboomarali

Windows 7, 64 bit home basic
 
 

It works with me 2, thanx
My System SpecsSystem Spec
29 Apr 2014   #6
bovoril

64 bit Win7
 
 

I also was having the same problem and went through the taking rights of folder, etc. The folder (C:\example) would not share either.

Strangely the next day when I came back to the computer the folder was deleted and another experimental folder was sharing which it wouldn't do earlier. Its almost like the explorer did not update the desktop visual screen but the folders were actually deleted and shared. One thing I noticed the previous night was the folders properties showed zero bytes, when I know there had been 700 Mb at least, so it was a sign....weird
My System SpecsSystem Spec
13 Dec 2015   #7
roor

Windows 7 64bit
 
 

I found an easier tool, tried it and it can reset owner permissions to any file or directory. It also supports giving permissions to directory including all sub folders and files.


Here
BeOwner - Mass file permission reset tool
My System SpecsSystem Spec
Reply

 Can't delete folder - access denied




Thread Tools




Similar help and support threads
Thread Forum
Delete folder/files - access denied
My PC originally came with a normal SATA HD with Windows 7 installed. Then I got an SSD and did a fresh installation of Windows 7 on the SSD. The SSD is labeled C: while SATA HD is D:\ Now I am trying to delete the SATA's folders:
General Discussion
Folder access denied, cannot rename or delete
Win 7 Premium 64, updated, logged in as Admin. Currently: C:\Users\Public Documents.........I have taken ownership Public Documents\Properties shows: General- Public Documents Sharing- Public Network Path:...
General Discussion
Unable to Delete Folder from Desktop: Access Is Denied?
I had a folder on my Desktop that just won't delete. It was apparently being shared with my Xbox360. I right-clicked it, pressed Delete, and it said it was being shared and if I was sure I wanted to do it anyways. So, of course, I said Yes. It deleted everything within the folder, yet the folder...
Software
Can't delete folder - access denied (despite attempts to fix)
I'm trying to delete an obsolete directory. When I try to do so, I get a message "Folder access denied: You require permission from Administrators to make changes to this folder." Based on forum advice for a similar problem that worked in the past, I did the following: Right-click the...
System Security
I cannot delete a particular file Access Denied
I am tryiong to save, delete or overwrite the file "Clear Print Spooler.bat" in C;\windows\system32 and in each case get "ACCESS Denied" error. I have tried the above in the command window with admin. priviledge. Same error. I had added a line that contained the word "Runas". Now I try to remove...
Security Basics


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:53.
Twitter Facebook Google+