Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Canīt Delete Folder. You Need Permission.....

15 Jul 2009   #11


Doing it from command shouldn't make a difference since it calls the same signal.

Are you sure you took ownership properly?

Right-click folder -> Click Properties -> Select Security tab -> Click Advanced button -> Select Owner tab -> Click Edit button -> Select your username or Administrators (if you are an Admin on your system) -> Click OK -> Click OK again. Now change the permissions by clicking the Edit button -> Select Administrators -> Check the Full Control checkbox under allow -> Click Apply -> Select your username -> Check the Full Control checkbox under allow -> Click Apply -> Click OK -> Click OK.

You should now be able to delete it without the permissions issue. Use Unlocker if needed.

My System SpecsSystem Spec
15 Jul 2009   #12

Windows Vista, Server 2008, Leopard, Suse

yeah calling it from cmd shouldn't make a difference, so surely the persmissions are wrong.
My System SpecsSystem Spec
15 Jul 2009   #13

Windows 7 RTM 64-Bit

I have done exactly as you discribed but i still get that message.
Maybe i am a idiot but i cant get unlocker to do anything it says it should be put into the explorer shell but it isīnt. have tried restarting but it doesīnt appear.
My System SpecsSystem Spec

15 Jul 2009   #14


That's odd. The only alternative I can think of is using PowerShell. I'm certainly no pro with PS, so here's a link to the remove-item command within it.
My System SpecsSystem Spec
15 Jul 2009   #15

Windows 7 RTM 64-Bit

Okay finally got it away. Hereīs what i did, i found a norton ghost recovery disk (which i have not been using for years) and booted into that. And from there i was able to delete the folder. So this topic is solved. Anyway thanks for all the help.
My System SpecsSystem Spec
10 Dec 2009   #16

Windows 7 Home Premium x64, Mac OS X 10.6.2 x64

just found that. tuneup utilities wouldnt delete it, so i tried safe mode and that worked.
My System SpecsSystem Spec
12 Mar 2010   #17

Windows 7
Deleting folder in CMD

OS: Windows 7

Start - type CMD


Click to open

you may find

C:\Users\Your Name>

Type again that i.e.

C:\Users\Your Name>cd c:\

You will see command


Type as below (in case folder is in Program Files (x86) in the command prompt)
(Let us take folder name as "trademanager" and it is to be deleted)

C:\>cd Program Files (x86)\del trademanager

It will ask Y/N/ type Y and press <enter key>

Note: You must re-check in command prompt whether the folder appears. In case it appears - does not matter

Repeat as above

Then close cmd

Open explorer - you may find that folder - just right-click- delete.

Folder will be deleted.

Restart PC/Notebook

Best of luck
My System SpecsSystem Spec
12 Mar 2010   #18

Windows 7
Deleting folder in CMD

Same procedure to follow - to delete file or folder which is not deleted

Instead "Program Files (x86) type

cd desktop\


cd documents

or so on

if the folder is on desktop/documents/ or under any category

same procedure

Best of luck
My System SpecsSystem Spec
12 Mar 2010   #19

Windows 7
Deleting folder in CMD

This is in continuation of my previous postings

Please note

Do not try to delete folder via Windows Registry

Some softwares like TradeManager will not be found in Registry.

Follow simple methods & avoid touching Registry.

Try not to use Windows Registry Clearner.

Sevenforums is one of the best.

Most of the help is found in Microsoft sites.


My System SpecsSystem Spec
17 Jun 2010   #20
Gamesoul Master

Windows 7 Ultimate (32-bit)
A real (and overlooked) solution to most of these problems

Sorry for the slight necro-post on my first post here, but I came across this same situation *twice*, and found a solution both times. I only post it here because when I google this particular problem, this is one of the first results that comes up, so I figured having a solid solution on this thread would be a good idea.

Setting proper ownership and permissions is on the right track, but there's an additional step that seems to need taking when dealing with some of these folders (*especially* folders on the root directory of the drive, as that's where the issue seems most prominent in my case).

When setting new permissions to allow yourself to delete the folder (via Properties (right-click) -> Security (tab) -> Advanced (button) -> Change Permissions (button)), you should definitely make sure you uncheck the first checkbox ("Include inheritable permissions from this object's parent") and check the second checkbox ("Replace all child object permissions with inheritable permissions from this object"), although that second checkbox is only needed if there are folders you want deleted in the folder you're trying to delete. It'll ask something about deleting permissions when you click OK, go ahead and agree to do what it asks. After that, you should be set to delete the folder.

Up until I did that last step, I was running across the same permission issues with deleting folders (Windows telling me I needed permission from "GamesoulMaster" to delete a folder when I *am* GamesoulMaster is very frustrating). Of course, I can understand the issue in my case, where it's inheriting permissions from the drive itself (being a folder in the root and such). Still, it's frustrating, but this should help a lot of people who are having this problem and haven't found the solution with the suggestions in this thread.
My System SpecsSystem Spec

 Canīt Delete Folder. You Need Permission.....

Thread Tools

Similar help and support threads
Thread Forum
Cannot delete folder on drive, says I don't have permission (I do)
Hello, Thank you for taking the time to read my post and aid me in my little issue I have here. There exists a folder in one of my hard drives that I cannot delete. I played around with the permission settings and gave all users "full control" to no avail. It still insists I do not have...
General Discussion
Permission to Delete Folder
I want to delete a particular folder but I keep getting this error. I tried "Take Ownership" and it still would not work. When I tried to access the sub-folders I get this access denied error.. I have had this issue for some time and I tried to ignore it but now I can't anymore as I am...
General Discussion
I need administrative permission to delete these files.
I want to delete three files but it gives me the " I need administrative permission to delete these files". I tried right clicking and clicking on properties but there is no security tab in there...can someone please help me?
General Discussion
You'll need to provide administrator permission to delete this folder.
I have tried everything to delete this folder. I was able to delete the file in the folder, but the folder itself won't delete. It won't delete in safe mode either. If I scan the folder or right click properties, it shows an object in the folder. If I check the "show hidden files" box, nothing is...
General Discussion
How Can I Get Permission to Delete a Folder When.....
I'm the person I'm supposed to be asking for permission? I created a folder on the desktop when I was in the agonizing throes of trying to set up Windows 7. I now want to delete the folder. The problem is that there are files in it that I'm told cannot be deleted without getting permission from...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Đ Designer Media Ltd

All times are GMT -5. The time now is 19:53.
Twitter Facebook Google+