Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Suddenly can't pin a program to taskbar anymore

15 Jun 2011   #1

Windows 7 Ultimate x64
Suddenly can't pin a program to taskbar anymore

This started a week or so ago. I had a program pinned to the task bar, but suddenly it was behaving strangely. When I ran one or more instances of the program, they would group together, but not group with the pinned icon. I could move them separately. Just now, in a attempt to fix this, I unpinned the program, and tried to re-pin it, but that option is gone! Dragging the .exe file to the task bar also gives me the 'not allowed' mouse cursor. Pinning any other program and pinning this program to the start menu is still possible.

Before you ask, I've tried the shortcut arrow fix, but I already have, and always had, the IsShortcut key in the registry.

I haven't installed or uninstalled any programs in the mean time (except for updates), and a reboot didn't work either.

My System SpecsSystem Spec
15 Jun 2011   #2

Windows 7 Ultimate x64/Windows 8 Consumer Preview x64/Ubuntu 11.04

Could you by any chance post a screenshot of the of the problem?
My System SpecsSystem Spec
16 Jun 2011   #3

Windows 7 Ultimate x64

What is the program?

In the case of 32/64 versions, if you pin the 32bit version (of IE, for example) to the taskbar, then run the 64bit version, they will have separate icons on the taskbar.
My System SpecsSystem Spec

16 Jun 2011   #4

Windows 7 Ultimate x64

The problem solved itself. The only thing I did was lock the computer and unlock it this morning, and the program (which was still running) was mysteriously pinned to the task bar and gave me the option to unpin. I unpinned it and again I couldn't pin it. I minimized then maximized the program and I can now pin/unpin it freely.
My System SpecsSystem Spec

 Suddenly can't pin a program to taskbar anymore

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 Professional Suddenly not Genuine anymore
Diagnostic Report (1.9.0019.0): ----------------------------------------- WGA Data--> Validation Status: Genuine Validation Code: 0 Cached Validation Code: 0x0 Windows Product Key: *****-*****-MV8MH-98QJM-24367 Windows Product Key Hash: wgci5Gdejx4esg7++zTOe3LWF+4= Windows Product ID:...
Windows Updates & Activation
Icons & Thumbnails don't appear in windows explorer or taskbar anymore
I'm never the one to ask, but I don't know what happened. I tried looking online but I couldn't find any solutions. It seems like all my icons (including folders) are not showing up in windows explorer, taskbar, or the desktop anymore. This isn't too big a problem, but navigating through my picture...
General Discussion
A program WinBeam not running anymore
On my Vista 32bit i had a program running ok. It's called WinBeam and it's very small - 1MB. It's an old program and it doesn't have new versions or support. After I upgraded to 7 64bit I can't install it.I get the error below. I tried to run the setup file in compatibility mode but I get this...
Windows 7 64-bit suddenly doesn't load anymore!!
Hi all! I had my laptop running last night and I woke up this morning and my computer was frozen. It wasn't the "blue screen of death" as many mention as it was simply frozen but when I turned it back on (and continue to turn it back on) it gets stuck on "Starting Windows" without even proceeding...
General Discussion
Suddenly no internet access anymore
Internet used to work fine but has always been a pain to set up. This morning I _suddenly_ had no connectivity anymore whats-o-ever, it worked fine yesterday. I've had this problem before (where suddenly the internet is gone) but this time I've been unable so far to find the culprit. I am...
Network & Sharing
I don't have a Uninstall a Program window anymore
Uninstall a program window does not open, the link is not working. How I'll open that window?
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:15.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App