Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows Search Not working.

12 Jul 2011   #1

Windows 7 32 bit
Windows Search Not working.

Any help would be appreciated. Thanks

Windows Search will not work. First of all I have tried a bazillion things and its a miracle my computer works at all. I will list what could be the most important symptom first and then all the other stuff.

Under Indexing Applet it says indexing is turned off and also the Modify option does not work. The advance button appears to work and it will let me select rebuild. It doesnt appear to do anything.

If I go to services and tell wsearch to start it does start and goes off 1 second later. If i look at the event viewer it shows many errors in the last hour and when searching on these I have not been able to come to any conclusions.

The rest is some boring things that a person does when they have done a bazillion things.

Indexing for several months has always been reindexing in outlook, i dont know if indexing was off at that time however outlook says its indexing now even though indexing applett says indexing is off.

Replace hard drive and went to a bigger one and did a clone and played with the partition. My original drive was having errors but i think it was heat related because i did not get any logged read errors and only after i pulled it out and put a fan on it was i able to clone from it.

updated intel driver mentioned in a couple post, I did not have the latest version

ran malwarebytes and did find a couple things but they were removed. Could have been out there for months

ran chkdsk and finished without errors

ran sfc scannow from safe mode and got errors but could not figure out what they were. No details. I think i have the log and i remember right i looked at it but couldnt tell heads or tails

Turned indexing on everyway i could, but never would come on.

Messed with registry setting.

Messed with permissions but dont think i screwed any up but since you have to have a phd in computer science from MIT to understand permissions I really dont know for sure.

Tried the GODAWFUL, MULTI HOUR, UNINSTALL TONS OF PROGRAMS, POC rebuild option available for windows. After several hours went to bed woke up the next morning and was told that it would have to undo itself.

Maybe i am crazy but it seems like the fact that the modify option on the Index applett is not enabled that either i have a registry problem or somehow i should be able to reload the necessary software.

My System SpecsSystem Spec
12 Jul 2011   #2

Windows 7 32 bit
Indexing doesnt stay on.

Anybody have any idea why the Modify button doesnt work on the Indexing applett or why Indexing(service for windows search) turns on and immediately goes off

Any suggestions would be greatly appreciated
My System SpecsSystem Spec
12 Jul 2011   #3

Windows 7 Ultimate x64/Windows 8 Consumer Preview x64/Ubuntu 11.04

Hi firepro,

I'm assuming by Windows search you mean this?
Windows Search Not working.-capture.png

I'm also assuming that you don't have a System Restore... but if you do, than definitely try it.
System Restore

If that doesn't work, try a repair install. It will attempt to fix your version of Windows but also keep all of your documents, settings, drivers etc.
Repair Install

Now, last resort is a clean install. It will wipe everything and then re-install Windows, so be sure to back up before you start.
Clean Install Windows 7

Hope this helps,

My System SpecsSystem Spec

12 Jul 2011   #4

Windows 7 32 bit

Hi Jaidynm for taking the time and effort to respond. In response to your questions:

The screen you show is not what i am talking about. If you go to --control panel-- then select "indexing options" it should bring up the "index applett" . On mine it says indexing is not running and and the "modify" button is grayed out.

Also only had one level of system restore did not work, repair install did not work and I would like to avoid clean install if possible.
My System SpecsSystem Spec
12 Jul 2011   #5
James Colbert


Here's a few links that may help:

The third or so post down seems relevant:

indexing not running - View topic • Windows Forums

And a lot of Vista results here, but may provide some relief:

windows 7 indexing is not running and and the "modify" button is grayed out. - Google Search

My System SpecsSystem Spec
18 Jul 2011   #6

Windows 7 32 bit

Still not working. Decided to do clean install. Everything was working perfect. Indexing was working like it should and somewhere in the lenovo driver install and window updates and pogoplug install it stopped working.
Did a restore about half way back still not working. Did restore all the way back and indexing does work. Any thoughts would be appreciated.
My System SpecsSystem Spec
18 Jul 2011   #7
Microsoft MVP

Windows 7 Ultimate X64 SP1

Welcome to Seven Forums firepro. Try this...Start|Admin Tools|Services, scroll to Windows Search and double click it. In the window that opens use the drop-down menu for start up type and set it to Automatic or Automatic (Delayed start), click start. Close all of that out and try the Indexing in control Panel again.
I just tried this and with Search disabled in services the Modify button was grayed out as you said.
Windows Search Not working.-svcs.png

My System SpecsSystem Spec
18 Jul 2011   #8

Windows 7 32 bit

Thanks. I have done that. When i disable then re-enable it comes on for a second and then on its on it turns off. I think we are close but missing the magic bullet
My System SpecsSystem Spec
18 Jul 2011   #9
Microsoft MVP

Windows 7 Ultimate X64 SP1

With a clean install it should be fine. What have you installed since the install?
My System SpecsSystem Spec
19 Jul 2011   #10
James Colbert


Did restore all the way back and indexing does work.
It seems apparent that something you have installed is casuing your issue (app, driver or update). It may be a bit tedious, but I would restore back to the point where it works, then install one thing at a time, checking indexing in-between each, perhaps waiting a bit or at least restarting the machine before proceeding. Make sure that restore points are created before each item installed.

Eventually, you should discover what is 'breaking' indexing, and decide if you can live without whatever the culprit is.

You may also want to consider using a partition imaging program. I use Acronis True Image (on special right now for 29.99), which is paid software. Others here tout the free Macrium Reflect. Images must be written to a partition other than that being partitioned (i.e., an image of the C:\ partition cannot be written to C:\)
My System SpecsSystem Spec

 Windows Search Not working.

Thread Tools

Similar help and support threads
Thread Forum
Windows Explorer search not working
For example: If I open "My Documents" and then try to search for a document by entering the name in the top right corner, it doesn't do anything (nothing shows or indicates it is even searching for that document I am trying to locate). Any ideas why it isn't working? P.S. It's like this...
General Discussion
Windows 7 Search Not Working
Searching folders for documents, music, etc. was working fine just a few days ago, but now suddenly it has stopped working completely. The search features in the start menu, windows explorer, and WIN + F aren't working. As I type a search query, I get no instant results. Even after I press enter...
General Discussion
windows search fucntion not working
using 7 pro 64 bit search not working- does not give any response- in folder- type in anything, no response in windows button start menu search- white screen- with see more results link- click on that "windows can not access the specified device, path or file" in outlook- ie...
Performance & Maintenance
Windows 7 not updating, Indexing not working, search not working, FYI
I had been working an issue where the search function was not working correctly, I then noticed that Indexing was not working and I could not update windows. I wanted to post this in case someone had similar issues, it took me a while to figure this one out... The problem likely started when I...
Windows Updates & Activation
Windows Search not working
recently i've been unable to search for folders, files, etc. that are located in "Computer"... for example I search for something I know is there and all I get is "No items match your search." I am however, able to search in libraries, homegroup, custom..., and internet and they also make a sound...
General Discussion
Windows Search Not Working for emails
I am having a problem with Windows 7 search when searching for emails: When searching for an outlook email in the "instant search" bar in Outlook, the results are as expected (the correct results are displayed for the search term) However, when searching exact same term as in #1 above,...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:07.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App