Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Bios Update now no Desktop

16 Jul 2011   #1
darkstarsinner

 
Bios Update now no Desktop

Hope I put this in the right place. Here goes...


So I updated my bios today from 1.7 to 1.A. When the system restarted it goes to Windows 7 with a black screen that says "C:\windows\system32\config\systemprofile\desktop Refers to a location that is unavailable". From here I have all of the basic buttons but I cannot access anything. I get an error even trying to run regedit. My system ran fine before the bios update. The system setup is as follows:


50GB SSD with Windows 7 installed only
4x 500GB HDD in Raid0 with all user profiles and default save locations set to it.
2x External drives (not to important here just run Ubuntu and a spare drive)

When I set the system up I changed all of the registry settings so that windows automatically saved everything to the Raid0 drive. Everything is still on the drive as it has been unchanged but Windows fails to find the desktop settings now. How can I change this? I CANNOT lose any of the files so a wipe and rebuild are out of the question. I'm lost here fellas and could really use your guidance. Thanks in advance.


Edit: When I looked in the system profile folder there was no "desktop" folder there. I manually created one and got some of my shortcuts on the desktop back but everything is still missing. At system launch I edited all registry settings to point to drive D: as the primary. Maybe something changed there?


My System SpecsSystem Spec
.
16 Jul 2011   #2
Golden
Microsoft MVP

Windows 7 Ult. x64
 
 

Hi,

Is this a hardware RAID0? If so, then check your updated BIOS to make sure it is still configured to use the RAID controller.

Regards.
Golden
My System SpecsSystem Spec
16 Jul 2011   #3
darkstarsinner

 

Thank you for replying. I have gone through the bios and everything is set accordingly. The issue is with windows not recognizing the proper drive with the user profiles. I think the registry has swapped back to the C: drive instead of the D: drive. Only issue is I don't know where to begin with it.
My System SpecsSystem Spec
.

16 Jul 2011   #4
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

IMO, The BIOS update has un-build the RAID.

I personally would stay away from RAID, as it seems to more problems than it is worth.
My System SpecsSystem Spec
16 Jul 2011   #5
darkstarsinner

 

The Raid array is actually fine. Window seven recognizes the drive just as it did before. The problem is with the registry not direct properly anymore.
My System SpecsSystem Spec
16 Jul 2011   #6
gregrocker

 

As suggested the BIOS updated reset to optimized defaults, so you'll need to find the setting change which affected the RAID drive's linkages from SSD or reimage or clean reinstall the OS.

One of the benefits of having the data moved off the OS drive is it makes a lean image which is easily reimaged and holds the links to data HD which remain current. I'd take advantage of this in the future.
My System SpecsSystem Spec
Reply

 Bios Update now no Desktop




Thread Tools




Similar help and support threads
Thread Forum
Desktop won't boot, gets stuck in BIOS
I just came back from a 10 day vacation, and when I tried turning on my desktop for the first time upon returning, it gets stuck on the BIOS screen for about a minute, then the screen goes black. I can't use any of the BIOS functions. The HDD activity light blinks a couple times right before it...
General Discussion
Bios Beeping Noises On old IBM desktop
I wanted to blow the dust off my old PC and see the old memories I have there from 3rd grade days When I opened it it started making some wierd noises so I searched google but could not identify the problem I removed the RAM and the battery on the motherboard and put them back but nothing changed...
General Discussion
Problems with Nvidia gpu post BIOS system BIOS update.
Hello all, this is my first time posting here so please forgive any mistakes/oversights. I've just updated my Samsung laptop's system BIOS via their software update program, and my Nvidia GPU (GT 650m DDR3) no longer seems to work. The Nvidia control panel is still there, and it still gives me...
Graphic Cards
Just used @BIOS to update my BIOS, it failed at 50%
Now I don't want to shut down or restart my computer because I fear it won't boot up. This is awful. Is there anything I can do to restore my BIOS whilst my computer still works? :(
Drivers
Windows Update INCLUDES Motherboard Drivers and BIOS Update on M2A-VM?
Hi Guys, I have a REAL newbie question. I’ve tried reading a bunch of tutorials, but they’re a little over my head. I think my question is pretty basic, but after a couple hours research, hopefully someone here would be kind enough to help. I have an M2A-VM motherboard and my system keeps...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:39.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App