Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Need advice: installing timer, comms software with no admin rights

26 Jul 2011   #1

Windows 7 Enterprise
Need advice: installing timer, comms software with no admin rights

Dear All,

I have a difficult mission: I work for a company that needs to send client data to an FTP server on a daily basis, with no intervention by the user. Before Windows 7, it was an easy task as we just supplied some FTP software, script and some timer software that installed itself as a new service. It worked really well....

But now I'm in the situation where our clients are getting new PCs with Windows 7 loaded, and due to lack of admin rights/elevation, we're no longer able to install software. Worse still, I can't install the timer software as a service for the same reason, and Task Scheduler also needs Admin rights.

I have half a solution which means supplying comms software that can literally be copied into a folder, and my testing has gone well, but I'm stuck with the timer software. Does anyone know of a standalone timer app that I could simply unzip and copy to a folder along with my comms software?

Any info/ideas would be gratefully received!

My System SpecsSystem Spec
26 Jul 2011   #2

Windows 7 Ultimate x64

Is there no admin at your company? You need to have an admin account to install software, but once it's installed you should be able to run it as a regular user. The same applies for scheduled tasks.
My System SpecsSystem Spec
26 Jul 2011   #3

Windows 7 Enterprise

It's not so much at my company - I can get Ops to give me temporary admin rights to test stuff, but I can't expect the same when I go to visit clients, or if I have to send them a CD in the mail: this is why I'm looking for a standalone solution (at least for the timer)..
My System SpecsSystem Spec


 Need advice: installing timer, comms software with no admin rights

Thread Tools

Similar help and support threads
Thread Forum
Admin Rights
Hi everyone I have 2 user in my system one is my user and second is administrator ... so when i get full rights on my user through change permission flow then it shows me error.. how to resolve this :huh:
System Security
"Unable to elevate to admin rights" error, when admin user
I am trying to download Adobe Digital Editions and I keep receiving the error message Unable to elevate to administrative rights, error 786 I am the admin! I have turned off the password, I have right clicked on the program and chosen 'run as admin'-then nothing happens. Any help would be...
Need help with installing software cant enter admin password
well im still stuck as a standard user but gotten used to it. I am trying to make a USB boot disk but the program requires a admin password when it it says "to continue type a administrators password then click yes then normally below it there should be accounts to pick and areas next to the...
System Security
Installing rights to standard user or prevent an admin user something
I tried to google this and it seems neither is possible but I wanted to hear the truths from the horses mouth. I have a Win 7 Pro x64 computer with 2 users who boths needs to be able (this really is a must) install software on the computer but they can't have access to each other's private...
General Discussion
admin user lost some admin rights
I can't delete a file from the desktop. When I try, it says to get the rights from the specified admin user (which I'm logged on). The strange thing is that I still can create other users from this account (including admins). Any suggestion on what to do?
BSOD Help and Support
Admin rights
Hi, I am a beginner and don't understand the logic of Windows Admin rights: 1. I am the adminstrator (the system control confirms that). Still I can not save a txt file under programs (in that case: under Thunderbird Mozilla / Chrome). WHY? 2. The problem exists even when I individually...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:41.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App