Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Need a bit of help here.

13 Aug 2011   #41
ollie1132

Windows 7
 
 

nope no FCC ID


My System SpecsSystem Spec
.
13 Aug 2011   #42
severedsolo

Windows 7 Ultimate X64 SP1
 
 

I really don't know what to suggest at this point... there is NOTHING about your Adapter out there, apart from the Belkin page.

Did you try my suggestion about selecting Belkin rather than Ralink to see if that would work?

Other than that.. I'm at a loss, sorry. The only other thing I can suggest, and I am loathe to recommend this, having dealt with them myself, is to try contacting Belkin.
My System SpecsSystem Spec
13 Aug 2011   #43
ollie1132

Windows 7
 
 

Ill give it a go once I have a free minute. Otherwise I will just get my mum to buy a new adapter for me before she gets home. Probs be easier.
My System SpecsSystem Spec
.

13 Aug 2011   #44
severedsolo

Windows 7 Ultimate X64 SP1
 
 

Just something to throw out there.

When I was researching this problem with my V3, I did hear tales of people getting it to work by installing the software in Compatibility mode with Vista. Never worked for me, but might be worth a go.

Obviously you'd need to uninstall/reinstall first.

OR! I just had a bit of a brainwave!

I managed to (somehow) manually extract the drivers for your adapter from the Belkin installer. It was a lot easier than I remembered.... must have changed it.

Anyway, they are attached Try extracting them somewhere, and then manually browse to them from Device Manager.

Note: These are (apparently) the X64 drivers (as that is what it gave me, as I am on X64) Although it wouldn't surprise me if they were actually X86 (32-bit) that was my issue last time.


Attached Files
File Type: zip net8192su.zip (344.8 KB, 3 views)
My System SpecsSystem Spec
13 Aug 2011   #45
ollie1132

Windows 7
 
 

Nopes can't install the drivers that way haven't tried compatability yet though. i really don't get why it now thinks its a realtek device.
My System SpecsSystem Spec
13 Aug 2011   #46
severedsolo

Windows 7 Ultimate X64 SP1
 
 

Ah... sorry my mistake. Another brainwave.

I just looked at the drivers I extracted, and established that it is a Realtek 8192SU Chipset.

Therefore. Try grabbing drivers from here:

Realtek

Again, you may need to follow my tutorial and tell Windows that it is a Realtek. (No compatibility mode should be needed)

Hopefully, that won't be needed though, as it has already been recognised as a Realtek device.
My System SpecsSystem Spec
13 Aug 2011   #47
ollie1132

Windows 7
 
 

this is silly to be honest lol. the adapters always been Belkin. no idea why its changed itself. it also states a Error Code 10. so it can't start for some reason.
My System SpecsSystem Spec
13 Aug 2011   #48
severedsolo

Windows 7 Ultimate X64 SP1
 
 

Quote   Quote: Originally Posted by ollie1132 View Post
this is silly to be honest lol. the adapters always been Belkin. no idea why its changed itself. it also states a Error Code 10. so it can't start for some reason.
This is what makes me think Belkin have been playing silly buggers again. Is your Windows 64 bit by any chance?

You think this is silly? You try doing it when NOBODY knows whats going on This is the situation I had as I got Win 7 pretty much the day it RTM'd.

Your best bet with belkin is to go straight to the chipset manufacturor. This is why I suggest you go for that Realtek driver.
My System SpecsSystem Spec
13 Aug 2011   #49
ollie1132

Windows 7
 
 

Well you see the Adapter randomly stopped working on my WinXp well i say randomly it just died on me was still recognised but not as it should've been. I was like well lets upgrade to Win7 cause i had no install Discs for my WinXp and im pretty sure i had a boot sector virus. Got Win7 to where it is now, used my Belkin G adapter for one restart then it died... kept getting BSOD got told the belkin driver was causing that so was like uninstall.... and we get to where we are now :/
My System SpecsSystem Spec
13 Aug 2011   #50
ollie1132

Windows 7
 
 

Right so, lets say the drivers ARE up to date (having faith in microsoft here!) how do i go about sorting the Error Code 10?
My System SpecsSystem Spec
Reply

 Need a bit of help here.




Thread Tools



Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:15.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App