Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Copying files to a usb hard drive

21 Sep 2011   #11

Windows 7 Home Premium 64bit 6.1 Build 7601 (SP1)

I've had good luck with a tool called DriveCleanup from Uwe Sieber. Cleans-up a PC's residue from USB plugs/unplugs/replugs. Look about halfway down this page:

Drive Tools for Windows

First make a System Restore point (the tool deletes abandoned registry keys), the copy the x64 version to your pc e.g. the C:\ root directory, open an elevated command prompt & type:

drivecleanup -t

I like to copy & paste the results to a text file before going-ahead and doing the cleanup (just leave-out the -t), just to see what kind of junk it has found. Then you just type 'drivecleanup' and it does everything.

Maybe not your issue but worth a look perhaps.

My System SpecsSystem Spec
21 Sep 2011   #12

Microsoft Windows 7 Home Premium SP1 64-bit Build 7600 / Microsoft Windows XP Professional SP3

Hem... just a question... which chipset does your MoBo has? just for the record...
My System SpecsSystem Spec
22 Sep 2011   #13

MS Windows 7 Ultimate 64-bit SP1

Are you trying in only one port or tried other USB 2.0 ports in your system?

Sometimes USB hard drives require special drivers, like Western Digital requires SES driver?

Connect the hard drive to your system, go to device manager and select this external drive and uninstall the drive. Now press the button above to detect new hardware devices.

Is the external hard disk is getting installed automatically or it is asking for a driver?
My System SpecsSystem Spec

22 Sep 2011   #14

windows 7 ultimate x64

Quote   Quote: Originally Posted by p5bdkw View Post
Are you copying from the USB 2.0 or USB 3.0 ports?
Now the computer says I dont have any 2.0 usb ports when that is what i have. Also the usb device is listed in the taskbar icons but is greyed out, so i cant safely remove it.
My System SpecsSystem Spec
23 Sep 2011   #15
Microsoft MVP

Windows 7 Ultimate X64 SP1

Quote   Quote: Originally Posted by Britton30 View Post
Welcome to Seven Forums dallasjme. Does the USB hard drive work otherwise and shows with a drive letter in Computer?
What about this? What other things have you tried so far?
My System SpecsSystem Spec
23 Sep 2011   #16

Windows 7 Professional 64 bit

Have you tried several different ports?
My System SpecsSystem Spec
24 Sep 2011   #17

win 7 ultimate 64

I have experienced the same problem as you have described, and I am running the same OS...I have considered it more of a nusaince than anything as it goes away after a reboot.... does yours?. can you copy to any usb item such as a thumb drive, memory stick etc?..
My System SpecsSystem Spec
06 Oct 2011   #18

windows 7 ultimate x64

Quote   Quote: Originally Posted by dallasjme View Post
I try to copy files to a usb harddrive but windows just stays there copying forever. I tried the usb hardrive on another computer and it works fine. I am using Windows 7 ultimate x64.
I found out the usb wireless network adapter was causing the problem.
My System SpecsSystem Spec
06 Oct 2011   #19
Microsoft MVP

Windows 7 Ultimate X64 SP1

Glad you figured out the fix dallasjme!
My System SpecsSystem Spec
06 Oct 2011   #20

MS Windows 7 Home Premium SP1 64-bit (Family Pack Lic.) Upgrade

can you reformat the usb drive?

A.) this will test the connection
B.) Make sure it's formatted correctly (file system, partitions, drive file table format,etc..)
C.) also might try scanning both drives for errors (could get caught in a corrupt file endlessly looping, or may be writing to a bad sector and trying over and over - also maybe it's just a bad HDD)

My System SpecsSystem Spec

 Copying files to a usb hard drive

Thread Tools

Similar help and support threads
Thread Forum
Copying files from one hard drive to another
Hello, I'm wanting to copy some files from an external hard drive to an internal SSD drive which has enough space free. However, when i copy and paste to the destination drive, Windows Explorer only recognises a fraction of the total amount I've selected, about 10% approximately. I doing this...
General Discussion
BSOD after copying files from one hard drive to another
Hello. I hope you can help as this problem is very frustrating. Just built a new PC: - Gigabyte Z97X Gaming 7 mobo - 8 gig Corsair Vengance 1866 mhz - EVGA GTX 770 video - Intel 4770K CPU - two 1 Tb WD black hard drives as RAID 1 - one ADATA 256 Gb SSD as OS drive - one 1 Tb Toshiba drive -...
BSOD Help and Support
Copying files to USB Portable Hard Drive stalls system
Hi guys, Today a friend of mine came to get some files from my computer and we ran into a bit of a problem. We were copying some huge files using windows explorer, some were around 10GB in size. Total size of about 90GB. Check system specs please. We were copying from the RAID spindle drives...
BSOD Help and Support
"0x80070057" Error copying files from hard drive to hard drive??
"0x80070057" error. I was simply trying to copy a folder or group of files to another hard drive. Hard drive to Hard drive, no SSD or External was involved. Any solutions to this issue? It literally refuses the copying to be performed ... I'm trying to copy folders/files from a Seagate...
Hardware & Devices
Copying rar files to a usb hard drive
All, Got a strange problem. I've have .rar files on the c: drive all around 90+mb each. On c: the rar files are error free (no crc errors when testing them). When copying to a usb hard drive after copying (with no errors during the copying process) the rar files fail with a CRC error. I've...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App