Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: No Boot sector main hard drive

13 Oct 2011   #31

Windows 7 Home Premium 64 bit

Quote   Quote: Originally Posted by gregrocker View Post
Yes it does. Most Reinstallation DVD's do not contain the other versions to unlock, but you can try.

You may need to borrow or find a Win7 retail installation DVD.
Here is what I did.
I ran the ei.cfg Removal Utility again for the Win7 iso and removed the ei.cfg and did the windows 7 usb dvd download tool to put the Win7 iso back on my flash drive. After it was finished I did a search and it found the ei.cfg file so I just deleted it. Then went through the install process and it did give me the menu options to select which version of windows I wanted to install. Everything seems to be working just fine.

My System SpecsSystem Spec
13 Oct 2011   #32

Microsoft Community Contributor Award Recipient


That is good news on the Toshiba tool getting things started, hopely the problem will not came back.
My System SpecsSystem Spec
25 Dec 2011   #33

Windows 7 Home Premium 64bit

Quote   Quote: Originally Posted by GMadd View Post
Good news I am up and running without the error about the boot sector. I ran the Toshiba test for the hard drive and it came back and said everything was ok I also ran the one that SeaGate has because it works on any disk and it came up good too. I used Bootrec.exe that was on the windows web page How to use the Bootrec.exe tool in the Windows Recovery Environment to troubleshoot and repair startup issues in Windows and followed all the steps and no luck. I deleted all the partitions and tried the Bootrec.exe again and no luck. Then I decided to go back and try bootcect.exe which I tried before posting on here and it fixed it. Thanks for all your help
Hi mate glad you sorted your problem and it seems to me a very trilling discovery as i am looking from weeks to find a good answer for my problem
I am having the same problem as you had , However i am able to start windows manually by pressing F1 key at ''no boot sector on internal hard drive'' bu i cant make it to boot normally as windows or bios suppos to do .
here is my post if its possible for you to help me overcome this problem it will be greatly appreciated
No boot sector on internal hard drive while AHCI enabled installation
My System SpecsSystem Spec


 No Boot sector main hard drive

Thread Tools

Similar help and support threads
Thread Forum
Boot sector on the wrong drive
Hi there, i'm a new member and very glad i found this forum because if you people don't have the answer i probably have to format and reinstall... I've searched the forum for an answer to my issue and found some things that might be the sollution, but i'm not totally confident it'll fix things,...
Installation & Setup
Find data stored on bad hard drive sector
Hi, I have 2 pending sector count and was wondering how to find what information is stored on these sectors. I have run HD Tune Pro and it showed 2 red blocks: Error : LBA 16829295 and 16901956. I downloaded a program called DiskView to find that clusters but the numbers didn`t match. How to find...
Hardware & Devices
No boot sector on internal hard drive while AHCI enabled installation
hi everybody! I have a dell studio 1536 my hard disk got corrupted a month ago and tried different software could not make it to work so, decided to buy another HD . my new hard drive is (used) bought in ebay and SMART shows 100% health also tested on dell diagnosetic utility and all tests passed...
Installation & Setup
No boot sector on internal hard drive error
Yesterday, I was browsing on my computer and heard a weird clicking noise when the CD drive was running. About a few minutes after that, Firefox froze so I did a hard reboot, and up comes this message: "No boot sector on internal hard drive No bootable devices--strike F1 to retry boot, F2 for...
General Discussion
Main Hard Drive isn't letter C:
Hi, I had Ubuntu 9.10 on my PC and decided to change to 7. It didn't recognize the main partition so it formatted it, and installed. When the installation was done, my main hard drive letter is E: . I tried changing it through Disk Management: it gave me ''The parameter is incorrect''. I tried...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:43.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App