Repeated "Disk Read Error" messages for no reason!

  1. Posts : 12
    Windows 7 Home Premium 64 Bit SP1

    Repeated "Disk Read Error" messages for no reason!

    Hi, I have a very frustrating problem. One day I was playing a game and then my cp BSOD (itís OCíd so I wasnít too alarmed). Then I went to boot back up and all I got was a blinking cursor. No msg, no text, NOTHING! Well I looked around on the internet and though a combination of windows startup repair and bootrec, bootsec, diskpart and chkdsk I was able to get it to where now all it will say is ďDisk Read Error, press ctrl+alt+del to restartĒ. Of course pressing that does nothing. The weird thing is that I know the drive is good, I can read all the data off of it just fine. I donít think itís going out as itís an 80gb intel ssd in a desktop with very good airflow, no issues there. Then when I try to go through windows startup repair it says no problems, clearly lying. Another weird thing is that when I first go to recovery options it will detect my os just fine, but then I run bootrec /scanos and it comes up with a BIG, FAT NOTHING!! Iíve been at this for about 8 hours on and off and Iím at my wits end. Any suggestions or tips are greatly appreciated! I really, really want to avoid formatting and re-installing because I very much want to not have to go through the huge hassle of re-installing EVERYTHING!! And even more so because I know the drive and data are good!
    Thanks in advance guys J
      My Computer

  2. Posts : 12
    Windows 7 Home Premium 64 Bit SP1
    Thread Starter

      My Computer

  3. Posts : 1,781
    Windows 7 Professional SP1 32-bit

    Sorry, no idea - unless the SSD is actually malfunctioning/failing.

    I notice though that you have Windows 7 RC build 7100...why are you still running a beta release now that the rest of the world is up to Service Pack 1? It's not even supported by Microsoft so you'll miss out on all the updates.

    To be honest, I think you should reinstall your OS, and reinstall it from the proper RTM or SP1 release of Windows 7.
      My Computer

  4. Posts : 12
    Windows 7 Home Premium 64 Bit SP1
    Thread Starter

    Oh yeah, sorry I forgot to update my specs, haven't been on here in a while!! But I put my current system in there now so it should look a bit better. That'd be pretty amazing to still be running a beta though!
      My Computer

  5.    #5

    Stop overclocking to see if that helps.

    Next I'd clean reinstall without the overclocking following these steps to know you have a perfect reinstall: Reinstalling Windows 7

    If this doesn't solve the problem, test your RAM - Test with Memtest86+and HD using maker's HD Diagnostic extended CD scan.
      My Computer

  6. Posts : 12
    Windows 7 Home Premium 64 Bit SP1
    Thread Starter

    I finally got it fixed!! I still have no idea what the problem was but hereís how I did it for anyone else having the same problem:

    I happen to have 2 identical disks but you could just make more logical drives instead.

    Disk 0: win7 80gb ssd
    Disk 1: games 80gb ssd
    Disk2: 1.5tb storage drive with several logical drives

    First, I created a copy of disk 1 on disk 2 using partition magic. Then I copied disk 0 to disk 1. When I tried to boot from this, new, copy, I started getting driver errors: ďso-and-so .dll is missing or corruptedĒ. Copying the same file from a different machine didnít help, so I erased disk 0 (after I had a copy of it on disk 1) and then did a fresh install of 7 on it. After installing all the motherboard drivers, I copied all of the .dllís in /system32 to /system32 of the old (currently non-booting) install. Restart, change boot order and what do ya know, it booted right up!! Now I just had to put everything back where it belonged and 85% of my programs were happy. There were a few (catalyst, Virtu and all the ASUS Mobo utilities) that said ďthis program is incompatible with the version of windows you are using, check and see if you can get a 32- or 64-bit version. I had to use a third party uninstaller to remove them because the built-in uninstallers would not run. After uninstalling and reinstalling everything, all was back to normal except windows desktop gadgets. This would not run either but was fixed by copying the /program files/windows desktop gadgets folder from my other 7 machine to the same dir on the problem machine, including all of the sample gadgets. Go figure on that one! Now the only issue is virtu not running and a .NET 4 security upgrade that wonít install.

    As I said I havenít the slightest clue what went wrong but from now on I will definitely be making regular back-ups and system images!!
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 03:45.
Find Us