Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Virtual memory - Pagefile problem: no drives in list!

13 Jan 2009   #31
limneos

Windows 7 RC 7100 32bit/64bit
 
 

Quote   Quote: Originally Posted by Mr GRiM View Post
Well when I installed mine I already had Vista on one of the HHD's and I just formatted the second HHD during setup and installed it, then once I had it installed I created the second partition and then I just done the same thing, during setup I formatted the partition and installed, no problems.
You had Vista installed, so there already existed a BCD store on your Vista partition, which was found during setup, used and updated from 6.0 to 6.1 (to support VHD) without adding the extra 200MB boot partition. I guess it happens only in clean installs, where all free unpartitioned space is used.


My System SpecsSystem Spec
.
13 Jan 2009   #32
limneos

Windows 7 RC 7100 32bit/64bit
 
 

I like it though, that microsoft uses an extra small partition for boot partition, leaving the windows partition untouched. It can help in cases of messing up with startup files on the windows partition. It can also help for managing several boot loaders without touching the windows partition. (You can add a bootsector file on the hidden partition once you unhide it first, of course, without putting bootsector files on the windows partition where they might be mistakenly deleted).

I think it also has to do with EFI support...we'll hear more about it , for sure.
My System SpecsSystem Spec
13 Jan 2009   #33
monaco

Windows 7 beta 1
 
 

I tried to do what you told me, i created the new partion but i can't copy CD file because it is in use:



Quote   Quote: Originally Posted by limneos View Post
I guess it happens only in clean installs, where all free unpartitioned space is used.
Yes it heppens when u have some free unpartioned space as I understood.

Whati do you thik i I do a fresh install after i phisically disconnect the 500 gb drive?
My System SpecsSystem Spec
.

13 Jan 2009   #34
Mark

Windows 7 Ultimate Vista Ultimate x64
 
 

Sounds like a good plan to me.
My System SpecsSystem Spec
13 Jan 2009   #35
limneos

Windows 7 RC 7100 32bit/64bit
 
 

Quote   Quote: Originally Posted by monaco View Post
I tried to do what you told me, i created the new partion but i can't copy CD file because it is in use:




Yes it heppens when u have some free unpartioned space as I understood.

Whati do you thik i I do a fresh install after i phisically disconnect the 500 gb drive?
Ok there's another way to copy that file.

open CMD with admin rights, and type :

BCDEDIT /export c:\BCD

this will save the bcd file to c:\

now copy it from c to your new partition under \boot so that the file path is \boot\bcd (in your new partition always)

Provided that the rest of the files are copied too, now proceed as instructed above.

Fresh install without the 500GB will work, but do this before, it's faster.
My System SpecsSystem Spec
13 Jan 2009   #36
monaco

Windows 7 beta 1
 
 

I didn't see you post in time so i tried a fresh install but there is a problem. I'm writing from my notebook now.
I disconnected the 500gb secondary hd and now i have only my 250, that si partioned in this way:

DISK 0 partion 1 PRIMARY (free)
DISK 0 partion 2 PRIMARY (free)
DISK 0 partion 3 SYSTEM (not free, almost full of data)
DISK 0 partion 4 PRIMARY (not free, almost full of data)

I try to install in partion 1 but i can't, it says:

"Setup was unable to create a new system partion or locate anb existing system partion. Se setup log..."

and i can't install. I tried also to delete and recreate the partion but the result is the same
My System SpecsSystem Spec
13 Jan 2009   #37
limneos

Windows 7 RC 7100 32bit/64bit
 
 

Cancel the clean install and log in to windows and do what I wrote above....
My System SpecsSystem Spec
13 Jan 2009   #38
monaco

Windows 7 beta 1
 
 

Quote   Quote: Originally Posted by limneos View Post
Cancel the clean install and log in to windows and do what I wrote above....
It would be too easy.. i formatted the windows partion... Now i'm going to try with gparted live if I can fix this and set the system partion.

EDIT: i solved this issue with gPArted live, now I'm installing (again...) windows seven. When it finish i'll post the situation updated, before reconnecting the other disk.
My System SpecsSystem Spec
13 Jan 2009   #39
monaco

Windows 7 beta 1
 
 

No way... fresh install with only one hard disk, hard disk list in virtual memory windows is still empty...
I think this was not a problem with partions...
Here's some screenshoot from the new install:




My System SpecsSystem Spec
13 Jan 2009   #40
Mark

Windows 7 Ultimate Vista Ultimate x64
 
 

Have you installed the drivers yet to see if it changes anything
My System SpecsSystem Spec
Reply

 Virtual memory - Pagefile problem: no drives in list!




Thread Tools




Similar help and support threads
Thread Forum
New PC - Low virtual memory problem
Hi I bought new customize pc 2 ago and yesterday and today shows me virtual memory error. I don't think that with following specs I have any problem with memory. Specs: Processor: Intel i7-4790K CPU @ 4.00GHz RAM: 32GB Graphics Card: NVIDIA GeForce GTX 760 (4096 mb) OS: Windows 7 64Bit
Performance & Maintenance
Question about Changing Virtual Memory/PageFile Size in Windows 7
Please help me understand this, I have a videoediting software that I am runing on 32 bit win7 with 4 Gb RAM, the company that makes the software suggests to set the Virtual Memory/PageFile Size to double the RAM amount. I looked and mine is set to auto, I have many drives and all say none...
Performance & Maintenance
I set maximum memory to 2 with no pagefile
Ok so I was trying to install dell quickset which doesn't work no matter what I do since I upgraded to 8gb or ram and installed a ssd. The main problem is I don't have the pagefile turned on so windows won't boot and safe mode boots but only has 240MB of ram and it so full you can't run anything. ...
Performance & Maintenance
Problem clearing virtual memory pagefile
I'm using Windows 7 64 bit and I'm having a problem disabling the option to clear virtual memory pagefile at shutdown since it makes shutdown takes 5+ minutes. Each time I disable it and restart my computer it enables itself again or maybe some software keeps enabling it. I tried disabling it using...
Performance & Maintenance
problem with video virtual memory
hello .. i have a problem with my laptop... i just upgraded from vista 64 bit home prenium to windows 7 ultimate 64 bit built 7057. after the upgrade my virtual video memory went to 0 MB my aptop has Intel graphics Media accelerator 4500MHD with uo to 1759MB .. when i used vista the adapter...
Graphic Cards
virtual memory problem
I get this error about my virtual memory setup. But the thing is that this is my same setup and configuration when I was running windows xp pro. Any ideas?
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:53.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App