Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 hangs for a few minutes

05 Aug 2009   #1
muth56

Windows 7 RC1
 
 
Windows 7 hangs for a few minutes

Hello!
My specs, first of all: Asus P5B (P-965 series), Intel Core 2 Duo e6600, 2 Seagate 160GB HDs, 1 WD 500GB (ALL SATAs), Sony NEC Optiarc 24x SATA writer, 2x1GB Kingston and 1x1GB Transcend DDR-2@667MHz, nVidia GeForce 7300GS.
I am running Windows 7 RC1 and it's a Clean Install.
I was experiencing this problem before as well, but it seemed to have gone away for a short while. But When I put in my new WD 500GB drive, it seems to have come back. Although I can swear there is nothing wrong with the HD, since the problem was there before as well.
When I'm in Windows, say listening to a song or something, the rest of the computer would freeze/hang RANDOMLY for upto 5 minutes :/ I mean, the song would still continue playing, but I can't do pretty much else. The mouse moves and even Ctrl-Alt-Del doesn't work. VERY annoying. I either have to wait for 5 minutes, after which the computer runs pretty slow and hangs again after sometime, or force restart.
I've done EVERYTHING possible: Flashed BIOS, reset CMOS, switched around the SATA ports for my different devices, reinstalled Windows at LEAST a million times.
I thought it was an overheating problem (and sure enough, my HDs DO run pretty hot to the touch; ie, I can't even touch them without wincing). Even my CPU was running at 73C (O.o). So I cleaned everything inside and now it runs at 53C, constant.(Doesn't exceed 60, whatsoever).
I am on the verge of tears. Please tell me what to try next?
Is it really an overheating problem? I mean can overheating lead to hangs of the kind I've described? Also, my BIOS is on pretty much its default settings: non-AHCI, ACPI enabled, etc etc.
Another peculiar thing: Sometimes, my BIOS takes AGES to identify my HDs. Like even upto a minute :/ And at times, it's instantaneous.
VERY weird, ehh?

I have a 450W power supply, btw.


My System SpecsSystem Spec
.
05 Aug 2009   #2
icoola77

Windows 7 Home Basic 64bit
 
 

Hi muth56, and welcome to Sevenforums.

What you could try :

- Install the latest Intel chipset drivers
http://www.station-drivers.com/telechargement/intel/chipset/intel_inf__9.1.1.1015(www.station-drivers.com).exe

- disable indexing and windows search, because windows may be busy indexing the contents of your hard drives

- remove additional hard drives and leave just the one where windows 7 is installed, if it runs ok, add another disk and see if the problems return, im guessing the smaller disks are older and may be damaged, but to isolate the one(s) that are problematic, you will have to test one at a time.

-Buy a couple of computer case fans and install them into your computer case so that they blow cool air over the disks.


That's all i can think of right now, but if i think of something else i will post it.

Hope this helps.
My System SpecsSystem Spec
05 Aug 2009   #3
RootAdmin

Null
 
 

probably unrelated, but recently i had an i7 motherboard that's onboard LAN was screwed up and it would freeze explorer for around 3 min when trying to open anything networking related, replaced motherboard, couldnt get it to happen again.
worst part was even with onboard lan disabled in the bios it would still freeze.

the onboard lan became screwy after it overheated. they left all the pc's in the office on, but turned off the ac because no one would be there over the july 4th holiday, i'm in texas, it was 108 the day they called me. they're lucky the only things that were damaged were a router and one of the 4 pc's in the office!
My System SpecsSystem Spec
.

05 Aug 2009   #4
muth56

Windows 7 RC1
 
 

Hi guys! And thanks for the replies!
However, I'm sure it's nothing to do with indexing since it happens COMPLETELY out of the blue.
Also, rootadmin, thanks for the feedback, but my LAN-card seems to be working fine O.o
This is truly stumping.

I just touched one of my HDs and nearly burnt my finger. It is SOOO hot :S
Also, I ran SeaTools on each of them, so rest assured, the HDs are fine. Don't know about the setup, though. Do I need to change some BIOS settings for Windows 7?
My System SpecsSystem Spec
05 Aug 2009   #5
icoola77

Windows 7 Home Basic 64bit
 
 

You could also try and change Power Options, i think the default profile is Balanced, so try setting it to High Performance, and go into advanced settings and make sure that "Turn off hard Disk after " is set to Never.

Oh and if you have AHCI enabled (because of Sata drives) then you could also try installing Intel Matrix Storage Manager.

Intel releases official Windows 7 graphics, chipset and AHCI/SATA drivers | Windows 7 Center


Of course, first and foremost, make sure you have the appropriate drivers installed for all your hardware, meaning : chipset, graphics card, audio, lan/modem etc, and try to find the latest drivers if possible, particularly drivers that are made for Win7.
My System SpecsSystem Spec
05 Aug 2009   #6
RootAdmin

Null
 
 

after re-reading your original post, it sounds like the HD is faulty, even if its reporting as A-ok, there must be something amiss in it.
My personal laptop was used and had been dropped a few times. originally it would randomly not see the hd and be unable to boot, but if it did see the hd, it would boot fine and act as if nothing was wrong other than being slow opening certain programs, replaced the hd, haven't had one problem with it since

also check the cable to the HD, kinks are bad! dirty connections are bad!
My System SpecsSystem Spec
05 Aug 2009   #7
icoola77

Windows 7 Home Basic 64bit
 
 

He mentioned that the hard drives are very hot to the touch, which should not be the case in normal circumstances.
Perhaps when he disassembled the computer for cleaning and then put it back together he did not connect hard disk cables properly.

Also muth56, how much free space do you have left on the partition where windows 7 is installed?
My System SpecsSystem Spec
05 Aug 2009   #8
harpua

Windows 7 Ultimate x64 (Retail)
 
 

The hard drive should not be that hot. Are all the drives that hot or only one? Sounds to me like the too hot to touch drive is defective. Perhaps W7 should be installed on another drive and the hot one pulled from the system. Be interesting to see what happens if the super hot one is removed from the system?
My System SpecsSystem Spec
Reply

 Windows 7 hangs for a few minutes




Thread Tools




Similar help and support threads
Thread Forum
Spinning Circle, Explorer hangs a few minutes after bootup.
Wondering if anybody has encountered any issues in the past 2 weeks with Windows 7 machines just randomly freezing, 5-10 minutes after bootup, things seem fine and then all of a sudden explorer.exe seems to just die. You get a spinning blue circle, cannot bring up task manager or anything else...
General Discussion
Windows 7 Media Hangs, after 5-20 minutes of uptime
Hello all I am struggling with this issues and it is really annoying trying to figure it out. I would appreciate any feedback or help in troubleshooting. So I built a new computer a few weeks ago for gaming and other items. I was just getting ready to start installing all my media software for a...
General Discussion
BSOD after a few minutes (5 to 55 minutes) with Samsung SSD 840 EVO
Hi. I have successfully cloned my existing OS over to the SSD 840 EVO using Samsung magician. My OS boots fine with the SSD 840 EVO but crashes several minutes after startup. Crashes can happen from 5 to 50+ minutes after start up. The crashing process happens slowly, starting with the mouse...
BSOD Help and Support
My Compaq Presario CQ40, windows 7, hangs in 2 minutes.
Hello everyone. Pardon me if my problem sounds little funny. I have Compaq Presario CQ40, windows 7 laptop.3GB RAM,320 GB Hard Disk. Since past few days i m facing this problem, whenever i put on my laptop, and when the desktop opens, my laptop hangs in another 1 or 2 minutes. i have tried...
General Discussion
System Hangs after ~ 5-10 minutes after Windows Update
Thursday night I installed a round of updates from Windows Update. All went well during the process. I even noted that that it said "Creating restore point." Since then, my system has been acting very erratically. I tried to restore to before the update, but it appears that all my restore points...
BSOD Help and Support
Windows 7 hangs about every 10-15 minutes
I have a Toshiba laptop and it had been working fine up until about a week ago. So I'm wondering about the updates that have been automatically installed since April 26th. Those numbers are kb2515325, kb890830, kb2522422, kb982018, kb2506928, kb2492386, kb915597 definitions 1.103.1139.0,...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:27.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App