Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: File permissions mystery!

10 Nov 2011   #1

Windows 7 Ultimate 32bit
File permissions mystery!

Hi,I am using windows 7 Ultimate 32bit sp1.

I have an external drive to store all my media and files.
I share the media folder via windows media player.
I can browse and play my movies on my Xbox 360.

Today I turned on my computer and the 360 can no longer see the media files.
It can see the computer but simply says 'no videos found'.

I checked media sharing; fine.
I checked media streaming: fine
I checked the PC can still see the 360; fine.
I checked the drive letter for the external drive hadn't changed; fine.
I cleared the media library in media player and re-added the media folder; fine.
Made sure I media player still shows the files and plays them; fine.

The 360 can still see the PC, but still saying 'no videos found'.

I checked the security permissions tab; bingo... found the problem.

As well as the normal security permissions (Authenicated Users, SYSTEM, Administrators and my profile), two new ones have been added: WMPNetworkSVC and another account saying Account Unknown with a red question mark beside it and a huge long alpha numeric string beside it.

All the permissions and the ability to edit them are disabled.

I checked your forums and followed the instructions for taking ownership of the folders; no joy. I also tried taking control of the individual files; no joy.

Does anyone have any idea how I can fix this problem?
I though about deleting the Account Unknown entry, but it said that it was inheriting permissions.

I have reached the limit of my expertise, help!


My System SpecsSystem Spec
10 Nov 2011   #2

Windows 7 Proffesional 64 bit

Well, you can do this in a few ways.

First) Put the file on a pen-drive or external hard-drive. Then go into windows safe mode and try editing the permissions on the file off your pendrive. This may of may not work.

Second option) Click run as administrator before streaming to the 360, usually works. (Recommended option)

Hope this helps,

My System SpecsSystem Spec
10 Nov 2011   #3

Windows 7 Ultimate 32bit

Thanks Rowan,
Tried both these options and no joy.

Have now also tried creating a new directory and copying the files to it, but they still have the same problem.

Any ideas?
My System SpecsSystem Spec

10 Nov 2011   #4

Windows 7 Proffesional 64 bit

No, but i'll look into it for you:)

My System SpecsSystem Spec
10 Nov 2011   #5

Windows 7 Ultimate 32bit

Ok, got it!

This is the solution that worked for me... is not for the faint hearted or those who don't have a backup.... you have been warned!!!

Step 0:
You must be logged in as an administrator.

Step 1:
At the top level of the affected directories/files, right click the folder and select 'properties'.

Step 2:
Select 'security' tab. VITALLY IMPORTANT: take a note of the profiles that are attached to the directory together with which permissions boxes are ticked... you will need to put them back EXACTLY later. Click 'advanced'.

Step 3:
Select 'Change permissions' and select any of the listed profiles. I used my profile name, but it also worked with 'administrators'. Then untick the 'Include inheritable permissions from this object's parent'.

Windows will then parse the files and directories you selected and remove the inheritances. 'Ok' everything to close down the properties. The directory you selected will now not be navigable. Don't panic...

Step 4:
Select the directory again and right click. Select properties again.
Now click 'edit', then 'add', then 'advanced', then 'find now'. Select your current administrator profile that you are logged in as and click 'ok', then click 'ok again.
Select the correct permissions check boxes for this profile and click 'apply'.

Now add each of the original profiles in turn following the same steps.

Click 'ok', and all should be well again.

Like I said, not for the faint hearted as the potential for screwing things up is really high... good luck!
My System SpecsSystem Spec
10 Nov 2011   #6

Windows 7 Proffesional 64 bit

Ok I hope all is well now.

My System SpecsSystem Spec
10 Nov 2011   #7

Windows 7 Ultimate 32bit

Tested and all good.
Thanks for your help,
My System SpecsSystem Spec
10 Nov 2011   #8

MS Windows 7 Ultimate 64-bit SP1

Digitalhelix, the procedure you have explained is a standard procedure every administrator follows for modifying the permissions. You will never loose the files by changing the permissions, but only the access which can be gained back with correct permissions...:)

Anyway glad that you could resolve your problem...
My System SpecsSystem Spec

 File permissions mystery!

Thread Tools

Similar help and support threads
Thread Forum
Mystery File Found
Hi Folks, I found a file (un_report.dat) on my Laptop, any suggestions?
General Discussion
Problem modifying hosts file, change file permissions?
Hi all,win7 Home Premium 64 bit. I'm having difficulties modifying my hosts file. Following guidance from this forum, I open Notepad++ as administrator & can navigate to and open the hosts file. But the "Save" option is greyed out, so I can't save directly to the original location. I can Save As...
General Discussion
Mystery to HOSTS File
Hi, :D Sorry if this is the wrong section but I didn't know where else to post it. But lately I have been attempting to connect to games and I can't and I keep getting errors that relate back to my hosts file(it's what I've read on the gaming forums). I can't seem to connect to games, when they...
Network & Sharing
LIVE FILE burning mystery
Hi guys I've been burning files with the LIVE FILE system, the files do copy and I'm able to close session "properly" to eject the disc. When I put BACK the dvd/cd, I can see that files have been written because a few GB of used space are shown (2.33gb free of 4.38gb). HOWEVER, when I...
Music, Pictures & Video
My Stationery File - Mystery Arrival
Hi With Brink's help I have recently recreated all my personal user folders after some incorrect deletions... However a mystery My Stationery folder with files like Art Deco has appeared in My Docs. Where has this come from and how is it normally used? I don't have Live Mail or anything like that....
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 08:51.
Twitter Facebook Google+