Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Always ask permission to copy files to C: drive and can't download

12 Nov 2011   #1

Windows 7 Ultimate x64
Always ask permission to copy files to C: drive and can't download

Hi all. I'm having a strange problem in Windows 7. The problem is that basically, anytime I want to copy a file to the C: (OS partition), Windows asks me if I want to continue copying a file there (I am an administrator so I don't know why it should). Also, if I want to download a file to the C: partition, it won't allow me and it'll tell me I have to save it in my username folder, not in the C: root. According to the persmissions, administrators have full control but I'm still asked if I want to copy files. So can anyone help on this? I've tried assigning users to have full control but I get a series of messages like "This file is currently in use, cannot set permission" and access denied for "Program files, Program Files (x86), Windows and C:\".

My System SpecsSystem Spec
12 Nov 2011   #2

Windows 10 Pro (x64)

Don't save to the root of the C: drive. Problem sovled. You have a user directory and a download directory for a reason.
My System SpecsSystem Spec
12 Nov 2011   #3

Windows 7 32 bit

If you really want to be logged in as administrator see this tutorial:

Built-in Administrator Account - Enable or Disable[2]=User%20Accounts

by the way, I don't use a download folder under my user account. I use a download folder directly under C:\. But I guess since it was not created by the system, but by me, it doesn't hassle me about it.

Some things I like to have the same across all flavors of Windows.
My System SpecsSystem Spec


 Always ask permission to copy files to C: drive and can't download

Thread Tools

Similar help and support threads
Thread Forum
Can't get permission to copy files to USB
Hello, For some reason I cannot copy files from the internal hard drive to a USB pen drive. When I try to do this, I get the following message: "Destination Folder Access Denied You need permission to perform this action." Although, I can copy files from USB to my PC(except powerpoint...
Copy files to new PC - file permission problems
I've just bought a new laptop and I need to move my personal files from the old one to the new one. I've tried several methods, but they all give me problems with certain files: some files (and I have not been able to find any pattern here) will simply not copy over. What I've done: Move files...
General Discussion
Can't copy files, Require permission from self, Common fix not working
I'm attempting to copy files from one HDD to another. The tens-of-thousands of files in question are in a complex hierarchy system, and windows file copy dialog isn't helping me identify the specific culprits, since many files share names within the hierarchy and the dialog doesn't show the path. ...
System Security
Permission denied to access/copy files from my old computer
I built a new desktop and did a clean Windows 7 64-bit install. I hooked up the hard drive from my old PC, which had XP on it, so I could copy all the files over to my new hard drive. But when I try, I keep getting errors that I don't have permission to access the file or copy the file. I was...
General Discussion
Permission denied to copy my own files
Hi there, I know there have been a lot of tutorial/tips on how to deal with permission when you need to copy files on Windows 7. I have turned off UAC, take the ownership of the folder and all sub-folders/files ... but still I have not been able to copy quite a few files in one of my folder. ...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:17.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App