Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: F8 "Repair your computer" stops working with 0xc000000e

15 Nov 2011   #1

Windows 7 Home Premium 64bit
F8 "Repair your computer" stops working with 0xc000000e

hi all

I am new to this forums and here is my question.

I tried to verify whether the F8 restore factory function is working in my dell inspiron 1545. I got this error -

Windows failed to start. A Recent hardware or software change might be the cause. To fix the problem:
1. Insert your windows installation disc and restart your computer.
2. Choose your langugae settings, and then click next
3. Click "repair your computer."
Status: 0xc000000e
Info: The boot selection failed because a required device is inaccessible.

there is only one operation system - windows 7 home premium installed. it boots correctly.

I found a thread at - Windows 7, "Repair your computer" F8 boot option not working (SOLVED) | Knowledge Base. it utilizes bcdedit to fix the problems.

for my case, the output of bcdedit /enum all shows unknown device as well. but I also noticed my output has 2 different guids.

i have no idea which one indicates which partition at all.

i will post my bcdedit output later today. hopefully, it will help troubleshooting.

thanks in advance,


there is the output of bcdedit.

Windows Boot Manager
identifier {bootmgr}
device unknown
description Windows Boot Manager
locale en-US
inherit {globalsettings}
default {current}
resumeobject {13d11a3c-b853-11de-82fc-002564641051}
displayorder {current}
toolsdisplayorder {memdiag}
timeout 3
customactions 0x100003d000001
custom:54000001 {0731e9bc-95c1-11e0-b998-0025645b65e9}
Windows Boot Loader
identifier {0731e9bc-95c1-11e0-b998-0025645b65e9}
Windows Boot Loader
identifier {0731e9bd-95c1-11e0-b998-0025645b65e9}
description Windows Restore
Windows Boot Loader
identifier {0731e9be-95c1-11e0-b998-0025645b65e9}
description Windows Restore
Windows Boot Loader
identifier {current}
device partition=C:
path \Windows\system32\winload.exe
description Windows 7
locale en-US
inherit {bootloadersettings}
recoverysequence {13d11a3e-b853-11de-82fc-002564641051}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {13d11a3c-b853-11de-82fc-002564641051}
nx OptIn
bootstatuspolicy IgnoreShutdownFailures
Windows Boot Loader
identifier {13d11a3e-b853-11de-82fc-002564641051}
Resume from Hibernate
identifier {13d11a3c-b853-11de-82fc-002564641051}
device partition=C:
path \Windows\system32\winresume.exe
description Windows Resume Application
locale en-US
inherit {resumeloadersettings}
filedevice partition=C:
filepath \hiberfil.sys
debugoptionenabled No
Windows Memory Tester
identifier {memdiag}
device unknown
path \boot\memtest.exe
description Windows Memory Diagnostic
locale en-US
inherit {globalsettings}
badmemoryaccess Yes
EMS Settings
identifier {emssettings}
bootems Yes
Debugger Settings
identifier {dbgsettings}
debugtype Serial
debugport 1
baudrate 115200
RAM Defects
identifier {badmemory}
Global Settings
identifier {globalsettings}
inherit {dbgsettings}
Boot Loader Settings
identifier {bootloadersettings}
inherit {globalsettings}
Hypervisor Settings
identifier {hypervisorsettings}
hypervisordebugtype Serial
hypervisordebugport 1
hypervisorbaudrate 115200
Resume Loader Settings
identifier {resumeloadersettings}
inherit {globalsettings}
Device options
identifier {13d11a3f-b853-11de-82fc-002564641051}
device ramdisk=[C:]\Recovery\13d11a3f-b853-11de-82fc-002564641051\Winre.wim,{e6752485-d2da-11de-8cd2-cdc3b318e7d5}
description Ramdisk Options
ramdisksdidevice unknown
ramdisksdipath \Recovery\WindowsRE\boot.sdi
Setup Ramdisk Options
identifier {ramdiskoptions}
description Restore Windows to factory settings Press F3
ramdisksdidevice unknown
ramdisksdipath \pcra\boot.sdi

My System SpecsSystem Spec
15 Nov 2011   #2
Microsoft MVP


All boot repair commands are automated in Win7 Startup Repair.
You sometimes have to run it more than once to sort all of the issues as it runs multiple test and fixes.

You said that you attempted to run Dell Factory Recovery from its F8 hotlink, but the error you report is one which is received when one tries to boot into a HD which will not boot.

Did you choose the Repair My COmputer link on the F8 Advanced Boot Options?
Did you then see the Factory Recovery Option as shown in this tutorial? Dell Restoring Your Computer´s Software to the Factory Settings

We need to know exactly what happened: What you did and when you got the errors, not just saying you booted into F8 and got this error. Please retrace and report every step.

It's possible what is needed is this if clicking Factory Recovery errors out: Dell Recovery Partition - restoring F8 link
My System SpecsSystem Spec
16 Nov 2011   #3

Windows 7 Home Premium 64bit

hi gregrocker

thanks for the reply first of all.

that is what i did.

1. this laptop was purchased as a refurbished one. that is why i want to recover entire system back to factory originals.

2. when the system first booted, there was 2 options - a) windows 7 b) recovery factory (something likes that. I can't remember exactly).
so, i gave the recovery a try and then System Recovery Options did not show at all. instead, it could not go anywhere. errors showed as i attached.

3. i booted system to windows 7. in disk management, i saw 4 partitions. the first one is factory oem. second one is a 256mb bland primary partition. there is no data no drive letter assigned. the third one is RECOVERY partition. the last one is OS partition.

4. so i dropped the second blank partition and merge the space back into RECOVERY partition.

5. after rebooting system and trying to recovery system once more, the error still shows exact like before.

the that is pretty much ALL i did so far.

i think i may have to try Dell Recovery Partition - restoring F8 link.

i will let you know later today.


My System SpecsSystem Spec

16 Nov 2011   #4
Microsoft MVP


Why would you merge a 256mb "blank" partition into the Recovery partition? Did you browse into it after unhiding Hidden and System files in Control Panel>Folder Options>View? It could have been your System boot partition!

Can you boot free Partition Wizard bootable CD to see a picture of your partitioning, post back a camera snap of the full drive map showing all listing columns? Take note of which partition is marked Active. If none, rightclick on Win7 partition to Modify>SEt to Active, Click OK. Then click on Win7 HD to highlight it, from Disk tab select Rebuild MBR, Apply. This may start your WIn7 if you deleted the boot partition.

If this fails you'll need to run Startup Repair from the DVD Repair console or Win7 Repair CD: System Repair Disc - Create

Report back with the results and camera snap attached using paper clip in reply box.
My System SpecsSystem Spec
16 Nov 2011   #5

Windows 7 Home Premium 64bit

also, i have a question about the recovery partition. according to my research, the recovery partition should not have any drive letter assigned. otherwise, it will not work.

but after reading the post Dell Recovery Partition - restoring F8 link. they do manipulate on a recovery partition with a drive letter assigned.

who is right?

My System SpecsSystem Spec
16 Nov 2011   #6
Microsoft MVP


If you want to restore the Recovery partition then follow the instructions in Dell's link, including use of any drive letter as specfied.

But first: If you want to get Win7 started please follow the steps I just gave you to determine if you deleted your System Boot partition, then Rebuild MBR or Startup Repair.

I have a limited amount of time to work with you today.
My System SpecsSystem Spec
16 Nov 2011   #7

Windows 7 Home Premium 64bit

the blank 256mb partition is purely blank. there is no data, no letter assigned. it shouldn't be the boot partition. since windows 7 still boot successfully.

my guess was that person who previously owned this laptop wanted to make a free partition for something else. i tried to use a winpe and a partition tool to hidden it. but recovery still complained device not recognized.

the currently active partition is the recovery partition. i guess it is supposed to be the win 7 partition. but it IS the recovery partition. also, my other identical laptop, which is working good both win7 and recovery function, has the same settings.

i think i will give this - System Repair Disc - Create a try first. since the error indicated to use a system repari disc to fix the issue.


My System SpecsSystem Spec
16 Nov 2011   #8
Microsoft MVP


The Recovery partition is Active because it also holds the System boot files so that Dell Recovery in Win7 can operate from F8 menu rather than needing the hotkey (which marks Recov partition Active) as in older Dells.

I was under the mistaken impression Win7 will not boot so it isn't necessary to Repair that or move the Active partition to Win7 unless you are unable to get Recovery Partition to boot or make disks and decide to delete it and recover its space.

It is a good idea to have the Repair CD on hand however in case Win7 fails to boot.'

Try the fix to return Dell Recovery to it's F8 link: Dell Recovery Partition - restoring F8 link

If this fails then you can seek additional help from Dell tech support (Chat sometimes remains free after a year's time). If you decide to recover the disk space we can advise you if you'll post back a screenshot of your maximized Disk Mgmt drive map and listings using Snipping Tool in Start Menu.
My System SpecsSystem Spec
16 Nov 2011   #9

Windows 7 Home Premium 64bit

Hi gregrocker

in this post Dell Recovery Partition - restoring F8 link, people tried to use the tool SetAutoFailover.cmd. this tool requires to give a driver letter of recovery partition, which is hidden in my case.

so, should i give the recovery partition a drive letter and run the command? i did tried to assign a drive letter to the recovery partition and it disappeared after a reboot.


My System SpecsSystem Spec
16 Nov 2011   #10
Microsoft MVP


Yes, try again.

Looks like it will be needed if there's chance this will work.

Did you make the Recovery Disks earlier?

Can you perchance make them now, as this interfaces differently from Win7?

Likewise, will Recovery Partition boot from Dell Datasafe link in Win7?
My System SpecsSystem Spec

 F8 "Repair your computer" stops working with 0xc000000e

Thread Tools

Similar help and support threads
Thread Forum
"repair your computer" isnt working
Hi guys, i wanted today to recover my Windows 7 Home premium SP1 64bit to factory backup on my laptop Dell Studio 1749, but when i selected command "repair your computer" in advanced boot options, instead of showing system recovery options it boots Windows 7. I found few threads about this, but i...
General Discussion
Windows 7: "Repair your computer" option not working (from f8)
Hello, I have a Dell Inspiron N7110 with windows 7 home premium. I want to restore my computer to factory settings but whenever I hit f8 at startup and choose the "repair your computer" option, my computer just boots up normally. I've tried several times and it never works. Please help!
Performance & Maintenance
"Repair Your Computer" Not Working
Hey guys I'm having some trouble with my laptop. I have a virus or viruses on my computer and have ran numerous scans and recovery disks to try and get them erased but to no avail. I've decided I'm going to factory reset my computer but in trying to do so I come up with another problem. During...
Installation & Setup
"Repair Your Computer" option not working (restoring factory backup)
I have a Dell Studio 1440 with Win 7 home premium 64bit. I want to use the built-in recovery but after pressing F8, I click on Repair Your Computer and Windows 7 begins to load instead of going to the recovery GUI. I am trying to restore the system to it's factory settings and it had worked...
Installation & Setup
To open "Manage" windows explorer stops working
I have a problem: When I right-click Computer to open "Manage" windows explorer stops working and looking for a solution .. Everything is blocked and the desktop disappears for 2 seconds and reappears! I open "manage" with shortcut(Computer Management) but the right- clic does not work!...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:33.
Twitter Facebook