Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Not Booting after resizing partition, No Boot Error

18 Nov 2011   #1

Not Booting after resizing partition, No Boot Error

I had an empty 70 GB partition on the left of my computer and a 230 GB on the right side but I wanted to combine them. Windows was on the 230 GB partition. I booted GParted and combined them, it copied everything from the 230 GB partition over and resized it, it took a few hours.

I assumed after it wouldn't boot and all I would have to do is pop in my Windows 7 install disc and go through the repair setup. At first I ran startup repair and it would say it found a problem, and I rebooted and still nothing.. After the bios loads and it lists my DVD drives I just get a cursor _ blinking, nothing else.. No BOOTMGR missing.

Odd I thought, so I ran repair again, and again it found another problem. I did this several times before it said it could not detect a problem but it still would do the same thing.

I opened the cmd prompt and issued the following commands

bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildocd

I tried installing a second copy of W7 on a 10 GB partition on the end, it went successfully but still blinking cursor. Theres a 54 MB partition at the beginning of type Primary, the main windows one is System and the test windows 7 partition is Primary as well. I thought the first one was usually 100 MB but maybe I am wrong.

Still I am stuck with a blinking cursor _ ...

Any insight is appreciated, thanks.

My System SpecsSystem Spec
18 Nov 2011   #2

Windows 7 32 bit

I've only used GParted when installing Linux. It may be worth a shot to boot it and see if it has some sneaky way of remembering the last operation. See if it gives any option to undo.

In the old days I used to move partitions all around using Partition Magic and everything always booted fine. Guess it's touchier now.
My System SpecsSystem Spec
18 Nov 2011   #3
Microsoft MVP

Windows 7 Ultimate X64 SP1

You can try the free (Home Ed) of Partition Wizard Bootable CD allows user to boot computer directly to manage partition. to see if you can recover the partition and then resize as needed.
My System SpecsSystem Spec

18 Nov 2011   #4


I forgot to mention I did load some sort of partition program called Active Boot Disk which allowed me to look at the drive, I could see all my files, windows folder etc.

To me it seems like some sort of boot manager issue not working properly as opposed to my windows installation going missing.
My System SpecsSystem Spec
18 Nov 2011   #5

Windows 7 32 bit

The booting is sensitive to the start of partitions. If a partition sizer doesn't do it right, esp. when moving or changing the start of the partition, that's when you have problems. That's why the Windows Disk Management doesn't want to let you absorb a partition to the left of the system partition.

I suggested booting GParted again in case it left a log file hidden on the drive someplace with a record of what it did. You may be able to put it back if you know exactly what changed. But it sounds like it moved files. For that reason I would try the undo with the program that did the do.
My System SpecsSystem Spec
18 Nov 2011   #6

Windows 7 32 bit

btw when you say you backed up everything that mattered it sounds like that didn't include the partitions and partition table? If you do an image restore it would probably be easier to try another program like Partition Wizard after you reset to a bootable usable system. The more you experiment around in broken the likelier to get further and further away from a fix.
My System SpecsSystem Spec
18 Nov 2011   #7
Microsoft MVP


It's likely the resizing failed and may be unrecoverable after using a dated XP-era tool and line commands to do such modern operations which are all automated now. Older tools can foul out when resizing on the boot sector. We've helped thousands of users here with complicated resizing operations using free Partition Wizard bootable CD which has never failed, and is the only one I know which won't.

You can browse in to see if your files are intact and rescue any this way: Copy & Paste - in Windows Recovery Console or Paragon Rescue CD. This will clue you if there's anything left.

If so boot the Win7 DVD Repair console or Repair CD, see if it detects an installation, if so accept any offered Repair. If not or Win7 fails to reboot, boot back in to Recovery Tools to run Startup Repair up to 3 separate times with reboots until Win7 starts

One last resort is using PW CD: After verifying Win7 or it's 100mb System Reserved partition (preferred) is still marked Active, click on Win7 HD to highlight it, from Disk tab select Rebuild MBR, Apply, reboot. If this fails, try again moving the Active flag to Win7 partition itself in case SysReserved has been hashed.
My System SpecsSystem Spec
19 Nov 2011   #8


Thanks, I will try PW CD as W7 startup repair I ran 5 times and it said the partition table had no SYSTEM partition in the details, which did the same thing 5 times.

I plugged my drive into external enclosure, all my data showed up fine and Im backing it up now. If PW CD doesnt work I guess I will reformat the entire drive.
My System SpecsSystem Spec
19 Nov 2011   #9
Microsoft MVP


You might need to mark Win7 or its SysReserved Active (try both starting with current) which PW CD can do or use Diskpart from DVD/Repair CD Command line:
Partition - Mark as Active (Method Two)

Then run Rebuild MBR from PW CD and if it fails Startup Repair 3 Separate Times
My System SpecsSystem Spec
20 Nov 2011   #10

Windows 7 Pro 64

If I ever needed to re-size to a larger partition, I would likely first try the work-around using Junction/Symbolic-links. Any opinion on practical limitations of this approach?
My System SpecsSystem Spec

 Not Booting after resizing partition, No Boot Error

Thread Tools

Similar help and support threads
Thread Forum
Something went wrong while resizing partition, now windows cant boot.
I really need your help with this problem. I have an Acer Aspire 5733-6607 with Windows 7 Home Premium 64bit installed. Two Months ago, I made another partition to install Elementary OS on it. After getting tired of it, i decided to delete the partition and resize my windows partition using...
Backup and Restore
Laptop SSD partition led to Windows not booting - Win Boot Mgr error
On a new Asus Win 7x64 laptop (Zenbook Prime UX21A), I was repartitioning the SSD with EaseUs and it seemed to be going well until restart. At that point, EaseUs gave a failure message and then Windows gave a failed to start/Windows Boot Manager mesage, with the error code 0xc00025. The Info is...
Hardware & Devices
Windows 7 - Error 0xc0000225 after resizing partition, can't boot
Hi everybody, I tried to resize my Win7 parition with Esaeus partition manager. So I had to restart win7 and before starting the SO the program began resizing the partitions. Unfortunately my brother plugged off the pc and when I restarted the pc on Win7 I saw this error: 0xc0000225 "boot...
BSOD Help and Support
Error 0xc0000225 after resizing partition, can't boot
Hi, I tried to resize the second partition on a friend's notebook from 252 GB to 75 GB – the partition where Windows 7 is installed (it's a Lenovo IdeaPad U550). I did this with KDE Partition Manager from a Linux Mint 9 KDE LiveUSB after I couldn't find the partitioning utility in Windows 7 in...
BSOD Help and Support
Seven boot problems after partition resizing
I installed windows seven beta a few weeks ago. I made the partition too small at the time and just recently used a live ubuntu cd's partition editor to add more space to the windows seven partition. When I booted into vista it automatically check the drive and restarted with no problems. ...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:59.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App