Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Anyone else kind of disappointed?

10 Aug 2009   #11
poin2

Windows7
 
 

I'm pretty happy overall. It's seeming stable and slick.

The RC was feature complete, and it's purpose was to test for bugs -- not add new features. I'm glad they didn't go trying to do anything extra. It's really truly a "Release Candidate," meaning you tell us the disasters that makes this something we can't release, not tell us what icons to add.

They can add doodads like icons and taskbar tweaks, etc. over time. Right now the foundation needs to be solid.

I'd mainly like to see more drivers, etc. I'd indeed like more input on what drivers are installed originally, and I'm finding there are some things like my Canon scanner where Vista drivers actually don't work (and what it installs by default doesn't work either).

But disappointed, no. They actually got this solid a lot faster from the RC than I expected.


My System SpecsSystem Spec
.
10 Aug 2009   #12
Zidane24

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64
 
 

Quote   Quote: Originally Posted by Antman View Post
I have to agree with the OP. I am completely bummed that my $300 version doesn't contain any untested and potentially dangerous features.
lmao...very nice
My System SpecsSystem Spec
10 Aug 2009   #13
LarryLaser

Windows 7 7600 x86 &x64, Windows XPP sp3 (x86) & sp2 x64
 
 

Quote   Quote: Originally Posted by Antman View Post
Because the issue propogates across platforms and OS builds, it is reasonable to conclude that the cause is not in the hardware or the OS build.

Are you applying a setting at any level that is drawn from your legacy bag of tricks?

For more than a year, I dealt with XP booting to svchost running at 50%/100% due to a customized network setting on my slipstream CDs. I knew it was somewhere in those settings because I finally solved the problem by installing from a slipstream that used default network settings. I burned an entire pack of CDs testing different slipstream configs. I still do not know what the actual setting was that caused the problem.

Something I "learned" and applied caused a major XP "bug". It spanned XP, XP SP1 and XP SP2 on every machine I ever installed it on.
Yes Antman, I have dealt with that issue in Win XP as well, and found the solution to the problems in the settings for network controls and services related to them.
That is what I am trying to solve in Win7. Not massive resource demands, just the freeze problem.

I do a lot of experimenting in my design work on my laptop (the Lenovo, the Acer is my Wife's toy) and them Sync the files to my main box, then intigrate the design work and run simulation testing on my main box (cause It has the needed resources).

The only Network services that I have not used yet is the HomeGroup, I did test it in the beginning, but It will not communicate with any other OS but Win 7 and Server 2008. But I don't think that it would be related to the Freeze problem.

One point that I can not figure out, When my System (my main box) goes to sleep and then freezes, it turns off the Network Adapter and USB ports.
I have gone through the Advanced settings and disabled the shut-down options on them, but they still shut down on the 7600 version, that one didn't happen on the earlier versions, (that I recall).
My System SpecsSystem Spec
.

10 Aug 2009   #14
Antman

 

Mr. Laser, it is bedtime here in DC. Let's pick this up tomorrow. Create a thread and copy your two posts from here. SF can help you fix this.

The Ozarks are beautiful.
My System SpecsSystem Spec
10 Aug 2009   #15
LarryLaser

Windows 7 7600 x86 &x64, Windows XPP sp3 (x86) & sp2 x64
 
 
Yep

Yea Mr. Antman
Its past my Bed time too.
I will start a post in this and see if any one else has these problems, I have been posting on the TechNet Forum, but still no solutions.

Thanks.
My System SpecsSystem Spec
10 Aug 2009   #16
Antman

 

Quote   Quote: Originally Posted by LarryLaser View Post
Yea Mr. Antman
Its past my Bed time too.
I will start a post in this and see if any one else has these problems, I have been posting on the TechNet Forum, but still no solutions.

Thanks.
TechNet lacks the technical expertise available here.
My System SpecsSystem Spec
11 Aug 2009   #17
mats

Windows7 Enterprise
 
 

As it happends I got 965P-DS3 in one of my seven boxes and I have seen one resume failure on that box but only one and i do use that function a lot. Running 64 bit Enterprise on it with a nvida 7600 Gt
My System SpecsSystem Spec
11 Aug 2009   #18
Zidane24

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64
 
 

Quote   Quote: Originally Posted by Antman View Post
TechNet lacks the technical expertise available here.
OMG...that avatar isn't funny at all Antman
My System SpecsSystem Spec
11 Aug 2009   #19
tw33k

Windows 7 Ultimate (x64) SP1
 
 

Quote   Quote: Originally Posted by Zidane24 View Post
OMG...that avatar isn't funny at all Antman
I agree...what's that about?
My System SpecsSystem Spec
11 Aug 2009   #20
1ncredible

Windows 7
 
 

Quote   Quote: Originally Posted by squonksc View Post
+1

Never enjoyed any OS more than Win7.
Ditto, Fast 'n' friendly
My System SpecsSystem Spec
Reply

 Anyone else kind of disappointed?




Thread Tools




Similar help and support threads
Thread Forum
Cloning Disappointed
:confused: I want to avoid the hazel of installing and updating Win 7 if current hard drive dies. All else (e.g. documents, AppData, eMail backed up and easily restored). I have identical hard drives (SATA) and cloned current drive "successfully". When I swap the drives, everything seems to...
Backup and Restore
Very disappointed with Win7 Core i7 DVD playback.
I have a Thinkpad W510. 8 GB RAM, running Win7 Pro 64-bit. My previous laptop was a Thinkpad T61 with 32-bit XP and 3 GB RAM. DVD playback on that machine was flawless, I could set up a DVD for the kids and never have to worry about it. There were no lags, no hiccups, no pauses. Playback on...
Performance & Maintenance
Max Payne 3 Pushed back 2 more days Disappointed
I don't know what it is with this Max Payne 3 Game but The release was last night 9pm pacific time 12am Eastern and I'll be Damed ! (Farooq voice lmao ) It was pushed back to june 1st STEAM issue? Does anyone else know anything about this I been waiting a long time for this and im about to...
Gaming
IE9 not impressed..slightly disappointed.
more of a random ramble about my hatred for IE9 here. I'm not thoroughly happy with IE9 at all. there are several annoying quirks about it that get on my nerves. none of these were present with IE8. 1. often in forums I have to click on things 2 times to get a response. 2. often pages will...
Browsers & Mail
Disappointed in XP Mode :(
I'm disappointed in XP Mode because it refuses to run several programs which previously operated without a hitch in XP Professional. Windows Virtual PC installed without problem and, thereafter, FireFox v 3.6 and PCTools v 2010 installed, call-up and run fine. Others, e.g. Palm Pilot v 4.1,...
Virtualization
Disappointed, satisfied? Thoughts about RTM...
Now that most of you are running the 7600.16385 (RTM), what are your thoughts on what is basically the finished version of Windows 7. After the past 6 months or more of progressing builds on the new OS, are you satisfied with the final product? Are you disappointed? Was there anything not in...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:56.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App