Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Trying to Delete Program Files, Access Denied

22 Dec 2011   #1

Windows 7 Home Premium 64bit
Trying to Delete Program Files, Access Denied

This entire morning thus far I've been attempting to delete files from Norton Internet Security, which has been inactive for a long time (we are not going to renew our account) and has been bugging us constantly. I assumed it would be an easy task, and I couldn't have been farther from the truth.

I went into the C:\Program Files (x86)\Norton Internet Security\ where the data for the program is found, and I couldn't delete the files. A dialogue saying
"You need permission to perform this action
You require permission from administrators to make changes to this folder"

I thought it weird, since I am one of the computer's administrators. Next, I logged on to my dad's profile (at his insistence, though there shouldn't be any difference in the administrator powers of our profiles). The same result followed.

Next, I looked online in a Google search and found this site, which told me to use the command prompt to first give me the ownership of the files, then give me complete permissions to the files, and then delete them. All three of these actions failed. The command prompt said "Access denied".

I tried a couple other command prompt actions, and all failed. I'm at a loss for what I'm supposed to do, or what I'm doing wrong. Does anyone know what the problem is?

My System SpecsSystem Spec
22 Dec 2011   #2

win 7 ultimate32bit, Win8.1pro wmc 32bit

Hi snowguy13, welcome to the forums , try our tutorial for a better way to take ownership of said file Take Ownership of file - Vista Forums
My System SpecsSystem Spec
22 Dec 2011   #3

Windows 7 Pro x64

Did you uninstall the program?
You can't just go in and start deleting the files without first uninstalling it either through Windows uninstall program or Nortons own uninstall option.
My System SpecsSystem Spec

22 Dec 2011   #4

Windows 7 Home Premium 64bit

welcome to the forums
Thank you!

try our tutorial for a better way to take ownership of said file Take Ownership of file - Vista Forums
Thanks but that's exactly what I had tried... However, after following mgp1964's advice it worked! Thank you!

Did you uninstall the program?
I did now. :P However, even through the command prompt I am still denied access to many files, even though I have ownership... :/
My System SpecsSystem Spec
22 Dec 2011   #5

Windows 7 Home Premium 64bit

I have a hunch that it has something to do with me owning the Norton Internet Security folder, but not all of its subfolders and files... Is there a quick way to own EVERY file and folder in a directory?
My System SpecsSystem Spec
22 Dec 2011   #6
Microsoft MVP

Windows 7 Ultimate 32bit SP1

Use the Norton Removal Tool
You might have to right click and choose to run as Administrator.
My System SpecsSystem Spec

 Trying to Delete Program Files, Access Denied

Thread Tools

Similar help and support threads
Thread Forum
Can't delete folder - access denied
Hello! I have a small issue concerning deleting folder. Here's situation: I had a folder that I wanted to delete. I used shift+del combo for instant deletion, but than issue occured. Basicly, folder stayed, yet files deleted themselves. And when I try to delete the folder, it says I need...
General Discussion
Log Access denied Win7 Program Files (x86) Wondershare Video Editor
Wondershare support group say they can't help me unless I send the log files. I can't send the log files because it seems I don't have permission. I'm the administrator so I don't know what's going on. I have Windows 7
I cannot delete a particular file Access Denied
I am tryiong to save, delete or overwrite the file "Clear Print Spooler.bat" in C;\windows\system32 and in each case get "ACCESS Denied" error. I have tried the above in the command window with admin. priviledge. Same error. I had added a line that contained the word "Runas". Now I try to remove...
Security Basics
Can't delete a file - Access is denied
Hi, I have a compiled .dll file that I want to delete - but I can't do it in any way. I already tried del command line and take ownership (both GUI and cmd) but nothing helped so far. I always get the Access is denied error. Any idea will be appreciated! Thanks, Shaorn
General Discussion
Writing To Program Files Folder - How (Access Denied) ?
Hi, I need write/full access to some files that are located in the Program Files folder on a Windows 7 64 bit machine but keep getting access denied messages. Can anyone please tell me how to temporarily allow write/full access to this folder? I am the PC owner with admin priveliges but...
General Discussion
access denied when I delete files in safe mode admin
Hello, I have an external drive which I'm trying to reuse as a storage only medium. It's a usb drive on which at one point I managed to install a limited version of windows xp,to run on my first netbook (which I no longer use). I have put other stuff on the drive so I don't want to format it, but...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:09.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App