Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Trying to copy txt file in Notepad. "Notepad: Access is denied"

26 Dec 2011   #1

Windows 7 Professional 64bit
Trying to copy txt file in Notepad. "Notepad: Access is denied"

If I had known how much hassle Win 7 was I would have stuck with XP! Well I suppose its a learning curve....

Latest major hassle, I have a text file on my E:\drive, this is a copy of my XP C:\ drive before I installed Win 7 on it.

I have now been able to get to it after changing the security settings, and then tried to drag and drop my Blacklist.txt to a newly installed version of the program (Mailwasher Pro) on my C:\ drive. I was not allowed to do this as "Notepad: Access is denied", I could not open it either to copy as again "Access is denied". What ever I try access is denied. This applies to Wordpad as well.

I am setup, as far as I can tell as administrator, I have printed and read the tutorial - Permissions - Alloy or Deny Users and Groups. but this did not seem to help, when I open the security tab it shows:
and a long, long set of numbers, there is no administrator or user information as I have seen in other Security tabs.

It was dead easy in XP just drag and drop or open in Notepad and copy paste across!

Is there a way to get around this problem?

My System SpecsSystem Spec
26 Dec 2011   #2

win 7 x64

1. If you have any AV running disable it and try to move the file.

2. Try to email the file to yourself and then open it.

See how those go.
My System SpecsSystem Spec
26 Dec 2011   #3

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64

Open notepad at an elevated level (Right click on notepad and select Run as Administrator).
Then open the text file and save to C:
My System SpecsSystem Spec

26 Dec 2011   #4

Win 7 Pro x64

Just a thought....

When you go to run Notepad, right click on it and choose the option "Run as administrator." I know it may seem redundant, but sometimes this makes major differences even on an account with Administrator privileges.

(Edit: What pbcopter said. )
My System SpecsSystem Spec
26 Dec 2011   #5

Windows 7 Ultimate SP1 - 64 Bit

You could try Taking Ownership of the folder or area your saving it to:

Take Ownership Shortcut

As well as Right Clicking on Notepad and selecting Run As Administrator.
My System SpecsSystem Spec
26 Dec 2011   #6

Windows 7 Professional 64bit

I have tried to send it by email, still Access Denied.
I have tried to get Notepad and wordpad to open the file, still Access Denied.
I have tried to open in V PC, still Access Denied.
I have tried to edit the permissions, still Access Denied.
I have tried to change the owner, still Access Denied.
I have tried to copy the whole folder and move to another drive, still Access Denied.

I will try the ownership of shortcut tomorrow, but have my doubts.

I think on every folder I have changed the permissions on I have seen, the following:
Everyone, SYSTEM, User (me) as administrator and user (me)

On this file there is SYSTEM and a 'bust' with a ? mark along side a long, long row of numbers, no administrator or user details. In 'Details' it is shown as Administrator as the owner.

In security there is an option to Edit permissions, this screen gives the choices of Users, Groups etc, from this location (My computer name) then I need to enter the 'Object' names to select. I do not have a clue what this means, there are examples but I am not sure what object I need to find/enter.

Anyone got a clue as to what the reason for the denied message is?
My System SpecsSystem Spec

 Trying to copy txt file in Notepad. "Notepad: Access is denied"

Thread Tools

Similar help and support threads
Thread Forum
Access Denied to Transparent Notepad?
Hey guys. I use this program called Transparent Notepad to view txt and rtf documents. I can't, however, set it as a default program. If I try to do it through the default programs manager it doesnt show it as an option and if i navigate to it it will select it in the explorer window but it...
I can't copy a file - "Access Denied"
I have Cygwin installed on my Windows 7 machine but it seems there is a problem with the permissions on the Cygwin folder because it doesn't allow me to copy any files to it, i get "access denied" every time i try. I tried to change the permissions from the folder properties but it doesn't allow me...
General Discussion
Notepad's "text copy" behaviour
Hello! In Windows XP, if I had a web link saved in a text form in Notepad and wanted to mark it and then copy into a web browser it was very easy: double-click, copy, paste and it's done. In Windows 7 the Notepad acts differently when I double-click a link: if a link has "?" or "-" marks in...
General Discussion
Error message when I replaces "notepad.exe" by "notepad++.exe"
Hi, I folow this tutorial: How To Replace Notepad in Windows 7 - How-To Geek After, when I started the "notepad.exe" (notepad++ executable) from C:\Windows the error below appears:
General Discussion
Notepad and File Folder crash when I press "Ctrl".
When I using "Ctrl+C" and "Ctrl+V" to copy, paste sth in notepad, the file folder and notepad will crash. The task bar will disappear and recovery in several seconds. But it works fine after I reboot the computer. Does anyone know the reason? Thanks.
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:13.
Twitter Facebook Google+