Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: General weirdness!

28 Dec 2011   #1

Vista Home Premium 32bit
General weirdness!

Sorry about the les-than-informative topic - but it is actually the best description I can think of. I have a Windows 7 64-bit setup installed clean on an ASUS Maximus IV Gene Z motherboard (with the latest BIOS), the hard drive is an OCZ RevoDrive Hybrid. Here are some of the strange behaviours I observe.

The machine boots with an active application (Garmin's ANT manager - not the background service reported on the right-hand side of the task bar but an actual desktop/minimized icon) which is not to be found in the startup group - I have to either kill it or just leave it be (it is minimized so it doesn't bother me much). Interestingly a previous install of Windows 7 on a different machine - and with a different SSD setup from OZC - did the same, but with a different application - that time it was Textpad and it opened expanded.

The display card is a Sapphire HD 6870. The Screen Resolution tab on the right-click desktop popup insists that the screen is set to 1920 x 1080 when in fact it is at the monitor's maximum resolution of 1920 x 1200. I can change the resolution to the correct value but the only change is that circles stop being ovals (as they are while the screen is wrongly reported). After the next boot everything is back where I started - screen is reported at 1920 x 1080 while being 1920 x 1200 and circles are back to being ovals.

Speaking of rebooting, I can't get the system to shut down properly, it keeps the power light on, turn on the "sleep" light (a feature of the case I am using - definitely a suspect in this part of the whodunnit) and stays there until I press the power button - which causes a reboot. I have checked all the "power management" options in device manager and set the power button (though it isn't really involved - I use a software shutdown command) to do a proper shutdown.

I can't help suspecting that the registry is involved in all this - but hesitate to grab a registry cleaner of doubtful usefulness - not to speak of the risk of it making matters even worse.

Does anyone have any ideas?



My System SpecsSystem Spec
28 Dec 2011   #2

Vista Home Premium 32bit
Update ...

... which nobody will believe, most likely :-)

Disconnecting a front-panel USB 3.0 port and a 4-port internal Sharkoon USB 3.0 hub from the motherboard USB 3.0 header caused the resolution to become correct at 1900 x 1200.

The Garmin program still loads as if it were in the startup group ...

Next I will try to shut down the computer and see if that works!

My System SpecsSystem Spec
28 Dec 2011   #3

Vista Home Premium 32bit
Update 2

Yes, the shutdown problem evaporated as well. Next I need to figure out whether it was the Sharkoon USB 3.0 hub or the front panel USB port built into my CoolerMaster case that was the culprit ...

My System SpecsSystem Spec

28 Dec 2011   #4

Win 7 Pro x64

Have you tried killing the Garmin service? Start \ then type msconfig in the search window. Go to the 'startup' tab and uncheck the program if its there.
My System SpecsSystem Spec
28 Dec 2011   #5

Vista Home Premium 32bit
It was neither ...

This beggars belief!

Both the built-in USB 3.0 front panel port and the USB 3.0 hub are designed to plug into rear-mounted USB ports. Since my motherboard has an on-board dual-port header I purchased an "external to internal adapter cable" from Amazon, the product is made by Silverstone (see here).

Just plugging in this (one would think) electrically neutral cable (connected to NOTHING) is enough to cause my system to mis-report the screen resolution as 1920 x 1080 instead of the correct 1920 x 1200!

Who would believe something so silly? I wouldn't if I hadn't seen it with my own eyes. As it happens I had bought two of these cables, I have tried both with identical results.

I guess all that remains is to try plugging both USB 3.0 devices into back-panel USB 3.0 ports to see what happens (I suspect the hub WILL interfere with shutting down the computer - but let's see!).

@ACR731, no, I hadn't tried that - but I will once my USB 3.0 adventure has run its course :-)

My System SpecsSystem Spec
28 Dec 2011   #6


Check for updated USB3 drivers. There are so many USB3 bugs emerging, which is why I'd still far rather use eSata personally.
My System SpecsSystem Spec
28 Dec 2011   #7

Vista Home Premium 32bit
Back to square one ...

Quote   Quote: Originally Posted by ACR731 View Post
Have you tried killing the Garmin service? Start \ then type msconfig in the search window. Go to the 'startup' tab and uncheck the program if its there.
OK, that solved the problem of the Agent showing up minimized - but presumably also prevents it being there when I plug in my ANT+ stick. Well, I'll sort that out when I need to.

My resolution problem seems a bit more complicated than I thought - it returned even with no USB 3.0 devices plugged in :-(

The machine actually switches to 1920 x 1080 just after it presents the login screen, you can see the little portraits change shape ....
My System SpecsSystem Spec

 General weirdness!

Thread Tools

Similar help and support threads
Thread Forum
Battery weirdness
Hi I'm having some weird issues with my battery. No idea why is this or what should I do... So lets see. I charge it to 100% and disconnect the charger. Then it starts to drain, but sometimes the indicator does not move at all. It stays on 100% even after 20 mins. Sometimes it moves as...
Hardware & Devices
Some general weirdness with Windows Explorer, etc
I have been experiencing some general weirdness with my windows lately, here are some issues.... a) If I click on 'New Updates Available', it doesn't open up Windows Update like it should b) The same can be said about my notifications to open 'Action Center' c) When I do a windows search,...
General Discussion
Taskbar weirdness.
What's with the Ghosts? See "behind" Fallout: New Vegas pinned icon (first one on the left) there's a ghost of Firefox's icon that is no longer pinned, or even installed to the computer for that matter. And this is just one example. Twice my system froze...
General Discussion
BSOD 124 and other weirdness
i have a new computer (i7 930 system running windows 7 64bit, 5770 xxx graphics card) i am not overclocked and I got this error from running the far cry 2 benchmark overnight (although viewing the timestamp reveals it happened 20 minutes after it started. i have been able to run memtest86+ and...
BSOD Help and Support
wifi weirdness
G60 win7 - can get online wired no worries, wireless gets weird; I can see my home network and enter my password but cannot connect to it. I can see random unsecured networks and connect to them fine but no internet. My home network runs perfectly well with other laptops and macbooks. ...
Network & Sharing
Activation Weirdness
I got a hold of an older LGA 775 Intel chip 3.0 gig old school single core P4... Wanted to sell it on eBay but thought I should check it to see if it works on this motherboard... The specs said it would so I swapped out my dual core E8400 with this older chip... Ran into some problems with...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App