Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Autoplay/autorun not working

09 Jan 2012   #1

Windows 7 home premium 64 bit
Autoplay/autorun not working

Running W7 Home Premium. When I insert an SD card into into SD reader on PC tower nothing happens. The light next to the reader comes on indicating it recognizes that I inserted an SD card but nothing else happens, no pop up drive/folder, or any other notice from the OS that I had inserted an SD card. I go to Start/Computer and there is nothing listed. The same applies when I use a USB port.

I have the box checked for "Use Autoplay for all media and devices" in Autoplay....but nothing comes up.

I guess Microsoft had to "improve" a simple function that worked all the time to something that doesnt work at all.

My System SpecsSystem Spec
09 Jan 2012   #2

Windows 7 home premium 64 bit

Actually I think this is a Sandisk driver problem, so my bad, sorry
My System SpecsSystem Spec
28 Jul 2013   #3


Your issue is Auto Play and I as well as a couple ITs and known us can fix it using Windows 7. I can find tons on any other OS but no 7 home premium. Please help!
My System SpecsSystem Spec


 Autoplay/autorun not working

Thread Tools

Similar help and support threads
Thread Forum
What is AutoRun and AutoPlay
When I plug my USB in Windows 7 a Auto Play window appear that ask for General Options like (open folder to view files etc. ) but in Windows XP my USB directly open. Why.I want to Turn Off Auto run feature in Windows XP,How I can do this. On Some blog i find whenever USB is directly open...
General Discussion
Autorun not working when CD/DVD in drive
Hi all, I have an Alienware M17x (for over a year now) and all of a sudden I have a problem with my DVD drive. Whenever I insert a CD/DVD, nothing happens. But when I go to My Computer, I see the name of the DVD and when I double click it, I get access to the files. The problem is the autorun....
Hardware & Devices
Autorun\Autoplay doesnt working
Please God give me strength! I have more hours invested in debugging Windows 7 64 bit than every other OS I've ever used combined. When i'm insert a disk or a disk on key i dont have the run setup.exe!!! i tried the sfc /scannow and its still dont working! PLEASE HELP ME PLEASEEE Thanks! ...
General Discussion
Autorun not working
Please God give me strength! I have more hours invested in debugging W7 64 bit than every other OS I've ever used combined. With that little rant said, let me ask, what on earth do I have to do to have a disk I insert into my optical drive autorun? I have gone to Hardware & Sound/Autoplay and...
General Discussion
Hiding Autoplay dialog from Autorun.inf
How can I hide the Autoplay dialog from the autorun.inf file? I have a USB with two partitions: A bootable linux partition (recognized as a fake CD drive by windows) and the normal "Removable disk" partition, where I can store my files. When I plug in my USB into any computer, I get two...
autorun/autoplay problem
Hi. I have a problem with CD/DVD ROM autorun. when I insert a disc in CD/DVD ROM,The autorun or autoplay doesn't work. how can i repair this problem? thanks
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:49.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App